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Drawing Arcs
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Editing Objects
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Arranging Objects
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Object Attributes
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Palette Editor
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Outline Styles
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Special Effects
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Color Control

Adjusting Brightness and Contrast
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Keyboard Shortcuts
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Tools
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View Menu



Pop-up Tools

More drawing tools are provided than can be visible in the drawing tool at one time, so the program 
provides special pop-up tools. When you press and hold the mouse button down on a drawing tool 
(except the pointer tool), a pop-up tool palette will appear containing additional drawing tools.

To select a tool from the pop-up tool palette

Press and hold the mouse button down on the drawing tool until the pop-up tool palette appears. Drag the
pointer tool to the desired tool and release the mouse button. The selected tool will now become visible in
the drawing tool palette.



Page Size

HiJaak Draw offers various paper sizes, ranging from standard North American paper sizes (A to E) and 
standard Metric paper sizes (A0 to A4), to custom paper sizes that you specify.
To use a custom paper size, you need to specify the paper size inside the Page Setup dialog box. The 
maximum paper size that you can use is 99" by 99".
Only the area of the artwork inside the border of the artwork page will be printed. The area outside the 
border, called the Paste Board, can be used as a storage area.
If your printer does not support a certain paper size, HiJaak Draw provides tiling. When the sheets are 
combined they will create the entire image. To use the tiling option, you need to enable the option inside 
the Page Setup dialog box. 

To set the page size

1. Choose the Page Setup... command from the File menu.
The Page Setup dialog box will appear.

2. Specify the page size inside the Size box by choosing one of the standard sizes from the Size 
combo box or by entering the appropriate measurements in the Height and Width fields.

3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Page Margins
Page Orientation
Page Panels



Page Setup Dialog Box

Size Combo Box: From the Size Combo Box you choose one of the standard North American or Metric 
paper. Selecting the Custom radio button tells the program that you want to use your own paper size that 
you specify inside the Width and Height fields.
The Width and Height fields: Inside these fields you enter the size of your own Custom paper size.
Orientation Box: Inside this box you select the Portrait or Landscape radio button to specify the page 
orientation.
Top, Left, Bottom, and Right fields: Inside these fields you enter the size of the top, left, bottom, and 
right margins.
Horizontal, and Vertical fields: Inside these fields you enter the number of panels in the horizontal and 
vertical directions.
Overlap fields: Inside these fields you enter the amount of overlap between adjacent horizontal and 
vertical panels, in the desired units.
The Column Guides button: Clicking on this button brings up the Guides dialog box that lets you specify
column settings. 



Page Orientation

You can orient the artwork page such that its longest side is either vertical or horizontal. Drawings that are
wider than they are tall are referred to as landscapes, while drawings that are taller than they are wide are
called portraits.
The page orientation is set inside the Page Setup dialog box.

To set the page orientation

1. Choose the Page Setup... command from the File menu.
The Page Setup dialog box will appear.

2. Specify the page orientation inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Page Margins
Page Panels
Page Size



Page Margins

You can also set the top, left, bottom, and right page margins inside the Page Setup dialog box. Printers 
generally cannot print to the edge of the paper, so these margins should reflect the unprintable portion of 
your page.

To set the page margins

1. Choose the Page Setup... command from the File menu.
 The Page Setup dialog box will appear.

2. Specify the page margins inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Page Orientation
Page Panels
Page Size



Page Panels

Panels are useful for pamphlets that consist of a single sheet of paper that is folded in several places. 
Each face of the pamphlet can be set up as a panel with its own set of margins.
In the case of an illustration that spans across several facing pages, each page can be set up as an 
individual panel with an amount of overlap between adjacent pages. When you overlap the sheets they 
will form the entire illustration.
You can specify panels in the horizontal direction, vertical direction, or a combination of the two.
Each panel will have margins. Panel margins are set in the Margin box of this dialog box. You can also 
overlap panels so that a portion of the artwork will print on both adjacent panels. Each panel will be the 
size specified as the page size.

To set the page panels

1. Choose the Page Setup... command from the File menu.
The Page Setup dialog box will appear.

2. Specify the page panel parameters inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Page Margins
Page Orientation
Page Size



Page Setup -- Column Guides

You can set column guides from the Page Setup dialog box. You can also specify column guides at any 
time by selecting the Guides... command from the View menu and then specifying the column parameters
inside the Guides dialog box.

To set page columns

1. Choose the Page Setup... command from the File menu.
The Page Setup dialog box will appear.

2. Specify the column guide parameters in the Guides dialog box. 
3. Clock on OK, or press [ENTER] when you are finished.

Related Topics:
Column Guides
Page Panels



Drawing Angle

Initially, the drawing angle is at zero degrees, meaning that the X and Y axes are parallel to the horizontal 
and vertical sides of the document window. HiJaak Draw allows you to rotate the drawing angle, and 
therefore change the X and Y axes of the artwork.
Any objects that you draw, such as rectangles, and ellipses, will be drawn at the current drawing angle. 
Once you have changed the drawing angle, use the [SHIFT] key to apply a 45-degree constraint to any 
drawing reshaping or transforming actions. The angles are constrained at 45 degrees relative to the new 
drawing angle. When you transform objects the operations are performed relative to the current drawing 
angle.
There are two methods of specifying a new drawing angle:

You can specify the new drawing angle numerically, by entering the new drawing angle inside the 
Drawing Angle dialog box.

You can specify the new drawing angle on the drawing itself.

To numerically set the drawing angle

1. Choose the Drawing Angle... command from the View menu.
The Drawing Angle dialog box will appear.

2. Specify the angle by dragging the dial or entering the angle in the field
3. Click on OK, or press [ENTER] when you are finished.

To set the drawing angle on the drawing itself

1. Choose the Drawing Angle... command from the View menu.
The Drawing Angle dialog box will appear.

2. Select the Specify on drawing checkbox.
3. Click on OK, or press [ENTER] when you are finished.
4. Position the pointer on the artwork, press and hold the mouse button down, and drag out a line that

specifies the new drawing angle.
The slope of the line will become the new drawing angle.

You can use any of the precision positioning tools to help you specify the drawing angle.



Drawing Angle Dialog Box

The Angle field: Inside this field you can specify the drawing angle by entering the angle value in 
degrees.
The Angle Dial: You can drag the dial in a clockwise or counterclockwise direction to specify the drawing 
angle.
The Specify on drawing checkbox: Selecting this checkbox tells the program that you want to specify 
the drawing angle on the drawing itself.



Creating New Documents

You can create a new document by choosing the New... command from the File menu. When you create 
a new document, you have two options:

You can clear the existing artwork.
You can open a new window.

To create a new document

1. Choose the New... command from the File menu, or press [CTRL][N].
Inside the New Drawing dialog box, you can click on the Clear button to simply clear the existing 
artwork, or the New button to open a new window. Clicking on the Cancel button will not create a 
new document, and will return you to the current artwork.

If you choose click on the New button without saving your artwork first, you will be asked if you want to 
save the current file.



Open Drawing Dialog Box

The Files List Box: Inside this list box you will see a list of all the HiJaak Draw files inside the current 
directory. You can double-click on the filename in the list box to quickly open the file or select the filename
and then click on the Open button to open the file.
The Sow Backup Files checkbox: Enabling this checkbox will include all backup files in the current 
directory, that were generated when you saved, this includes backup files made by the Automatic Timed 
Save option if you have this option enabled in the Preferences dialog box. Enabling this checkbox allows 
you to open any existing version of a file.
The Directories List Box: Inside this list box you will see a list of the directories on the current path.
The Drive combo box: From this combo box you choose the desired drive.
The Filename field: Inside this field you can enter the path and the name of the document that you want 
to open.
The Preview Box: The preview box displays a preview of the artwork that you have selected from the 
Files List Box.
The Show Preview checkbox: Selecting this checkbox tells the program to show a preview of the 
selected file.
The Description field: The description field displays any text that you entered in the description field 
when you save your artwork during your previous work session.
The Open button: Clicking on this button will open the file selected in the Files List Box.
The Find... button: Clicking on this button brings up the Find File dialog box that lets you search for the 
file that you want to open. It is useful in situations where you can not locate the file that you want to open.



Opening Existing Documents

You can open existing HiJaak Draw documents or artworks by choosing the Open... command from the 
File menu and then choosing the document to be opened from the Open Drawing File     dialog box  .

To open an existing document

1. Choose the Open... command from the File menu, or press [CTRL][O].
The Open Drawing File dialog box will appear.

2. Select the file you want to open and click on OPEN. 
If you do not know where the drawing file is located, click on Find... to bring up the Find File Dialog Box.

Related Topics:
Opening a Copy of a Document



The Find File Dialog Box

The Find File dialog box will appear when you click the mouse button on the Find... button inside the 
Open Drawing File dialog box. You can use this dialog box to locate files anywhere on your hard drive.
The Search Pattern field: Inside this field you enter the string of characters to be located.
The Clear List button: Clicking on this button clears the list of found files.
The Drives to Search List Box: Inside this list box you select the drives to search. To select the drives, 
you simply click the mouse button on the drive inside the Drives List Box.
The Files Found List Box: Inside this list box you will see a list of all the files found that match the 
specified search pattern. You can click on the Clear List button to clear this list box. Click on a file from the
found file list, and then on OK to update the path.
The All Drives button: Clicking on this button tells the program to search all drives.
The Find button: Clicking on this button tells the program to start the search of the selected drives, 
according to the search pattern specified. All the files that match the search pattern, will be listed inside 
the Files Found List Box.

Related Topics:
Opening a Copy of a Document
Opening Existing Documents



Opening a Copy of a Document

You may not want to open the original artwork, but rather a copy of the document. This will leave the 
original document untouched. To do this, you choose the Open Copy... command from the File menu. 
Then choose the file that you want to open as a copy inside the Open Copy Of Drawing dialog box. This 
dialog box is identical to the Open Drawing dialog box.

Related Topics:
Find File Dialog Box
Opening Existing Documents



Saving Artwork
When you save your artwork, the current version of the artwork is saved and you can continue working on
it. You should save your artwork frequently so that you do not lose it if you encounter a power failure or 
system error.

To save your artwork

1. Choose the Save command from the File menu, or press [CTRL][S].
If you are saving the artwork for the first time, the Save Drawing File dialog box will appear. This 
dialog box asks you to specify the name of the document and the directory where the artwork is to 
be saved.

2. If this dialog box appears, enter a the filename to save the drawing under, and click on SAVE.

Related Topics:
Automatic Timed Save
Saving Copies of Artwork



The Save Drawing File Dialog Box

The Filename field: Inside this field you enter the name of the file to be saved. You can also specify the 
path and filename inside this field instead of specifying the path inside the Directories List Box.
The Make backup checkbox: Selecting this checkbox tells the program to make a backup file when it 
saves the artwork. The backup file will have the same filename as the original with the extension PD~.
The Preview combo box: From the preview box you can choose the type of preview to be saved. You 
have the choice of three previews: No Preview, B/W Preview, and Color Preview.
The Description field: Inside this field you enter a text description of the file. You do not have to type 
anything in this field. This field is useful for adding a detailed description about the file.
The Files List Box: Inside this list box you will see a list of all HiJaak Draw files contained in the current 
directory.
The Directories List Box: Inside this list box you will see a list of all directories contained on the selected
drive. You select a new directory by clicking the mouse button on the desired directory inside the list box.
The Drives combo box: From this combo box you select the drive on which you want to save the file. 
The Directories List Box will show the names of all the directories contained on the currently selected 
drive.
The Save button: Clicking on this button tells the program to save the artwork.



Saving Copies of Artwork

At times you may want to save a copy of the currently opened artwork under a new name. To do this, you 
choose the Save As... command, and then specify the name of the file and path inside the Save Drawing 
File dialog box. When you save a copy, the original artwork will be unaffected.



Correcting Mistakes 

You can use the Undo command, located inside the Edit menu, or [CTRL][Z] or [ALT][Delete] to correct 
mistakes while you are creating your artwork. When you choose the Undo command the last operation 
that you performed is undone and your artwork is restored to the way it was prior to the operation. 
You must choose the Undo command prior to performing another operation. For operations that cannot 
be undone, the Undo command will be grayed out inside the Edit menu. 
NOTE: The Undo command will only undo the last operation performed. Selecting the Undo command 
twice in a row will undo the Undo, meaning the operation will be re-applied. 



Exiting HiJaak Draw

To leave the HiJaak Draw program, you choose the Exit command from the File menu, or press [CTRL]
[Q], or [ALT][F4].
If you have not saved the artwork that you were working on, the program will ask you if you wish to save 
the current artwork.



Magnification of Artwork

HiJaak Draw provides variable magnification levels for creating detailed drawings. Increasing the 
magnification level allows you to see more details of your artwork, while decreasing the magnification 
allows you to see more of the entire artwork.
The HiJaak Draw program provides several methods for changing the magnification of your artwork:

The Zoom-in and Zoom-out tools, found inside the transformation palette, let you magnify and 
reduce your artwork.
The Normal View (100%  )  , Show Entire Page, Show All Objects  , and Full Screen menu commands 
are found inside the View menu. They let you instantly change to specific magnifications of your 
artwork.
The Zoom Scale, enabled by clicking on the status bar to the right of the transformation palette. It 
allows you to select an approximate scale quickly.
The magnification shortcuts, [CTRL] right mouse button click for zoom-in and [SHIFT][CTRL] right 
mouse button click for zoom-out, let you change the magnification by a factor of 2, while you are 
performing other operations.

If you are working in the normal Outline mode, the magnification level does not affect the line thickness of 
the object outlines. However, if you have the Outline Only with Line Width enabled, then the outline 
thicknesses will be adjusted to reflect the current magnification level.
In the Preview mode, the line thickness of the object outlines will always be adjusted to reflect the current 
magnification level.



Magnification Shortcuts

You can use the right mouse button to zoom-in and zoom-out while you are performing other operations 
such as drawing, reshaping, and transforming.
To quickly zoom-in two times, hold down the [CTRL] key while clicking the right mouse button.
To quickly zoom-out two times, you hold down the [CTRL] and [SHIFT] keys while clicking the right mouse
button.
 The location where you click the mouse button will become the center of the document window.

Related Topics:
Magnification Commands
Zoom-in tool
Zoom-out tool
Zoom Scale



Magnification Commands

The Normal View (100%) command, or pressing [CTRL][1], adjusts the current magnification level so that
the artwork is shown at its actual size.
The Show Entire Page command, or pressing [CTRL][2], adjusts the current magnification level so that 
the entire artwork page is visible inside the document window.
The Show All Objects command, or pressing [CTRL][3], adjusts the current magnification level so that all
of the objects in the artwork, both on the page and off of it, are visible inside the document window.

Related Topics:
Magnification Shortcuts
Zoom-in tool
Zoom-out tool
Zoom Scale



Zoom-in Tool

Using the Zoom-in tool, located inside the transformation palette, you can magnify your artwork up to a 
maximum size of 3200 percent -- 32 times its Actual size.
There are two methods of using the Zoom-in tool to magnify portions of your artwork:

You can position the zoom rectangle over objects in your artwork and click the mouse button to 
zoom-in two times.

You can perform a variable zoom by dragging out a new zoom rectangle to enclose only the 
objects that you want to see on the screen. The enclosed objects will be enlarged such that they 
occupy the entire document window.
Using the Zoom-in tool does not affect the size or shape of the objects in the artwork. 

To zoom-in two times

1. Select the Zoom-in tool.
As you move back onto the artwork, a zoom rectangle will appear. The pointer changes to a 
magnifying glass containing a plus sign, and is located at the center of the rectangle.

2. Position the zoom rectangle over the portion of the artwork that you wish to magnify.
The area of the artwork that falls inside the zoom rectangle will be magnified.

3. Click the mouse button to zoom-in two times.
The objects inside the zoom rectangle will be magnified two times and the zoom rectangle will 
disappear.

If you wish to zoom-in again, select the Zoom-in tool and repeat the above steps. You can magnify the 
artwork up to a maximum of 32 times the drawings actual size.

To perform a variable zoom

1. Select the Zoom-in tool.
As you move back onto the artwork, a zoom rectangle will appear and a magnifying glass with a 
plus sign will be located at its center.

2. Position the magnifying glass over the center of the portion of the artwork that you wish to magnify.
3. Drag out a new zoom rectangle from its center, until it encloses all of the objects that you want to 

magnify.
Holding the [CTRL] key down lets you drag out the zoom rectangle from a corner.

4. Release the mouse button when the zoom rectangle encloses all of the desired objects.
The enclosed objects are enlarged so that they occupy the entire document window.

If you wish to perform another variable zoom, select the zoom-in tool again and repeat the above steps.
NOTE: If you zoom-out immediately following the variable zoom, the artwork will be returned to the size it 
was before you performed the variable zoom.

Related Topics:
Magnification Commands
Magnification Shortcuts
Zoom-out tool
Zoom Scale



Zoom-out Tool

The Zoom-out tool, located inside the transformation palette, lets you reduce your artwork to a minimum 
size of 3 percent -- 32 times smaller than its original size.
To use the Zoom-out tool, you simply position the magnifying glass at the location where you want to 
zoom-out and click the mouse button to zoom-out two times.

To zoom-out two times

1. Select the Zoom-out tool.
As you move back onto the artwork, the pointer changes to a magnifying glass with a minus sign at 
its center.

2. Position the magnifying glass at the center of the area you want to zoom-out.
3. Click the mouse button to zoom-out two times.

You can click the mouse button again to reduce the artwork another two times. Every time you click 
the mouse button, the artwork will be reduced by another factor of two, down to a minimum size of 
3 percent.

The location where you clicked the mouse button will become the new center of your document window 
when the screen is redrawn.
NOTE: If you zoom-out immediately following the variable zoom, the artwork will be returned to the size it 
was before you performed the variable zoom.

Related Topics:
Magnification Commands
Magnification Shortcuts
Zoom-in tool
Zoom Scale



Status Bars

HiJaak Draw provides three status bars that display information on the type of tool that is currently 
selected, the location of the pointer in x and y coordinates, the current zoom level, and the current display
mode that is being used.
The status bar located beside the transformation palette, displays the current magnification of the artwork,
and the display mode currently selected. Clicking on this status bar brings up the Zoom Scale, allowing 
you to quickly zoom-in to approximate magnifications.
The status bar located at the bottom of the document window displays the pointer's X and Y co-ordinates 
when the pointer is located within the document window. When you are performing a drawing action, the 
status bar also displays the drawing angle, the length of the line being drawn, and the distance the pointer
currently is from the X and Y co-ordinates of the drawing action's last specified point. This status bar also 
displays the number of objects that are selected within the document window. When the Pointer tool or 
one of the Marquee tools is selected, it will also display the fill type, line width, and line and fill colors.    
Double clicking on this status bar will enlarge it so that it also displays the name of the line and solid fill 
colors.
The third status bar, located at the bottom of the HiJaak Draw window, displays tool information. When 
the cursor is within the document window the cursor displays the currently selected tool and modifier. 
When the pointer is moved over one of the tool palettes, this status bar will also display the name of the 
tool the pointer is on top of. The status bar also gives instructions for using some parts of the screen 
when the pointer is on top of them.
NOTE: Two asterisks "**" following a tool name in the third status bar indicate that when you double-click 
on that tool a dialog box will appear.

Related Topics:
Show Current Cursor Position
Zoom Scale



Scrolling the Artwork

HiJaak Draw provides two techniques for viewing different areas of your artwork:
The scroll bars let you scroll the artwork in the horizontal or vertical direction.
The Hand tool appears when you press the right mouse button, and lets you scroll the artwork in any 

direction.
You can use the scroll bars or Hand tool to scroll the artwork at any time during your work session. The 
scroll bars work in the same way as the scroll bars of any other Microsoft Windows programs. For more 
information on how to use the scroll bars, please refer to your Microsoft Windows manual.
You can also turn off the scroll bars at any time. 

To scroll using the Hand tool

1. Press and hold the right mouse button down to activate the Hand tool.
The pointer changes to a hand.

2. Drag the hand in the direction you are that you want to scroll, as if you were pushing the paper in 
that direction.

3. Release the right mouse button when you are finished scrolling.



Displaying Artwork

The primary display mode is the Preview mode. The Preview mode is the most detailed display method, 
showing all of the object attributes.
However, working in the Preview mode slows down the screen redraw. For this reason, HiJaak Draw 
allows you to work in the Outline mode in which only the object outlines are visible. In this mode, the 
screen redraw is much faster.
You can work in both full Preview mode or Outline mode. You can draw, reshape and transform objects in 
either of the two modes.
While you are working in Preview mode you can choose to have certain objects in your artwork displayed 
in outline mode, while the rest remain in Preview mode. To do this, you simply select the desired objects 
and then choose the Preview Options/Outline Only command from the View menu.



Outline Mode

The Outline mode is enabled by choosing the Preview Options/Outline Only command from the View 
menu, or by pressing [F9]. The Outline Only command toggles the display between full Preview mode or 
Outline mode.
When working in the Outline mode, you also have the option of displaying the actual outline thickness of 
the objects, by choosing the Outline Only with Line Width command from the View menu, or by pressing 
[F9]. In normal Outline mode, all of the objects have the same outline thickness and their actual outline 
thickness is not shown.

To display the entire artwork to Outline mode

1. Choose the Preview Options/Outline Only command from the View menu, or press [F9].
You can choose the Outline Only with Line Widths command or press [CTRL][F9], to display the 
actual line thickness of the objects.

To display only selected objects in Outline mode

1. Select the objects that you want to display in Outline mode.
2. Choose the Preview Options/Outline Only command from the View menu, or press [F9].

The screen is redrawn to display the selected objects in the Outline mode.
You can choose the Outline Only with Line Widths command or press [CTRL][F9], to display the actual 
line thickness of the selected objects.
A checkmark will appear next to the Outline Only command in the View menu, indicating that the Outline 
mode is currently enabled.



The Full Screen Preview

The Preview Options/Full Screen Preview command found inside the View menu, or pressing [SHIFT]
[F9],hides the preview window, menus and tools. This allows you to previews your artwork with all of its 
attributes without showing the program window's menus or tool palettes. The size of the artwork page is 
adjusted so that it occupies the entire screen.
Clicking the mouse button while in Full Screen Preview will bring up a menu of viewing commands. This 
menu contains the following options:

Normal View (100%) -- Shows the actual size of the artwork while still in Full Screen Preview.
Show Entire Page -- Shows the Entire page while still in Full Screen Preview.
Show All Objects -- Shows the entire page in while still in Full Screen Preview.
Show Page Border -- Toggles the display of the page border on and off while still in Full Screen 
Preview.
Last Page -- Goes to the last page of the document and displays it is Full Screen Preview.
Next Page -- Goes to the next page of the document and displays it in Full Screen Preview.
Goto Page -- Brings up a dialog box that allows you to specify what page you want to display in 
Full Screen Preview.
Exit (Full Screen) -- Returns you to the HiJaak Draw window.

The right mouse button allows you to scroll around the page, and zoom in  and out the same as it does in 
the HiJaak Draw window.

To see a full screen preview

1. Choose the Preview Options/Full Screen Preview command from the View menu, or press [SHIFT]
[F9].
The artwork is displayed across the entire screen of your monitor.

2. To exit, click the mouse button anywhere, and choose Exit (Full Screen) from the menu that 
appears.



Interruptable Redraw

HiJaak Draw provides an interruptable redraw that allows you to choose a menu command in the middle 
of a screen redraw. The redraw is stopped, allowing you to finish executing your command.
To enable the interruptable redraw, choose the Interruptable Redraw command from the View menu. 
When the interruptable redraw is enabled, a checkmark appears beside the command inside the View 
menu. The Interruptable Redraw command is a toggle command that switches the interruptable redraw 
on and off.
When you interrupt the redraw to execute a command, there will be portions of your artwork that have not 
been redrawn. You can refresh the display causing the entire artwork to be redrawn again.

To enable the interruptable redraw

1. Choose the Interruptable Redraw command from the View menu.
A checkmark will appear next to the Interruptable Redraw command in the View menu, indicating 
that the interruptable redraw is currently enabled.

Related Topics:
Refreshing the Screen



Refreshing the Screen

When you use the interruptable redraw you will encounter situations where you will need to refresh the 
entire display of your artwork. When you refresh the display, the entire artwork will be redrawn.
To refresh the display, choose the Refresh Screen command from the View menu, or press [CTRL][4].

To refresh the display

1. Choose the Refresh Screen command from the View menu or press [CTRL][4].
The display is redrawn.

Related Topics:
Interruptable Redraw



Color Dithering

If you have a 256 color system you can use color dithering to preserve the allocation of colors. Since you 
have only 256 colors available, you will not be able to show more than 256 colors as solid colors on the 
screen. HiJaak Draw allows you to dither the screen representation of all colors, the color bar, and/or the 
graduated fills. This allows you to show the colors used in your artwork as solids, while still retaining the 
full range of colors in the palette.
The Color Dithering command will only be enabled on a 256 color machine.

To set color dithering

1. Choose Color Dithering from the View menu.
The Color Dithering submenu appears containing 3 options:

Dither Colors: Dithers all colors within the HiJaak Draw window.
Dither Graduated Fills: Dithers the colors within graduated fills.
Dither Color Bar: Dithers the colors displayed in the color bar.

These are all toggle commands. You will only be able to choose the Dither Graduated Fills and 
Dither Color Bar commands if the Dither Colors command is not enabled.

2. Select the dithering commands you want, and release the mouse button.



Layers

Each layer can be thought of as an individual transparency that, when stacked on top of each other, 
create the entire artwork. By organizing your artwork on layers, you can isolate portions of your drawing 
while you are working on it. Layers are especially useful for technical illustrations and design work. For 
example, you can organize an architectural drawing in a number of layers, such as, one layer for the floor 
plan, another for the wiring, and a third for the plumbing layout. Another use for layers is to load bitmaps 
or clip art into lower layers as a template.
HiJaak Draw allows you an unlimited number of layers in your artwork, and you can give each layer a 
name for your reference.
The layer that you are drawing is the current layer. You will only be able to see objects on all the layers 
below the current layer.
The current layer is displayed inside the Layers combo box in the upper right corner of your document 
window. Clicking on the Layers combo box displays a list of all the layers that are currently being used.
To the left of the Layers combo box is the Layers button. Clicking on this button will bring up the Layers 
menu. The commands in this menu allow you to bring up the Layer Manager, add more layers, hide any 
layer, rearrange layer order, and change layer colors. You can even gray out all lower layers.

Related Topics:
Display Object Outlines by Layer Colors
Moving Objects between Layers
Removing Layers



The Layers Combo Box

The layer order is shown inside the Layers combo box. The layers are listed from top to bottom with a 
checkmark next to the current layer, and the layer color displayed to the right of the layer name. Hidden 
layers will be grayed out and can not be selected.
To change the current layer, simply click on the desired layer from the list of layers inside the Layers 
combo box. The new layer will be displayed inside the Layers combo box, and it will have a checkmark 
beside it.



The Layers Menu

The Layers pop-up menu will appear when you click on the Layers button. The Layers button is located 
directly to the left of the Layers combo box.
From the Layers menu you can:

Choose the Layer... command to bring up the Layer Manager that lets you add a new layer, name 
the layers, hide several layers, delete layers, change the layer order and colors.
Insert new layers in your layer list.
Delete layers from your layer list.
Hide layers.
Show all the previously hidden layers.
Hide all layers below the current layer.
Gray out the layers below the current layer.
Display object outlines in corresponding layer colors (in Outline mode only).



The Layer Manager

Bring up the Layer Manager by choosing the Layer... command from the Layers pop-up menu. From the 
Layer Manager you can perform all the layer operations including: adding new layers to the layer list, 
changing the layer names, choosing a current layer, deleting and hiding any of the layers in the current 
layer list, rearranging the layer order, and assign new layer colors.
The Layer List Box: Inside this list box you will see a list of all the layers that are being used in your 
artwork. The list box will show the layer name, and the layer color to the right of the layer. The current 
layer will have a checkmark beside it in the list. To select layers click on their name inside the list box.
The Name field: This field shows the name of the selected layer, and you can rename the selected layer 
in this field.
The New button: Clicking on this button will add a new layer to the top of the layer list. The new layer will
initially be selected and given a default name. While it is selected you can enter a new layer name.
The Delete button: Clicking on the Delete button will delete the selected layer from the list box.
The Hide/Show button: Clicking on the Hide button will hide the selected layer in the list box. If the 
selected layer is currently hidden, this button will change to Show, and clicking on this button will show the
layer.
The Move Box: Clicking on the Up or Down buttons will move the selected layer, up or down one position
in the layer list. Clicking on the Top or Bottom buttons will move the selected layer to the top or bottom of 
the layer list.
The Colors Palette: Clicking on one of the color representations will change the color of the selected 
layer.



Inserting a Layer 

New layers can be inserted into the layer list by choosing the Insert Layer... command from the Layers 
pop-up menu. You specify the name of the layer, and its position in the layer list inside the New Layer 
dialog box.

To insert a new layer in the layer list

1. Choose the Insert Layer... command from the Layers pop-up menu.
The New Layer dialog box will appear.

2. Enter the name of the new layer inside the Name field.
3. Specify the position of the layer by selecting one of the position radio buttons.
4. Click on OK, or press [ENTER] when you are finished.

NOTE: If you want to specify a layer color, you need to bring up the Layer Manager, and then choose the 
new layer color.



New Layer Dialog Box

The Top Layer radio button: Selecting this radio button places the layer at the very top of the layer list.
The Bottom Layer radio button: Selecting this radio button places the layer at the bottom of the layer 
list.
The Above Current Layer radio button: Selecting this radio button places the new layer above the 
current layer.
The Below Current Layer radio button: Selecting this radio button places the new layer below the 
current layer.



Removing Layers 

You can use the Remove Layer command from the Layers pop-up menu to delete the current layer from 
the layer list. When you delete the current layer, the next visible layer beneath the current layer will 
become the current layer.
You can also delete any of the layers by using the Layer Manager.

To delete the current layer from the layer list

1. Choose the Remove Layer command from the Layers pop-up menu.
If the current layer has objects on it, the program will ask you whether you are sure that you want to
remove that layer.
The current layer will be deleted from the list, and the next visible layer down will become the new 
current layer.

NOTE: You can not undo a remove layer operation



Hiding and Showing Layers

You can use the Hide Layer command from the Layers pop-up menu to hide the current layer. The current
layer will be grayed out inside the layer list, and objects contained on this layer will no longer be visible.
You can also hide layers by using the Layer Manager. The Hide Layer command is a quick way of hiding 
the current layer.

To hide the current layer

1. Choose the Hide Layer command from the Layers pop-up menu.
The current layer will be grayed out in the layer list, and objects contained on this layer will no 
longer be visible.
The next lower visible layer will become the new current layer.

To show all layers

1. Choose the Show All Layers command from the Layers pop-up menu.
All the previously hidden layers will be visible again.

NOTE: To show individual hidden layers, you need to use the Layer Manager.



Hiding Layers Below the Current Layer

Using the Hide Lower Layers command from the Layers pop-up menu, you can hide all the layers below 
the current layer, and only the current layer will be visible. This feature is useful when you are working on 
a complex illustration, and want to hide some of the objects to unclutter your artwork.
When this option is enabled, a checkmark will appear beside the command inside the Layers pop-up 
menu. The Hide Lower Layers command is a toggle command.



Graying Out Layers 

Using the Gray Lower Layers command from the Layers pop-up menu, you can fade the objects on all the
layers below the current layer. When this option is enabled, a checkmark will appear beside the command
inside the Layers pop-up menu. The Gray Lower Layers command is a toggle command.



Displaying Object Outlines by Layer Colors

You can use the Use Layer Colors command from the Layers pop-up menu, to display the object outlines 
in their corresponding layer colors. This will only work in Outline mode. When this option is enabled, a 
checkmark will appear beside the command inside the Layers pop-up menu. The Use Layer Colors 
command is a toggle command.



Moving Objects Between Layers

HiJaak Draw provides two methods for moving objects between layers:
You can use the clipboard commands: Cut, Copy, Paste from the Edit menu. 
You can move the objects to the pasteboard, which is the area around the artwork page, and then 
change the current layer. Make sure that the objects are entirely off the artwork page. The objects 
on the paste board will remain usable on all layers.



Multiple Pages

HiJaak Draw provides multiple pages that you can use to organize your artwork. For example, you can 
use pages to create slide presentations, or multiple page brochures. Using multiple pages you can save 
these as a single document. Panels are pages that are placed side-by-side and you can specify the 
amount of overlap. They are useful for organizing your drawing as facing pages, or to take into account 
any folding that you will perform for brochures.
The page list will be displayed on the right side of the document window, provided that the Screen 
Layout/Show Page List command is selected from the View menu. The View/Screen Layout/Show Page 
List command turns the page list on and off.
The current page will be highlighted in the page list. Clicking on a different page icon will make that page 
the current page.
To the left of the Layers button is the Page button. Clicking on this button will bring up the Page pop-up 
menu. The commands in this menu allow you to flip through the pages, go to a specific page, insert 
additional pages, delete pages, add panels, and sort the pages.

Related Topics:
Page Menu



The Page Menu

The Page pop-up menu will appear when you click on the Page button. The Page button is located 
directly to the left of the Layers button.
From the Page pop-up menu you can:

Go to the previous page.
Go to the next page.
Go to a specific page.
Insert new pages.
Delete a range of pages.
Specify page panels.
Sort the pages with the Page Sorter.



Flipping Through the Pages

HiJaak Draw provides several methods for flipping through the pages:
You can click on a page icon to go to a specific page. If the number of pages is too large to be 
shown at once, you can use the scroll arrows at the top and bottom of the page list to show a 
different portion of the page list.
You can choose the Previous Page or Next Page commands from the Page pop-up menu to go to 
the previous or next page.
You can choose the Go To Page... command in the Page pop-up menu to specify the page number 
that you want.



Inserting Pages

Choose the Insert Pages... command from the Page pop-up menu to specify the number of pages to be 
inserted, and where the pages are to be inserted, inside the Insert Pages dialog box.



Insert Pages Dialog Box

The Insert field: Inside this field you enter the number of pages that you want to insert.
The Before Current Page radio button: Selecting this radio button tells the program to insert the pages 
before the current page.
The After Current Page radio button: Selecting this radio button tells the program to insert the pages 
before the current page.



Deleting Pages

You can use the Remove Pages... command from the Page pop-up menu to delete any number of pages 
from your page list. You specify the page or range of pages to be deleted inside the Remove Pages dialog
box.



Remove Pages Dialog Box

The Remove Pages field: Inside this field you enter the first page number of the range of pages that you 
want to delete.
The Through field: You enter the last page of the range of pages that you want to delete inside this field.



Specifying Page Panels

For each page, you can specify the number of horizontal and vertical page panels. Panels are specified 
by using the Panels... command from the Page pop-up menu. Each panel will be the size specified in the 
Page Size box of the Page Setup dialog box. 
The Panels... command will bring up the Number of Panels dialog box. The panel parameters that you 
enter here will override those that you have specified inside the Page Setup dialog box.

Related Topics:
Page Panels



The Number of Panels Dialog Box

The Panels Preview Box: The preview box will display the way that the panels will look according to the 
parameters that you specified inside the dialog box, and the dimensions of the final page. You can also 
click in the preview box and drag the preview to change the number of panels.
The Horizontal and Vertical fields: Inside these fields you enter the number of horizontal and vertical 
panels that you want on the page.
The Overlap fields: Inside these fields you enter the amount of horizontal and vertical overlap between 
adjacent panels.



Sorting Pages

You can use the Sort Pages... command, from the Page pop-up menu, to rearrange the pages in the page
list. For example, if you used pages for each slide in your slide presentation, then this will allow you to 
quickly reorganize you presentation.
Pages are sorted inside the Page Sorter dialog box. To sort or rearrange the pages, simply drag the 
pages to a new location. As you drag, a black bar indicates where the page will be inserted. Once you 
have finished sorting the pages, click on OK to make the changes, or on Cancel to ignore these changes.
You can use the scroll bars on the right of the Page Sorter dialog box to scroll through the entire page list.
Double-clicking on a page inside the dialog box will return you to the page clicked on as well as accepting
the changes that you have made.



Drawing Methods

Drawing methods are different procedures that you can use to draw the same object. As an example, you 
can draw circles by specifying a radius or diameter.
In certain situations, one drawing procedure will be more useful than another. In order to give you the 
greatest amount of flexibility and control while creating your artwork, some of the drawing tools have 
different drawing methods that allow you to draw the same object in different ways.
There are two ways to select drawing methods.

If the Method Button located underneath the drawing palette is visible, it shows the drawing method
currently selected to draw the object. Pressing the Method Button causes the Method Palette to 
appear to the right of the button, displaying all of the available drawing methods for the selected 
drawing tool. The Method Button appears with the Modifier     Palette   when View/Screen Layout/Show
Modifiers has a checkmark beside it.
After you have selected a drawing tool, you can press the right mouse button on the drawing tool, 
causing the Method Palette to pop-up directly to the right of the drawing tool.

If the Method Button becomes empty when you select a drawing tool, then the selected drawing tool has 
no alternative drawing methods available.

Choosing a different drawing method

1. Press and hold the left mouse button down on the Method Button or the right mouse button on the 
tool.
The Method Palette will appear to the right of the Method Button or tool.

2. Drag the pointer to the desired drawing method and release the mouse button on the desired 
method.

Related Topics:
Drawing Bezier Curves
Drawing Circles
Drawing Circular Arcs
Drawing Ellipses
Drawing Elliptical Arcs
Drawing Fillets
Drawing Freehand Curves
Drawing Gratings
Drawing Lines
Drawing Polygons
Drawing Rectangles
Drawing Regular Polygons and Stars
Drawing Spline Curves



Control Points

Control points are positions that determine the size and shape of objects. The different drawing methods 
allow you to specify different sets of control points to draw the object. 
Control points are placed when you click, double-click, press or release the mouse button during the 
drawing process.
You can use any of the precision positioning tools to help you specify control points at precise locations or
in specific relationships to other objects.



Constraining with the [SHIFT] key

You can use the [SHIFT] key to constrain any mouse movement to angles that are increments of 45 
degrees or to constrain ellipses and rectangles to circles and squares, or elliptical arcs to circular arcs. 
The exact role of the [SHIFT] key depends on the drawing tool and method that are being used at the 
time.



Drawing Rectangles

 
To draw rectangles, you use the Rectangle tool, located inside the drawing tool palette. HiJaak Draw 
provides six different methods for drawing rectangles :

Corner-corner method of drawing rectangles

1. Select the Rectangle tool and the Corner-corner method .
2. Position the cross at a corner of the rectangle that you want to create, and drag diagonally to 

specify the opposite corner.
3. Release the mouse button when the rectangle is the desired size and shape.

Center-corner method of drawing rectangles

1. Select the Rectangle tool and the Center-corner method.
2. Position the cross at the center of the rectangle that you want to create, and drag diagonally to 

specify one of the corners.
3. Release the mouse button when the rectangle is the desired size and shape.

Angled-corner-corner method of drawing rectangles

1. Select the Rectangle tool and the Angled-corner-corner method.
2. Position the cross at a corner of the rectangle that you want to create, and drag out an angled side 

of the rectangle.
3. Release the mouse button, and move the black arrowhead away from the angled side to specify 

the opposite corner of the rectangle.
4. Click the mouse button when the rectangle is the desired size and shape.

Angled-center-corner method of drawing rectangles

1. Select the Rectangle tool and the Angled-center-corner method.
2. Position the cross at the center of the rectangle that you want to create, and drag out a line that 

specifies the angle of the rectangle.
3. Release the mouse button, and move the black arrowhead away from the angled line to specify 

one of the corners of the rectangle.
As you move the mouse, the rectangle will grow in both directions away from the angled line.
4. Click the mouse button when the rectangle is the desired size and shape.

Sheared-corner-corner method of drawing slanted rectangles



1. Select the Rectangle tool and the Sheared-corner-corner method.
2. Position the cross at a corner of the sheared rectangle that you want to create, and drag out an 

angled side of the sheared rectangle.
3. Release the mouse button at the end point of the side, and move the black arrowhead away from 

the angled side to specify the third corner of the sheared rectangle.
4. Click the mouse button when the sheared rectangle is the desired size and shape.

Numerical entry method of drawing rectangles

1. Select the Rectangle tool and the Numerical Entry method.
2. Position the cross anywhere on the artwork, and press the mouse button.
3. Specify the rectangle parameters inside the Rectangle dialog box.
4. Click on OK, or press [ENTER] when you are finished.

The Rectangle dialog box will appear.

Related Topics:
Reshaping Rectangles
Rounded Rectangles



The Rectangle Dialog Box

Origin radio buttons: Select one of these radio buttons to tell the program which point on the rectangle 
is to be used as the origin.
Origin X and Origin Y fields: In these fields you enter the location of the origin on the artwork page, in 
the desired units. Initially, these fields will contain the coordinates of the location where you pressed the 
mouse button.
Width and Height fields: In these fields you enter the width and height of the rectangle, in the desired 
units.
Angle field and dial: In this field you enter the angle of the rectangle in degrees. The angle is measured 
in the clockwise direction, with the vertical designated as 0 degrees. You can also drag the dial in a 
clockwise direction to specify the angle of the rectangle.



Rounded Rectangles

Rounded rectangles are drawn using the Rounded Rectangle tool located inside the Rectangle tool pop-
up palette. To draw a rounded rectangle, simply specify a corner radius inside the Corner Radius dialog 
box, and then draw a normal rectangle.
When you draw rounded rectangles using the Numerical Entry method, you will notice a slight difference 
between the Rounded Rectangle dialog box from that of normal rectangles.
The Rounded Rectangle dialog box will have an extra field, the Corner Radius field, where you enter the 
size of the corner radius, in the desired units.
If you draw a rounded rectangle without specifying a corner radius value, then the rectangle will be drawn 
with the default corner radius value, or the last value you entered.

Specifying a corner radius

1. Double-click on top of the Rounded Rectangle tool .
The Corner Radius dialog box will appear.

2. Enter the corner radius value inside the Corner Radius field.
The corner radius can range from zero to no larger than one half the size of the smallest side of the 
rectangle, and can be specified in inches, centimeters, points, or pixels.



Drawing Circles

To draw circles, you use the Circle tool located in the drawing tool palette. HiJaak Draw provides four 
methods for drawing circles:

Diameter method of drawing circles

1. Select the Circle tool and the Diameter method.
2. Position the cross on a point on the perimeter, and drag out the diameter of the circle.
3. Release the mouse button when the circle is the desired size and shape.

Radius method of drawing circles

1. Select the Circle tool and the Radius method.
2. Position the cross at the center, and drag out the radius.
3. Release the mouse button when the circle is the desired size and shape.

Three-point method of drawing circles

1. Select the Circle tool and the Three-point method.
2. Position the cross on a point on the perimeter, and drag out a line to specify a point on the opposite

side.
3. Release the mouse button, and move the black arrowhead away from the line to specify the third 

point on the circle.
4. Click the mouse button when the circle is the desired size and shape.

Numerical entry method of drawing circles

1. Select the Circle tool and the Numerical Entry method.
2. Position the cross anywhere on the artwork, and press the mouse button.

The Circle dialog box will appear.
3. Specify the circle parameters inside the Circle dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Reshaping Circles



The Circle Dialog Box

Center X and Center Y fields: In these fields you enter the location of the circle center, in the desired 
units. Initially, these fields will contain the coordinates of the location where you pressed the mouse 
button.
Radius and Diameter radio buttons: Click on one of these radio buttons to tell the program that you are 
specifying the size of the circle by the radius or diameter.
Radius and Diameter size field: This field is located next to the Radius and Diameter radio buttons, and 
in this field you enter the size of the radius or diameter, in the desired units.



Drawing Ellipses

You can draw ellipses by using the Ellipse tool found inside the Circle tool pop-up palette. When you draw
ellipses using the Ellipse tool, you are really dragging out a bounding rectangle that encloses the ellipse. 
For this reason, the ellipse drawing methods are identical to those of rectangles:

Corner-corner method of drawing ellipses

1. Select the Ellipse tool and the Corner-corner method .
2. Position the cross at a corner of the bounding rectangle, and drag diagonally to specify the 

opposite corner of the bounding rectangle.
3. Release the mouse button when the ellipse is the desired size and shape.

Center-corner method of drawing ellipses

1. Select the Ellipse tool and the Center-corner method.
2. Position the cross at the center of the bounding rectangle, and drag diagonally to specify a corner 

of the bounding rectangle.
3. Release the mouse button when the ellipse is the desired size and shape.

Angled-corner-corner method of drawing ellipses

1. Select the Ellipse tool and the Angled-corner-corner method.
2. Position the cross at a corner of the bounding rectangle, and drag out an angled side of the 

bounding rectangle.
3. Release the mouse button, and move the black arrowhead away from the angled side to specify 

the opposite corner of the bounding rectangle.
4. Click the mouse when the ellipse is the desired size and shape.

Angled-center-corner method of drawing ellipses

1. Select the Ellipse tool and the Angled-center-corner method.
2. Position the cross at the center of the bounding rectangle, and drag out a line that specifies the 

angle of the ellipse.
3. Release the mouse button, and move the black arrowhead away from the angled side to specify 

one of the corners of the bounding rectangle.
4. Click the mouse button when the ellipse is the desired size and shape.

Numerical entry method of drawing ellipses



1. Select the Ellipse tool and the Numerical Entry method.
2. Position the cross anywhere on the artwork, and press the mouse button.

The Ellipse dialog box will appear.
3. Specify the ellipse parameters inside the Ellipse dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Reshaping Ellipses



Ellipse Dialog Box

Origin radio buttons: Select one of these radio buttons to tell the program which point on the ellipse 
bounding rectangle is to be used as the origin.
Origin X and Origin Y fields: In these fields you enter the location of the origin on the artwork page, in 
the desired units. Initially, these fields will contain the coordinates of the location where you pressed the 
mouse button.
Width and Height fields: In these fields you enter the width and height of the ellipse, in the desired units.
Angle field and dial: In this field you enter the angle of the ellipse in degrees. The angle is measured in 
the clockwise direction, with the vertical designated as 0 degrees. You can also drag the dial in a 
clockwise direction or counter-clockwise direction to specify the angle of the ellipse.



Drawing Lines

You can draw lines by using the Line tool found inside the drawing tool palette. HiJaak Draw provides 
three different line drawing methods.

 End-end method of drawing lines

1. Select the Line tool and the End-end method.
2. Position the cross at the starting point of the line that you want to create, and drag to the endpoint.
3. Release the mouse button when the line is the desired size and shape.

Midpoint-end method of drawing lines

1. Select the Line tool and the Midpoint-end method.
2. Position the cross at the midpoint of the line that you want to create, and drag to an endpoint.
3. Release the mouse button when the line is the desired size and shape.

Numerical entry method of drawing lines

1. Select the Line tool and the Numerical Entry method.
2. Position the cross anywhere on the artwork, and press the mouse button.

The Line dialog box will appear.
You have two options of specifying the line. You can either define the line by specifying the two 
endpoints of the line, or you can define the line by specifying the location of a single endpoint, 
length of the line, and the angle or slope of the line.

3. Enter the line parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Reshaping Lines



The Line Dialog Box

Start X, Start Y, End X, and End Y fields: Inside these fields you enter the locations of the two endpoints
of the line, in the desired units.
Point X, Point Y, Length, and Angle fields: Inside these fields, you enter the location of a single 
endpoint, the length of the line, and the angle or slope in degrees. You can also drag the dial in a 
clockwise or counterclockwise direction to specify the angle of the line.



Arc Styles

Arc styles define the way that your arc will look when it is filled. You can fill the arc so that it is a pie 
shape, or have its endpoints connected by a chord (straight line) and its interior filled.
Arc styles are specified inside the Arc Style dialog box, and you have the choice of four styles.
These arc styles can be assigned prior to drawing an arc or to existing arcs that are already on your 
artwork.

Assigning an arc style prior to drawing an arc

1. Double-click on any of the arc tools.
The Arc Style dialog box will appear.

2. Specify the desired arc style inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

You can now draw the arc.

Assigning an arc style to existing arcs

1. With the Selection tool, double-click on an arc in your artwork.
The Arc Style dialog box will appear.

2. Specify the desired arc style inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

The arc is redrawn to reflect the new arc style.



Arc Styles Dialog Box

Pie and Chord radio buttons: Click on one of these radio buttons to select between pie shapes and 
chord arcs.
Open and Closed radio buttons: Click on one of these radio buttons to select between open and closed
pie shapes and chord arcs.



Drawing Circular Arcs

HiJaak Draw allows you to easily create circular arcs by using the Circular Arc tool, found inside the 
drawing tool palette. There are four different drawing methods available for drawing circular arcs.

Radius method of drawing circular arcs

1. Select the Circular Arc tool and the Radius method.
2. Position the cross at the center of the circular arc that you want to create, and drag out the radius.
3. Release the mouse button, and move the black arrowhead in a clockwise or counterclockwise 

direction to specify the end point of the arc.
4. Click the mouse button when the arc is the desired size and shape.

Semi-circle method of drawing circular arcs

1. Select the Circular Arc tool and the Semi-circle method.
2. Position the cross on one of the endpoints of the semi-circle that you want to create, and drag out 

the diameter.
3. Release the left mouse button when the semi-circle is the desired size and shape.

Three-point method of drawing circular arcs

1. Select the Circular Arc tool and the Three-point method.
2. Position the cross at the start point of the circular arc that you want to create, and drag out a line to

specify the end point of the arc.
3. Release the mouse button, and move the black arrowhead away from the line to specify the third 

point on the arc.
4. Click the mouse button when the arc is the desired size and shape.

Numerical entry method of drawing circular arcs

1. Select the Circular Arc tool and the Numerical Entry method.
2. Position the cross anywhere on the artwork, and press the mouse button.
The Circular Arc dialog box will appear.
3. Specify the circular arc parameters inside the Circular Arc dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Arc Styles



Reshaping Circular Arcs



Circular Arc Dialog Box

Center X and Center Y: Inside these fields you enter the location of the center, relative to the upper left 
corner of the artwork page, in the desired units.
Radius or Diameter radio buttons: Click on one of these radio buttons to tell the program that you are 
specifying the size of the arc by the radius or diameter.
Start Angle and End Angle fields: Inside these fields you enter where the arc is to start and end as 
angles in degrees. Angles are measured clockwise, with the vertical as zero degrees.
Pie and Chord radio buttons: Click on one of these radio buttons to select between pie shapes and 
chord arcs.
Open and Closed radio buttons: Click on one of these radio buttons to select between open and closed
pie shapes and chord arcs.



Drawing Elliptical Arcs

You can draw elliptical arcs easily by using the Elliptical Arc tool found inside the Circular Arc tool pop-up 
palette. Unlike circular arcs, there is only one way of drawing elliptical arcs.

Method of drawing elliptical arcs

1. Select the Elliptical Arc tool.
2. Position the cross on one of the endpoints of the elliptical arc, and drag to the other endpoint of the

arc.
3. Release the mouse button when the arc is the desired size and shape.

Related Topics:
Arc Styles
Reshaping Elliptical Arcs



Drawing Fillets

Fillets are circular arcs that are drawn to fit between any two lines in your artwork. When you draw fillets, 
a circle is fitted between the two selected lines and a circular arc is drawn, such that its endpoints touch 
the two lines.
HiJaak Draw provides two fillet drawing methods. The way that you draw the fillets is the same for both 
methods, the only difference is which of the two arcs is drawn when you finish.

Method of drawing fillets

    

1. Select the Fillet tool.
2. Position the plus sign on top of one of the lines, click the mouse button, and move the mouse to the

second line.
You will see a guide line following the movement of the mouse as you move to select the second 
line.

3. Click the mouse button on the second line.
The guide line will disappear and a circle will appear between the two selected lines. The circle will 
be tangent to both of the lines.

4. Move the mouse between the lines to position the circle where you want to draw the fillet.
5. Click the mouse button when the circle is at the desired location.

The fillet will be drawn between the two lines with its endpoints as the tangent points of the circle 
and the two lines. Whether the smaller or the larger of the two arcs is drawn depends on the 
method that you have selected.

Related Topics:
Arc Styles
Reshaping Fillets



Drawing Polygons

You can draw open and closed polygons with the Polygon tool, by clicking to place anchor handles. The 
Polygon tool is located inside the Line tool pop-up palette.
What distinguishes an open polygon from a closed polygon is where you terminate the polygon. 
Terminating the polygon with the endpoint on top of the first point creates a closed polygon, while 
terminating anywhere else creates an open polygon.

Method of drawing polygons

1. Select the Polygon tool.
2. Position the cross at the first point of the polygon that you want to create, and click the mouse 

button.
3. Move the black arrowhead to where you want the first segment of the polygon to end, and click the 

mouse button.
4. Continue clicking to place additional anchor handles.
5. Terminate the polygon.

Terminating a Polygon

You can terminate the polygon in two ways. You can close the polygon or create an open polygon.
To create an open polygon simply double-click the mouse button where you want to place the last anchor 
handle.
To close the polygon, click on the first anchor handle.

Related Topics:
Deleting Polygon Segments
Drawing Curved Segments with Polygon Tool
Drawing Regular Polygons and Stars
Reshaping Polygons
Rounded Corner Polygons



Rounded Corner Polygons

You can create rounded corner polygons by double clicking on the polygon tool before you drag out the 
polygon. This will bring up the Corner Radius dialog box. To enable the rounded corner option, select the 
Rounded Corner checkbox.
Once the rounded corner option is enabled, you can specify the radius of the corner in the Corner Radius 
field. Corners can be no more than half the length of the shortest side of the polygon.



Deleting Polygon Segments 

If you make a mistake while you are drawing a polygon, you can delete segments of the polygon by 
pressing the [BACKSPACE] key. You can erase any number of segments by pressing the [BACKSPACE] 
key the required number of times.



Drawing Curved Segments with Polygon tool

HiJaak Draw lets you interchange straight line and curved segments when drawing polygons with the 
Polygon tool. Holding down the [CTRL] key as you place an anchor handle, lets you draw spline curve 
segments in place of straight line segments. 
When you place an anchor handle with the [CTRL] key down, you are telling the program to draw a spline
curve. When you do this, the previous polygon segment and the next polygon segment become curves, 
and the shape of these curves is determined by the location of their anchor handles. The best way to 
explain how the spline curve drawing works, is with a series of illustrations.
You can place several consecutive spline anchor handles to draw more complex continuous curves.



Drawing Regular Polygons and Stars

You can draw regular polygons and stars with the Regular Polygon/Star tool, located inside the Line tool 
pop-up palette.
You can draw both regular polygons and stars with this same tool by specifying which you want to draw 
inside the Regular     Polygon/Star dialog box  .
If you draw a polygon/star without specifying any of the parameters, then the polygon/star will be drawn 
with the default values or the last values you specified.

Specifying regular polygon and star parameters

1. Double-click on the Regular Polygon/Star tool.
The Regular Polygon/Star dialog box will appear.

2. Specify the regular polygon and star parameters inside the Regular Polygon/Star dialog box.
3. Click on OK, or press [ENTER] when you are finished.

Drawing regular polygons and stars

1. Select the Regular Polygon/Star tool.
2. Position the cross at the center of the polygon/star that you want to create, press the mouse 

button, and drag away from the center.
3. Release the mouse button when the polygon/star is the desired size.

Related Topics:
Drawing Polygons
Reshaping Regular Polygons/Stars



Regular Polygon/Star Dialog Box

Polygon and Star radio buttons: Selecting one of these radio buttons, tells the program whether you 
want to draw a regular polygon or a star.
Number of Segments field: Inside this field, you enter the number of sides for your regular polygon or 
the number of points for your star.
Inner Radius Size field: This field is only used for drawing stars. It allows you to enter the size of the 
inner circle of the star, as a percent value. The smaller the inner radius, the longer the points of your star, 
and vice-versa.
Alternate checkbox and field: This checkbox is only active when you are specifying parameters for a 
star. When the checkbox is enabled, you can enter a percentage value in the field, to specify the size of 
every second spike in the star. Values can be positive or negative, allowing you to create some interesting
effects. 
Rounded checkbox and field: Select this checkbox to create polygons and stars with rounded corners. 
You can specify the size of the rounded corner in the field, but rounded corners can be no more than half 
the length of the shortest side of the object.
Preview Box: Inside the Preview Box, you will see a sample preview of how your regular polygon or star 
will look, according to the parameters that you have entered.



Drawing Gratings

Gratings are a series of equally placed, parallel lines. You can draw horizontal and vertical gratings with 
the Gratings tool, located inside the Line tool pop-up palette. 
You can create gratings by dragging out a grating bounding rectangle, and then specifying either a fixed 
spacing between the lines or a fixed number of lines, in a horizontal, vertical or both directions (grid).
The direction of the grating and the necessary grating parameters are specified inside the Grating 
Parameters dialog box. If you draw a grating without specifying the any grating parameters first, then the 
grating will be drawn with the default values or the last parameters you specified.

Specifying grating parameters

1. Double-click on the Grating tool.
The Grating Parameters dialog box will appear.

2. Specify the grating parameters inside the Grating Parameters dialog box.
3. Click on OK, or press [ENTER] when finished.

Method of drawing a grating

1. Select the Grating tool.
2. Position the cross on a corner of the grating that you want to create, and drag diagonally to specify 

an opposite corner.
3. Release the mouse button when the grating is the desired size and shape.

Related Topics:
Reshaping Gratings



Grating Parameters Dialog Box

Horizontal, Vertical, and Both radio buttons: Click on one of these radio buttons, to specify the 
direction of the grating. Clicking on Both tells the program that you want a crosshatched grating.
Fix Spacing fields: Inside this field, you enter the size of the fixed spacing between adjacent grating 
lines, for the direction that you have selected.
Fix Number fields: Inside this field, you enter a fixed number of grating lines.



Curve Segments

Curve segments span between two anchor handles and can be one of two types: straight line segments 
and curved segments. A curve can contain any combination of straight and curved segments.
A continuous curve will consist of several curved segments joined end-to-end. The anchor handles of the 
interior segments will have two tangent lines and tangent control points, one specifying the direction of the
segment entering the handle, and the other specifying the direction of the segment leaving the handle. By
moving the tangent control point relative to the anchor handle you change the shape of the curve.
The way that the tangent lines behave when you move one of the control points of an interior anchor 
handle, depends on the type of anchor handle that you have placed. There are three types of anchor 
handles: smooth handles, symmetric handles, and corner handles.
An anchor handle of a straight segment has no associated tangent lines or control points.



Anchor Handles

There are three types of anchor handles, that affect the continuity and shape of the curve at the handle: 
smooth handles, symmetric handles, and corner handles.
For symmetric handles the two tangent control points and the handle lie on a straight line, and the 
control points are always the same distance from the handle. Moving one of the tangent control points 
causes the other to move in unison.
A smooth handle has both the tangent control points and the anchor handle lying on a straight line, but 
the control points are not necessarily the same distance from the handle. When you move one of the 
control points, the other rotates with it, but it maintains it's own relative distance from the handle.
A corner handle does not necessarily have tangent control points and the anchor handle lying on a 
straight line. Each of the control points move independently of each other. Corner handles are useful for 
creating cusps (the point created by converging curves).
You can change the anchor handle type at any time during your work session.



Curve Drawing Tools

You can draw curves in HiJaak Draw by using three different drawing tools: the Pen tool, the Freehand 
tool, or the Spline tool. Each of these tools works differently, therefore the one that you use will depend on
the particular effect you are trying to create.

The Pen tool lets you draw bezier curves, and gives you the greatest control over the way that the curve 
is shaped. You have total control over the placement of anchor handles, and their tangent lines.

The Spline tool also lets you draw smooth continuous curves, except that you have less control over the 
shape of the curve. When you draw spline curves, you place anchor handles on the artwork, and the 
program fits a smooth curve between them. The Spline tool is useful in situations where you want to 
create a smooth curve quickly, and the accuracy is not really crucial.

The Freehand tool lets you draw just as if you were drawing with a pencil on a sheet of paper. You simply 
drag the mouse to draw the freehand curve, and then HiJaak Draw creates a bezier curve to represent 
the freehand curve for you.



Drawing Bezier Curves

The Pen tool should be used when you want to create accurate continuous curves. The Pen tool allows 
you to draw bezier curves with any combination of straight and curved segments.
You draw bezier curves by pressing and holding the mouse button down to place anchor handles and 
then dragging away from the handle to specify the tangent lines of the curve at the handle.
When you first draw a bezier curve, the program places symmetric handles, however, you can change the
handle to a smooth or corner handle as you draw. 

Method of drawing bezier curves

1. Select the Pen tool.
2. Position the cross where you want the curve to begin, and press and hold down the mouse button.
3. Drag away from the anchor handle to specify the length and direction of the tangent line.

The length and direction of the tangent line determines the height and direction of the curve at the 
anchor handle.

4. Release the mouse button when the tangent line is the desired length and direction.
5. Position the cross where you want the curved segment to end, and press and hold down the 

mouse button.
The second symmetric anchor handle appears.

6. Drag away from the handle to specify the length and direction of the tangent line at the second 
anchor handle.

7. Release the mouse button when the tangent line is the desired size and direction.
8. Repeat steps 5 through 7 to create additional segments.
9. Terminate the curve.

Once you terminate your curve, the black arrowhead will change back to a cross, indicating that you can 
now draw another bezier curve.
The anchor handles of the bezier curve will be highlighted, indicating that the curve is selected.

Terminating a Bezier Curve

You can terminate the bezier curve in two ways. You can close the curve or create an open curve.
To create an open curve, you have three options:

Double-clicking the mouse button on the last anchor handle causes the curve to terminate at that 
handle.
Double-clicking the mouse button anywhere else on the artwork causes the curve to terminate at 
the location where you double-clicked the mouse button. The program places a corner anchor 
handle, with no associated tangent line, at that location for you.
Selecting another tool causes the curve to terminate at the last anchor handle.

There are three ways of closing a curve:
Clicking on the first anchor handle closes the curve, and there is no tangent line included for the last
curve segment entering the first handle.
Dragging on the first anchor handle closes the curve with a smooth ending handle.
Holding the [ALT] key down and dragging on the first anchor handle closes the curve with a corner 
handle.



Related Topics:
Anchor Handles
Curve Segments
Deleting Curve Segments
Drawing Freehand Curves
Drawing Splines
Drawing Straight Segments with the Pen Tool
Reshaping Bezier Curves



Drawing Straight Segments with the Pen Tool

You can draw straight line segments with the Pen tool, by clicking instead of dragging to place anchor 
handles. HiJaak Draw lets you intermix straight line and curved segments as you draw curves.
If you are in the process of drawing a curve, and you want to draw a straight segment, you simply click on
the last anchor handle and then move to where you want the straight segment to end, and click the 
mouse button again.
Just as with the Polygon tool, you can also draw straight line polygons with the Pen tool. You merely click 
to place anchor handles, in the same manner as with the Polygon tool. 

Method of drawing a straight segment

1. Position the black arrowhead on the last anchor handle, and click the mouse button.
The portion of the curve that was trailing the black arrowhead will disappear.

2. Move the mouse to the end of the straight line segment and click the mouse button.
A straight line segment will be drawn.



Deleting Curve Segments

If you make a mistake while you are drawing a curve, you can delete segments of the curve by pressing 
the [Backspace] key. You can erase any number of segments by pressing the [Backspace] key the 
required number of times.
You can use the [Backspace] key to delete segments as you draw with the Pen tool and the Spline tool.

Changing Handles 

HiJaak Draw lets you change anchor handle types from symmetric to smooth or corner, as you draw. 
This feature is useful, since you can edit a handle type as you draw, without having to finish drawing your 
curve, and then going back and editing individual handles.
To change the handle to a smooth handle, position the black arrowhead on the last handle, press and 
hold the mouse button down, and drag away from the handle to specify the tangent lines at the new 
smooth handle.
To change the handle to a corner handle, position the black arrowhead on the last handle, hold the [ALT] 
key down, and press and hold the mouse button down. Then drag away from the handle to specify the 
tangent line of the new corner handle.



Drawing Splines

You can use the Spline tool located inside the Pen tool pop-up palette, to draw spline curves by clicking to
place anchor handles on your artwork. The program will then automatically draw the curve between the 
anchor handles. For this reason, the spline drawing method does not offer as much control as the bezier 
method.
The program requires at least three anchor handles before it can draw a curve. With only two handles, a 
straight line is drawn. Placing a new anchor handle will affect the shape of the last five segments. The 
spline method should be used when you want to create short smooth curves or curves where the degree 
of accuracy is not important.

Method of drawing spline curves

1. Select the Spline tool.
2. Position the cross where you want the curve to begin, and click the mouse button.
3. Move the mouse to where you want the curve segment to end, and click the mouse button.
4. Repeat steps 2 and 3 to create additional segments.
5. Terminate the curve.
Terminating a Spline Curve

Just as bezier curves, you can terminate the spline curve in two ways. You can close the curve or create 
an open curve.
To create an open curve, you have three options:

Double-clicking the mouse button on the last anchor handle causes the curve to terminate at that 
handle.
Double-clicking the mouse button anywhere else on the artwork causes the curve to terminate at 
the location where you double-clicked the mouse button.
Selecting another tool causes the curve to terminate at the last anchor handle.

There is only one way of closing a spline curve:
Placing the last handle on top of the first anchor handle closes the curve.

Related Topics:
Anchor Handles
Curve Segments
Drawing Bezier Curves
Drawing Freehand Curves
Reshaping Spine Curves



Drawing Freehand Curves

Using the Freehand tool located inside the Pen tool pop-up palette, you can draw freehand curves by 
dragging across your artwork in the same way that you would with a pencil on paper. When you finish 
dragging the curve, the program places corner anchor handles along the curve for you.
The curves that you draw with the freehand tool will be bumpy because the mouse shakes as you drag. 
The freehand tolerance value specifies the amount of shaking that is tolerable without showing up as 
bumps on the artwork. Freehand tolerance is specified in pixels (from 1 to 10) and is set inside the 
Freehand Settings dialog box. The larger the freehand tolerance value, the smoother the curve will look.
If you wish to draw smooth curves you should use the bezier or spline curve drawing methods. The 
freehand method should be used for fast sketching where accuracy is not important or when you want to 
create a hand-drawn look in your artwork.
You can not use any of the precision tools when drawing freehand curves.

Specifying the freehand tolerance

1. Double-click on the Freehand tool.
The Freehand Tool Settings dialog box will appear.

2. Enter the freehand tolerance value inside the Tolerance field.
The value is specified in terms of pixels. The larger the value you specify, the smoother the curve 
will be.

3. Click on OK when you are finished.

Drawing freehand curves

1. Select the Freehand tool.
2. Position the cross where you want the curve to start and drag across the artwork to draw the 

freehand curve.
3. Release the mouse button when the curve is the desired size and shape.

You can create closed freehand curves by releasing the mouse button back at the starting point, or an 
open freehand curve by releasing the mouse button anywhere else.

Erasing Portions of the Freehand Curve 

You can erase any part of your freehand curve as you are drawing by holding down the [Backspace] key 
and then retracing over the portion of the curve that you want to erase.
Then once you have finished erasing the desired portion of the curve, you can continue drawing by 
releasing the [Backspace] key.

Related Topics:
Anchor handles
Curve Segments
Drawing Bezier Curves
Drawing Splines 
Reshaping Freehand Curves



Text Features

HiJaak Draw provides two types of text that you can use in your illustrations.

The Text Effects tool lets you create title text that runs horizontally, at an angle, on the inside or outside an
ellipse, along a curve, and between two curves.

The Block Text tool lets you enter linked blocks of paragraph text. The text can flow inside objects or 
around other graphics.



 Text Effects

The text effect feature creates title text for your artwork. HiJaak Draw provides six drawing methods for 
creating text effects.
Multiple line text effects can be created simply by pressing the [ENTER] key when you want to start a new
line of text.
The text effects that you create can be reshaped and transformed the same as other objects are.
You can use any of the features found inside the Special menu, to blend, distort, and extrude text effects.
As well, the text effects can be filled with solid color, patterns, linear or radial graduated fills, and 
PostScript fills. They can be outlined with solid or dashed line styles, and have colored outlines that are 
colored using spot or process colors. Text effects can even be used as masks.

To create straight text effects

1. Select the Text Effect tool and the Straight method.
2. Position the I-beam where you want the text effect to be located and drag out the horizontal text 

bounding box.
The height of the bounding box determines the size of characters that will be used when you type 
your text.
You can specify the location of the text effect by clicking the mouse button at the location where you
want the text to be located. When you enter the text, the size of the text will be the currently 
selected font size.

3. Type your text.
4. Click on any other tool when you are finished.

To create angled text effects

1. Select the Text Effect tool and the Angled method.
2. Position the I-beam where you want the text to be located and drag out an angled bounding box.

The height of the bounding box determines the size of characters that will be used when you type 
your text.

3. Type your text.
4. Click on any other tool when you are finished.

To create text effects on an ellipse

1. Select the Text Effect tool and the On Ellipse method.
2. Position the I-beam where you want the text to be located and drag out the ellipse.
3. Type your text.
4. Click on any other tool when you are finished.



To create text effects on the inside of an ellipse

1. Select the Text Effect tool and the Inside Ellipse method.
2. Position the I-beam where you want the text to be located and drag out the ellipse.
3. Type your text.
4. Click on any other tool when you are finished.

To create text effects on a curve

1. In the Document window, draw the curve you want to wrap the text on.
2. Select the Text Effect tool and the On Curve method.
3. Click the I-beam on the curve that you want to fit your text.

NOTE: The direction of the text depends on the direction that the curve was drawn. Make sure that 
you draw the curves from left to right so that the text will be oriented in the proper way.

4. Type your text.
5. Click on any other tool when you are finished.

To create text effects between two curves

1. Select the Text Effect tool and the Fit Between Curves method.
2. Position the I-beam where you want the text effect to be located and drag out the horizontal text 

bounding box from corner to corner.
3. Type your text.
4. Click on the Pointer tool when you are finished.
5. Position the pointer on any anchor handle of the top and bottom bounding curves, press and hold 

the mouse button down, and drag the handle to a new location to reshape the bounding curves.
6. Repeat step 5 until the bounding curves are the desired shape.

Related Topics:
Baseline Shift
Reshaping Text Effects
Selecting Text Effects
Type Attributes



Selecting Text Effects

You can either click or drag a marquee to select text effects. When you select text effects in this way, a 
bounding box will surround the entire text effect, and the base line that the text runs along will be 
selected. Since all the characters of the text effect are selected, whatever operation you perform will 
affect all the characters in the same way. To select text by clicking on it, you must click on the text's 
baseline.
You can select a range of characters by selecting the Text Effect tool and dragging the I-beam over the 
characters to highlight them. Once you select a range of characters, you can change their font, font size, 
spacing, or fill and outline color. 
To edit individual characters, select the text effect by clicking or dragging a marquee, and then choose the
Reshape Characters command from the Type menu. The text effect will be broken up into individual 
characters, and anchor handles will appear at the bottom left of each character. The individual character 
is selected by selecting its handle. 



Reshaping Text Effects

To resize all the characters simultaneously, drag any of the bounding box handles to a new location.
When you reshape a text effect involving a curve, you can add or remove handles from the base curve, 
change curve segment type, add and remove handles from the base curve, and change handle type. To 
change the flow of the text you drag any of the anchor handles of the ellipse to a new location
When you reshape Straight or Angled text effects, you can drag the end handles of the baseline in a 
clockwise or counterclockwise direction to change the angle of the text. When you drag the end handles, 
you can hold down the [SHIFT] key to constrain the text to angles that are increments of 45 degrees. You 
can also use any of the precision positioning tools to help you rotate the text in specific relationships to 
other objects.

Reshaping Individual Characters

When you select a text effect, you can choose the Reshape Characters command from the Type menu to 
break up the text effect into individual characters. Anchor handles will appear at the bottom left of each 
character, and you can click on these anchor handles to select individual characters. Once you have 
selected a character, you can move, resize, transform, or change the fill or outline color.



Block Text

Using the Block Text tool, located inside the Text tool pop-up palette, you can enter paragraph text in 
rectangular block form, or in objects of other shapes. If your printer supports hinted fonts, you print the 
Block Text using these hinted fonts. Font formats that supply hinted fonts include Adobe Type 1 and 
TrueType.
HiJaak Draw lets you enter text inside shapes, such as circles, triangles, and slanted rectangles. You 
define the shape of the block text by choosing the desired object from the sub-menu associated with the 
Type/Shapes command. All of the text in a text block is arranged to create the selected shape. If you want
a specific piece of text to form a shape, reflow the text between text blocks so that the text you want to 
shape is in its own block.
Whenever you enter block text, the text will assume the shape of the currently selected shape from the 
Shapes command, located in the Type menu. The currently selected shape will have a checkmark beside 
it inside the Type/Shapes sub-menu. When you first run HiJaak Draw, the rectangle shape is selected, 
and any block text that you enter will be rectangular in shape. You can choose different text block shapes 
at any time during your work session.

To add block text to your artwork

1. Select the desired text block shape from the sub-menu behind the Type/Shapes command.
2. Select the Block Text tool.
3. Position the I-beam where you want the text to be located and drag out the text bounding box.
4. Type your text.
5. Click on any other tool when you are finished.

Related Topics:
Importing Text
Inserting Text in a Text Block
Margins
Paragraphs
Reshaping Block Text
Selecting Block Text
Spell Checking
Text Block Dialog Box
Type Attributes
Wrapping Text Around Objects (Repel Text)



Importing Text

On some occasions you may have existing text you want to bring into your artwork, or you may have long 
pieces of text you wish to perfect in a text editor. You can import text that has been saved as ASCII text.
You can place the block text bounding box before or after you import the text. If you place the bounding 
box first, the text will be imported into it. If you have not placed the bounding box when you import, the 
pointer will change to the Block Text pointer. You can place the bounding box and the text will appear 
inside it.



Selecting Block Text

You can either click on or drag a marquee over the text block to select it. When you select text blocks a 
bounding box will surround the block. The bounding box will have anchor handles at its corners, and 
loops at the top and bottom edge of the bounding box. When the text block is selected, you can drag it to 
a new location, drag any of the corner handles to reshape it, or drag the loops up and down to control the 
amount of text that is visible. However, you can not change the font type, font size, or any of the other text
attributes. To change the text attributes, select a range of text from the text block.
You can use the Block Text tool to select a range of characters by dragging the I-beam over the 
characters that you want to select. The selected characters will be highlighted, indicating that they are 
selected. Once you select a range of characters, you can change their font, font size, leading, or any of 
the other text attributes found inside the Type menu. 
Double-clicking the mouse button on a word inside your block text, will select the entire word.
You can extend text selection/deselection by holding down the [SHIFT] key as you click or drag to select 
text characters.



Reshaping Block Text

You can drag any of the corner handles of the bounding box to resize it. Resizing the bounding box will 
not change the size of the text. When you increase the size of the bounding box, you give yourself more 
space to enter text.
To control the amount of text that is visible, drag one of the loops up or down.
When there is more text than is currently being displayed (the bounding box is not large enough to show 
the entire text block), a black arrowhead will appear in the bottom loop.



Inserting Text in a Text Block

Using the Text Block tool, you can insert new text into an existing text block.

To insert new text in a text block

1. Select the Block Text tool.
2. Position the I-beam in the text block at the point where you want to insert the text, and click the 

mouse button.
3. Type the new text.
4. Click on any tool when you are finished.



Deleting Text from a Text Block

You can use the Block Text tool to delete portions of text from existing text blocks.

To delete text from a text block

1. Select the Block Text tool.
2. Drag the I-beam over the range of text that you want to delete.
3. Press the [Backspace] key.
4. Click on any tool when you are finished.



Copying Text between Text Blocks

At times you will want to move a range of text from one text block to another. You can do this by using the 
Block Text tool in conjunction with the Copy, Cut, and Paste commands, located inside the Edit menu. 

To copy text from one text block to another

1. Select the Block Text tool.
2. Drag the I-beam over the range of text that you want to copy to another text block.
3. Choose the Copy command from the Edit menu, or press [CTRL][C].

If you choose the Cut command from the Edit menu, the selected range of text will be deleted from 
the text block and copied onto the clipboard. You can use the Cut command to move a range of text
from one text block to another.

4. Position the I-beam at another position or in the second text block where you want to insert the 
copied text, and click the mouse button.

5. Choose the Paste command from the Edit menu, or press [CTRL][V].
6. Click on any tool when you are finished.



Flowing Text Between Blocks

You can break up an existing text block into separate linked text blocks. When text blocks are linked the 
text will flow between them. If you drag the loops of one text block to show less of the text, the next linked 
text block will be updated to show the remaining text, and vice-versa.
You can tell whether there is additional text that is not currently visible in the text block, by a black 
arrowhead inside the bottom loop.

To flow text between blocks

1. Click on the black arrowhead in the bottom loop of a text block.
2. Drag out another block text bounding box.



Wrapping Text Around Objects

The repel text feature is useful for wrapping block text around graphical objects. To repel text, you simply 
select an object and choose the Repel Text command from the Objects menu. When you place the object 
on top or overlapping a text block, the text will automatically wrap around the object.

To wrap text around objects

1. Select the object that you want to use as the repelling object, and choose the Repel Text command
from the Objects menu.

2. Drag the objects onto a block of text, or so that it is overlapping a block of text.
You can specify how you want the text to wrap around the object by double clicking on a Text Block to 
bring up the Text Block dialog box. In this dialog box you can specify No Wrap, Wrap to Bounds, Wrap to 
Shape and how far you want the text to stay from the object.



Type Attributes

HiJaak Draw gives you control over text attributes such as: font type, font size, leading, character width, 
tracking, type style, alignment, indents, tabs, and hyphenation. The type attribute commands are located 
inside the Type menu. Text attributes can be set before you enter your text and can be changed later by 
selecting the text you wish to alter, and then choosing the appropriate attributes. 
Some of the type attribute commands have submenus associated with them. Attribute commands that 
have an associated submenu are marked with a black arrowhead to the right of them inside the Type 
menu. If you press and hold the mouse button down on any of these commands, the submenu will 
appear.



Font Type

The font type refers to an entire set of characters that comprise a particular typeface. You can use the 
Font command from the Type menu to choose a new font type. The Font command has an associated 
submenu that contains the Other... command, and a list of previously used fonts.
You can either choose one of the fonts already used in your artwork, or you can select a new font by 
choosing the Other... command and then choosing the desired font from the Fonts dialog box.
As you choose new fonts from the Fonts dialog box, they will be added to the list of fonts inside the Font 
submenu.
The currently selected font will have a checkmark beside its name inside the Font submenu.

To choose a new font

1. Choose the Fonts/Other... command from the Type menu.
The Fonts dialog box will appear.

2. Choose the desired font from the Fonts dialog box.
3. Click on OK, or press [ENTER] when you are finished.



The Fonts Dialog Box

The Font List Box: Inside this list box you will see a list of all the available fonts. You can use the scroll 
bars to scroll through the entire list of fonts. Click the mouse button on the desired font name to select it. 
The selected font name will be highlighted when it is selected.
The Style List Box: Inside this list box you will see a list of available font styles such as regular, bold, 
italic, and bold italic. Click the mouse button on the desired font style to select it. The selected font style 
will be highlighted when it is selected. The icons next to the font name tell you what type of font it is: 
Adobe Type 1, printer font, or Truetype.
The Font Preview Box: The Font Preview Box will display a sample of the way that the currently 
selected font will look. The preview box will only display a sample if the Show checkbox is selected.
The Show checkbox: Selecting this checkbox tells the program to display a sample of the currently 
selected font inside the Font Preview Box.



Font Size

The font size refers to the size of the text characters in points, and varies according to the font type. One 
point is equal to 1/72 of an inch. You can use the Size command from the Type menu to specify new font 
sizes. The Size command has an associated submenu that contains the Other... command, and a list of 
standard font sizes ranging from 6 points to 72 points.
To change the font size, select a range of text, and choose one of the standard font sizes. You can specify
your own custom font size by choosing the Other... command and then specifying the desired font size 
inside the Point Size dialog box.
The currently selected font size will have a checkmark beside it inside the Size submenu. If the current 
font size is a custom size, then a checkmark will appear beside the Other... command in the submenu.

To specify custom font sizes

1. Choose the Size/Other... command from the Type menu.
The Point Size dialog box will appear.

2. Specify the desired font size inside the Point Size field.
3. Click on OK, or press [ENTER] when you are finished.



Type Leading

Leading refers to the amount of spacing between lines of text (sometimes called line spacing). You can 
use the Leading command from the Type menu to specify the line spacing. The Leading command has an
associated submenu that contains the Other... command, Single Spaced, 1-1/2 Spaced, Double Spaced 
commands, and a list of standard line spacings ranging from 11 to 30 points. 
To assign line spacing, select a range of text, and choose one of the standard line spacings, or specify 
your own custom leading by choosing the Other... command and then specifying the desired line spacing 
inside the Leading dialog box.
The currently selected leading will have a checkmark beside it inside the Leading submenu. If the current 
leading is a custom leading, then a checkmark will appear beside the Other... command in the submenu.

To specify custom leading

1. Choose the Leading/Other... command from the Type menu.
The Leading dialog box will appear.

2. Specify the desired leading inside the Leading dialog box.
3. Click on OK, or press [ENTER] when you are finished.



Leading Dialog Box

The Relative radio button and field: Select this option to enter the leading as a percentage of the 
maximum font size. You enter the percentage value in the field next to it. A leading of 100% corresponds 
to single line spacing, while 200% corresponds to double spacing.
The Extra radio button and field: Select this option to specify the leading as the font size plus an extra 
amount, that you specify in points. The amount extra is entered in the field next to it.
The Fixed radio button and field: Select this option to specify an absolute line spacing in points. The 
amount of spacing is entered in the field next to it.



Character Width

HiJaak Draw lets you vary the width of text characters by specifying a new character width that is a 
percentage of the original width. You can use the Char Width command from the Type menu to specify a 
new character width. The Char Width command has an associated submenu that contains the Other... 
command, and a list of character widths ranging from 70% to 130%.
To change the character widths, select a range of text, and choose one of the standard character widths 
from the predefined list. You can also specify your own custom width by choosing the Other... command 
and then entering the desired character width inside the Character Width dialog box.
The currently selected character width will have a checkmark beside it inside the Char Width submenu. If 
the current width is a custom size, then a checkmark will appear beside the Other... command in the 
submenu.

To specify a custom character width

1. Choose the Char Width/Other... command from the Type menu.
The Character Width dialog box will appear.

2. Specify the desired character width inside the field.
3. Click on OK, or press [ENTER] when you are finished.



Tracking

Tracking refers to the ability to increase or reduce the spacing between characters in a selected range of 
text, and is measured in units that are 1/100 of an em space. An em space is equal to the width of a 
capital M. You can use the Tracking command from the Type menu to specify the tracking. The Tracking 
command has an associated submenu that contains the Other... command, Very Loose, Loose, Tight, and
Very Tight commands.
To adjust the character tracking, select a range of text, and choose one of the common tracking styles 
from the list. You can specify your own custom tracking by choosing the Other... command and then 
specifying the desired character spacing inside the Tracking dialog box.
The currently selected tracking will have a checkmark beside it inside the Tracking submenu. If the 
current tracking is a custom tracking, then a checkmark will appear beside the Other... command in the 
submenu.

To specify a custom tracking

1. Choose the Tracking/Other... command from the Type menu.
The Tracking dialog box will appear.

2. Specify the desired character spacing inside the field.
3. Click on OK, or press [ENTER] when you are finished.



Type Style

You can assign type styles to selected text in a text block, such as bold, italics, and underline. You set the 
styles by choosing the Type Style command from the Type menu. The Type Style command has an 
associated submenu that contains the style options for the currently selected font.
The currently selected style will have a checkmark beside it inside the Type Style submenu.



Type Alignment

Type alignment refers to the way that text is arranged in paragraphs. The available type alignment options
are: Align Left, Align Center, Align Right, and Justify. You set the alignment options by using the Alignment
command from the Type menu. The Alignment command has an associated submenu that contains 
alignment options listed above.
To change the text alignment, select a range of text, and choose one of the alignment options from the 
Alignment submenu.
The currently selected alignment option will have a checkmark beside it inside the Alignment submenu.
When you align text to the left, the text is placed flush to the left side of the text bounding box. Aligning 
text to the right will place the text flush to the right of the bounding box. Centered alignment will center 
each line of text within the bounding box. Justified alignment will adjust the text such that it is flush with 
the left and the right side of the text bounding box.



Paragraphs

You can set the amount of space between paragraphs, and the amount paragraphs are indented using 
the Paragraph... command from the Type menu.

To specify paragraph parameters

1. Choose the Paragraph... command from the Type menu.
The Paragraph dialog box will appear

2. Specify the paragraph attributes in the dialog box.
3. Click on OK, or press [Enter] when you are finished.



The Paragraph Dialog Box

The Spacing field: Inside this field you can enter the number of lines you want left between paragraphs.
The Indent field: Inside this field you can set, in points, how far paragraphs will be indented from the 
bounding box.
The Indent First Line field: Inside you can set, in points, how far the first line of paragraphs should be 
indented from the rest of the text.



Tabs

You can set tabs in your block text using the Tabs... command from the Type menu and then specifying 
the tabs inside the Tab Positions dialog box.

To specify tabs

1. Choose the Tabs... command from the Type menu.
The Tab Position dialog box will appear.

2. Specify the tab positions inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.



Tab Position Dialog Box

The Positions field: Inside this field you can enter the new tab positions in the desired units.
The Tab Ruler: You can use the tab ruler to place the tab positions relative to the zero point. Clicking the 
mouse button on the ruler will place a tab marker at the location where you clicked the mouse button. 
Once you have placed a tab marker, you can drag the marker to change the tab position.
The Tab marker: The tab marker marks the position of the current tab position. You can drag any of the 
tab markers to change the tab position. When you drag the marker the Positions field will display the 
changing tab position.



Hyphenation

You can choose to have HiJaak Draw automatically insert hyphens in words for you. HiJaak Draw uses 
algorithmic based hyphenation to break words at the end of a line. The hyphenation command follows 
basic hyphenation rules. To specify the hyphenation options, you choose the Hyphenation... command 
from the Type menu, and then specify the hyphenation options inside the Hyphenation dialog box.

To specify the hyphenation

1. Choose the Hyphenation... command from the Type menu.
The Hyphenation dialog box will appear.

2. Specify the hyphenation options inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Auto Hyphenation



The Hyphenation Dialog Box

The Hyphenation On and Off radio buttons: Selecting these radio buttons turns the hyphenation on 
and off.
The Language combo box: Clicking on this checkbox will display a list of all the languages supported by
HiJaak Draw. You can choose the language you are presently using.
The Break Capitalized words checkbox: Selecting this checkbox tells the program to hyphenate 
capitalized words as well.
The Preferential Hyphens checkbox: Selecting this checkbox tells the program to grammatically place 
the hyphen at the best position in the word. Otherwise, the word will be broken at a hyphenation location 
that is closest to the block margin.
The Minimum word length field: Inside this field you enter the minimum number of characters in a word 
that can be hyphenated.
The Minimum chars. before field: Inside this field you enter the minimum number of characters before 
the hyphen.
The Minimum chars. after field: Inside this field you enter the minimum number of characters after the 
hyphen.



Auto Hyphenation

If you just want to turn the hyphenation on or off, without changing any of the parameters, you can select 
the Auto Hyphenation command from the Type menu. This is a toggle command that turns hyphenation 
on and off without affecting the hyphenation settings.



Spell Checking

HiJaak Draw provides a built-in spell checker that will check the spelling of block text and text effects. 
You can check the spelling of a selected word, a selected range of text, the entire linked text block, or all 
of the text in your artwork.
If a word is not in the current HiJaak Draw dictionary, you can enter the word in your own user defined 
dictionary.
If your document has multiple pages with text, the Check Spelling command in the Text menu brings up a 
dialog box asking whether you wish to spell check the entire artwork, or just the current page. 
If text is currently selected, the command will check all text in the current selection (both Text Effects and 
Block Text). 
If you are currently editing within text blocks or text effects, the check will cover the text block you are 
currently working in.
If you have a range of text selected, the spell check will be confined to this range.

To Check Spelling

1. If you want to check a specific range or block of text, select it.
2. Select Type/Check Spelling...

The Check Spelling dialog box will appear.
3. Click on the Start button to begin the spell check. 

If you do not have any text selected a dialog box will appear asking if you want to check the entire 
document. If you do want to check the document, click on OK. If you do not want to check the entire
document, click on cancel, and then select the text you want to check, and Choose Type/Check 
Spelling... again. If you have a text effect, text block, or range of text selected, the program will 
immediately begin to check the selection.

4. Choose the appropriate action for each misspelled word that appears in the Context box.



Check Spelling Dialog Box

The User Dictionary menu: This menu contains items that allow you to open create, or close a user 
dictionary. Clicking on this button will bring up the User Dictionary. 
The Context box: Inside this box you will see the context of the unknown or misspelled word, and the 
word will be highlighted.
The Page and Layer fields: If a misspelled or unknown word is found, these fields will show the page 
and layer where the word was found. To the right of these fields you will see either Text Block or Text 
Effects, telling you whether the word was found in a text block or text effect.
The Go To button: Clicking on this button will go to the page and layer where the misspelled or unknown 
word was found.
The Change to field: Inside this field you can correct the misspelled word.
Ignore button: Clicking on this button causes the program to skip the current occurrence of the word 
shown in the Context box, and continue checking the selection.
The Change button: Clicking on this button will change the misspelled or unknown word to the word that 
is entered in the Change to field.
The Suggest button: Clicking on this button tells the program to suggest a new spelling for the 
misspelled word.
The Add button: If the spell checker finds an unknown word, you can click on this button to tell the 
program to add this word to the current user dictionary.
The Suggest button: Clicking on this button tells the program to suggest a new spelling for the 
misspelled word.
The Suggested Words list box: Inside this list box, you will see a list of all suggested spellings for the 
misspelled word. Clicking on a word in the list box selects the word, and places it inside the Change to 
field. You can then click on the Change button to replace the misspelled word with the word in the Change
To field.
The User Dictionary box: This box will display the name of the current user dictionary.
The Cancel button: Clicking on this button will make the Check Spelling dialog box disappear.



Connection Socket Tool 

The Connection Socket tool, located inside the drawing tool palette, is used to place connection sockets 
that anchor connection lines. When you change the location of the connection sockets, the connection 
lines that are attached will stretch and stay attached. You can connect any number of connection lines to 
a single socket.
Connection sockets are normally visible on your artwork for your reference, but will not be printed. 
However, you can use the Show Options/Show Sockets command to hide and show the sockets on your 
artwork. When the sockets are visible, the Show Options/Show Sockets command will have a checkmark 
beside it.
Connection sockets can be grouped, moved, and deleted just like any other objects in your artwork. You 
can group sockets with other objects, such as flowchart shapes, so that when you edit your flowcharts the
connection lines will always remain attached to the objects. Sockets can even be added to existing 
connection lines to create T-junctions.
When you transform or reshape objects that contain connection sockets, the size of the sockets is not 
affected by the transformation. However, the location of the sockets is adjusted to reflect the 
transformation.
You can use any of the precision positioning tools to help you locate precise points on your drawing, while
placing the connection sockets. Modifiers are useful for placing connection sockets at object centers, 
corners, or on object outlines.
Sockets can also be inserted on existing connection lines to create T-junctions by simply clicking with the 
Connection Socket tool on any point along an existing connection line.
When you are placing library symbols that contain Connection Sockets and the Snap to Grid option is 
enabled in the View menu, the socket will snap to the grid instead of a handle on the symbol's bounding 
box. This allows you    accurately place irregularly shaped objects.

To place a connection socket

1. Select the Connection Socket tool.
2. Position the cross where you want to place a connection socket, and click the mouse button.

To delete connection sockets

1. Select the connection sockets that you want to delete.
2. Press the [Delete] key.

To insert a connection socket on a connection line

1. Select the Connection Socket tool.
2. Position the cross on the connection line where you want to place a connection socket, and click 

the mouse button.

Related Topics:
Connection Dialog Box
Connection Lines
Cutting Connection Lines
Selecting Connection Sockets and Connection Lines



Connection Dialog Box

Double-clicking the mouse button on any of the connection tools will bring up the Connection dialog box. 
Inside this dialog box, you can specify the types of joints, the line style and width, place arrowheads on 
connection lines, and set various options to control how connection lines are attached to sockets and 
objects.
The Line Style Box: Inside this box you specify the connection line style and width. You can select either 
the Single Line radio button to draw normal lines, or the Double Line or Shadowed radio buttons to draw 
thick connection lines that can be filled and outlined with color. You specify the width of the Double Line or
Shadowed connection line inside the Width field. When you choose the Single Line option, the connection
lines will be drawn as normal lines, and you can change the line thickness and color, add arrows, and 
assign dashes, in the same way as normal lines.
The Joint Style Box: Inside this box you select the desired connection line joint style. You have a choice 
of three joint styles: Mitered, Beveled, and Rounded. If you choose a beveled or rounded joint style, you 
can enter the radius of the joint inside the Radius field.
The Arrows Box: Inside this box you specify where you want arrowheads to be placed on your 
connection lines as you draw them. Arrowheads can be placed at the Start, End, or Both ends of the 
Double Line or Shadowed connection line. You specify the size of the arrowheads inside the Length and 
Width fields. If you do not want arrowheads to be drawn with your connection line, select the None radio 
button.
The Attach to Sockets checkbox: Selecting this option tells the program to attach the connection line to 
the sockets so that when you move the connecting socket the connection line will move with it. If this 
option is not selected, then you can draw connection lines between sockets, but the connection lines will 
not be anchored to the sockets and will not move with them.
The Connect to Objects checkbox: Selecting this option allows you to draw connection lines freely 
without having to first place connection sockets. When you select this option, the program will 
automatically place connection sockets when you click on an object to start or end a connection line. The 
connection line will be connected to the socket and the object. The connection line will move with the 
object.
The Center in Objects checkbox: This option is used in conjunction with the Connect to Objects. When 
you select this option, the program will automatically place connection sockets at the centers of objects 
when you click on an object to start or end a connection line. The connection line will be connected to the 
socket. This option will be disabled if the Connect to Objects option is not selected.



Connection Lines

There are two methods of anchoring connection lines to objects, depending on the options that you have 
selected inside the Connection dialog box.
You can place sockets on objects, and then click the mouse button to draw connection lines from one 
socket to another. The sockets are not grouped with the objects, and you must group the sockets with the 
objects if you want them to maintain their connection to the objects when you move the objects.
If you select the Connect to Objects option, you draw connection lines freely without having to first place 
connection sockets. The program will automatically place connection sockets on the outlines of objects 
when you click on an object to start or end a connection line. These sockets will be automatically grouped
with the objects. You can also select the Center in Object option in conjunction with the Connect to 
Objects to have the program anchor the connection lines at the centers of the objects.
In both of the above cases, the connection line will only be connected or plugged into the socket if the 
Attach to Socket option is selected inside the Connection dialog box. If the connection lines are not 
plugged into the sockets the connection lines will not maintain their connection to the sockets when you 
move the sockets.
The way that you draw connection line depends on the connection line tool that you select from the 
Connection pop-up tool palette.

Related Topics:
Adding Handles to and Removing from Ninety Degree Connection Lines
Connection Line Style
Cutting Connection Lines
Ninety degree Connection Lines
Selecting Connection Sockets and Connection Lines
Straight Connection Lines



Ninety-degree Connection Lines

Using the Ninety-degree Connection Line tool, you can draw ninety-degree connection lines. The ninety-
degree connection line can consist of any number of line segments. This means that you may have any 
number of ninety degree bends in your connection line.

To draw ninety-degree connection lines

1. Select the Ninety-degree Connection Line tool.
2. Position the cross where you want the connection line to start, and click the mouse button.

If the Connect to Objects option is selected inside the Connection dialog box, starting a connection 
line on an object will place a socket on the nearest outline of the object. The connection line will be 
drawn from the socket.

3. Move the mouse, and click the mouse button to introduce 90 degree bends in the connection line.
If the Connect to Objects option is selected inside the Connection dialog box, clicking on an object 
will place a socket on the nearest outline of the object. The connection line will be terminated at the 
socket.

4. Continue to click the mouse button to place 90 degree bends in the connection line, until you reach
the end of the connection line.

If the Connect to Objects option is selected inside the Connection dialog box, terminating a connection 
line on an object will place a socket on the nearest outline of the object. The connection line will be 
terminated at the socket.
Double-clicking the mouse button at the end will terminate the connection line and add a new socket.
The connection lines will only move with sockets, if the Attach to Socket option is selected inside the 
Connection dialog box.

Related Topics:
Adding Handles to and Removing from Ninety Degree Connection Lines
Connection Line Style
Connection Socket Tool
Cutting Connection Lines
Reshaping Ninety degree Connection Lines
Selecting Connection Sockets and Connection Lines
Straight Connection Lines



Straight Connection Lines

Using the Straight Connection Line tool you can draw straight connection lines. The straight connection 
line consists of a single line segment, and has no bends.

To draw straight connection lines

1. Select the Straight Connection Line tool.
2. Position the cross where you want the connection line to start, and click the mouse button.

If the Connect to Objects option is selected inside the Connection dialog box, starting a connection 
line on an object will place a socket on the nearest outline of the object. The connection line will be 
drawn from the socket.
Double-clicking the mouse button at the start will also add a socket at the starting point.

3. Move the mouse to where you want the connection line to end, and click the mouse button.
If the Connect to Objects option is selected inside the Connection dialog box, terminating a connection 
line on an object will place a socket on the nearest outline of the object. The connection line will be 
terminated at the socket.
Double-clicking the mouse button at the end will terminate the connection line and add a new socket.
The connection lines will only move with sockets if the Attach to Socket option is selected inside the 
Connection dialog box.

Related Topics:
Connection Line Style
Connection Socket Tool
Cutting Connection Lines
Ninety Degree Connection Lines
Selecting Connection Sockets and Connection Lines



Selecting Connection Sockets and Connection Lines

Connection sockets and connection lines can be selected by either clicking with the Pointer tool on a 
socket or connection line, or dragging a marquee to select several sockets and connection lines or 
handles simultaneously. 
A selected ninety-degree connection line will have an anchor handle at each of its corners or bends. You 
can use the Pointer tool to select the handles of the ninety-degree connection line. By selecting multiple 
anchor handles, you can drag the selected handles to reshape several bends simultaneously.
NOTE: You can always select a socket, even if it is located behind other objects.



Reshaping Ninety-Degree Connection Lines

When ninety-degree connection lines are selected, anchor handles will appear at each of their corners or 
bends. You can use the Pointer tool to reshape the connection line by dragging any of these handles to a 
new location.
You can also select multiple handles, and drag them to a new location to reshape several bends 
simultaneously.

Related Topics:
Cutting Connection Lines



Cutting Connection Lines

You can use the Scissors tool to cut connection lines anywhere along the connection line -- even into 
several segments. You can also cut the connection line at the sockets to break the connection between 
the line and the socket so that they no longer move together. The cut ends of connection lines are free to 
be attached to other sockets. 



Connection Line Style

Double-clicking the mouse button on any of the connection tools, or on an existing connection line, will 
bring up the Connection dialog box. You can then specify new connection line styles inside the dialog box.
When you finish specifying new connection parameters inside the dialog box, the connection line will be 
redrawn to reflect the new parameters.



Adding Handles to and Removing from Ninety-Degree Connection Lines

Using the Add Handle and Remove Handle tools, you can introduce bends, or remove bends from ninety-
degree connection lines. By adding and removing handles, you can get more control over the shape of 
the connection line.
You can only remove handles if the ninety-degree connection line has at least two bends.

To remove bends

1. Select the Remove Handle tool.
2. Position the cross on the bend that you want to remove, and click the mouse button.

The bend will be removed, and the connection line will change in shape.
3. Repeat steps 2 and 3 to remove additional bends.

To add bends

1. Select the Add Handle tool.
2. Position the cross on the ninety-degree connection line where you want to add a bend, and click 

the mouse button.
An anchor handle will be added to the connection line. Drag the new handles to create the new 
bend. The shape of the connection line will change to accommodate the new bend.

3. Repeat steps 2 and 3 to add additional bends.



Rulers

The HiJaak Draw program has two rulers, one across the top of and one along the left side of your 
document window.
You can use rulers to determine the distance between objects, the dimensions of an object, or to locate 
exact points on your artwork while drawing, reshaping, transforming, and moving objects. The exact 
location of the mouse, in X and Y coordinates, is always displayed at the bottom of your document 
window.
When you run HiJaak Draw for the first time, the rulers are visible. You can hide the rulers at any time by 
choosing the Screen Layout/ Show Rulers command from the View menu. When the rulers are visible, a 
checkmark appears beside the Show Rulers command inside the View menu. The Show Rulers 
command is a toggle command that turns the rulers on and off.
When the rulers are visible, they are marked with the units of measurement that you set inside the 
Preferences or Rulers and Grids dialog box. The ruler units can be points, picas, inches, and centimeters.
If you do not set your own ruler units the rulers will display the default units of measurement, which are 
inches. 
You can change the value of the ruler origin at any time during your work session. The ruler origin is the 
point at which the rulers reads 0 (zero). When you start HiJaak Draw, the ruler origin is located at the 
upper left corner of the artwork page. 

To show or hide the rulers

1. Choose the Screen Layout/Show Rulers command from the View menu.
A checkmark will appear beside the Show Rulers command inside the View menu when the rulers 
are visible.

Related Topics:
Ruler Guides



Ruler Units

As stated earlier, the default ruler units are inches. If you do not wish to work in inches, you can change 
the unit of measurement to either picas, points or centimeters, using the Preferences... or Rulers and 
Grids... command from the View menu. Setting the ruler units inside the Preferences dialog box will 
change the default ruler units. The units that you set will be saved in the HiJaak Draw Preferences file, 
HJDRAW.INI The Preferences file will be located in the same directory as the HiJaak Draw program. The 
ruler units that are saved in the Preferences file will affect all future documents until you change them. 
If you need to change the ruler units temporarily during your work session, you should use the Rulers and
Grids... command from the View menu. Changing the ruler units in this way will not change the default 
units.
The default ruler units will also appear inside all the dialog boxes that require units. Again, if you need to 
use other units instead of the default, you can choose different units inside these dialog boxes without 
affecting the default units of the rulers. 

To temporarily change the ruler units

1. Choose the Rulers and Grids... command from the View menu.
The Rulers and Grids dialog box will appear.

2. Specify the new ruler units inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.



Rulers and Grids Dialog Box

The Ruler Type Box: Inside this box you select one of the radio buttons to choose a new ruler unit of 
measurement. You have a choice of inches, decimal inches, points, centimeters, millimeters, and picas.
The Ruler Origin Box: Inside this box you specify the new ruler origin. There are three ways to set the 
ruler origin:

The Page Origin radio button to set the ruler origin to be the upper left corner of the artwork page. 
The Margins radio button sets the ruler origin to be the intersection point of the left and top margins.
The Custom radio button allows you to specify the X and Y coordinates of the new ruler origin. 

The Show Rulers checkbox: When this box is enabled, the Rulers are visible on your screen. This 
option does the same thing as the Screen Layout/Show Rulers option in the View menu.
The Show Grid checkbox: When this box is enabled, the Grid is visible on your screen. This option does
the same thing as the Show Options/Show Grid option in the View menu.
The Grid Spacing Box: Inside this box you can select one of the preset grid spacing radio buttons, or on 
the Custom radio button. Choosing the Custom radio button allows you to enter your own spacing inside 
the field next to it.
The Snap to Grid checkbox: This checkbox enables and disables the Snap to Grid option. When Snap 
to Grid is on, any drawing, reshaping or moving action will snap to the nearest grid point. This option does
the same thing as the Snap to Grid option in the View menu.
The Grid Lines Box: Inside this box, you can specify how many horizontal and vertical grid lines will be 
visible. Entering 16 in the fields means every 16th grid line will be visible. The rest of the grid lines will be 
represented by dots on the visible lines. This creates both visible and invisible grid line intersections. The 
numbers below the Grid Line Spacing fields tell you the distance between visible lines of grid points.



Ruler Origin

The ruler origin is the point where 0 (zero) is located on the rulers. When you run HiJaak Draw the ruler 
origin is located at the upper left corner of the artwork page. There are two techniques that you can use to
change the ruler origin:

Dragging the origin to a new location on the artwork page.
Choosing the Rulers and Grids... command from the View menu, and numerically entering the 
location of the new origin inside the Rulers and Grids dialog box.

If you drag to specify the new ruler origin, you can use any of the precision tools to help you place the 
new origin accurately.
You can change the location of the ruler origin at any time during your work session.

To change the ruler origin by dragging

Provided that the rulers are currently visible:
1. Position the pointer inside the box at the upper left corner of the artwork, where the rulers intersect.
2. Press and hold the mouse button down, and drag the pointer into the artwork area to the location 

where you want the new origin to be located.
As you drag you will see thin dotted lines inside the rulers moving with the movement of the mouse.
You can use any of the other precision tools such as the Snap to Grid, Snap to Handles, guides or 
modifiers to help you place the new origin accurately.

3. Release the mouse button when the new ruler origin is at the desired location.
The new ruler origin will be marked with the point zero on both rulers.

To change the ruler origin numerically

1. Choose the Rulers and Grids... command from the View menu.
The Ruler and Grids dialog box will appear.

2. Specify the new ruler origin inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.



Ruler Guides
Horizontal and vertical ruler guides can be placed anywhere in your artwork to help you align objects and 
text. When you move objects and text near the ruler guides, their bounds will automatically snap to the 
guide.
As you draw or transform objects, moving the black arrowhead near a ruler guide causes the arrowhead 
to snap to the guide. The cursor temporarily changes to a hollow arrowhead indicating that it has snapped
to the guide. Similarly, as you reshape or move objects, the pointer will snap to a ruler guide when it is 
near one. The pointer then temporarily changes to a hollow pointer to indicate that it has snapped to a 
guide.
There are two techniques for placing ruler guides onto your artwork:

You can drag the pointer from either the horizontal or vertical rulers to place guides, provided that 
the rulers are visible.
You can place guides numerically, by specifying the location of the horizontal or vertical guides 
inside the Guides dialog box.

Once you have placed your guides, you can move them to a new location at any time during your work 
session.
When you finish using any of the guides, you can remove them so that your artwork does not get 
cluttered.
You can double-click the mouse button on a guide at any time to bring up the Guides dialog box.

To place ruler guides by dragging from the rulers

1. Ensure the Show Options/Show Guides option is enabled in the View menu. There will be a 
checkmark beside Show Guides when it is enabled. If this option is not enabled, you will be able to 
place ruler guides, but they will be invisible.

2. Select the Pointer tool.
3. Position the pointer on top of either the horizontal or vertical rulers, press and hold the mouse 

button down, and drag the pointer onto the artwork.
4. Release the mouse button when the guide is at the desired location.

The ruler guide will be placed at the location where you released the mouse.
You can use any of the other precision tools such as Snap to Grid, Snap to Handles, rulers or 
modifiers to help you position the guides accurately.
You can repeat steps 2 and 3 until you have placed all the guides necessary.

To place ruler guides numerically

1. Choose the Guides... command from the View menu or double-click the mouse button on either 
ruler or any existing guides in your artwork.
The Guides dialog box will appear.

2. Specify all of the guide parameters you need in the dialog box.
Enter the guide location inside the Guide field and then click on either the horizontal or vertical Add 
button to add the guide to the list.

3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Column Guides
Moving Ruler Guides
Removing Ruler Guides





Moving Ruler Guides

As discussed earlier, you can move any of the ruler guides, that you had already placed on your artwork. 
There are two techniques for moving ruler guides:

You can use the Pointer tool and drag the guide to its new location.
You can specify the new location inside the Guides dialog box.

To move ruler guides by dragging

1. Select the Pointer tool.
2. Position the pointer on the guide that you want to move.

When the pointer is near the guide it will snap to it and the pointer will change to a hollow pointer.
3. Press and hold the mouse button, and drag the guide to a new location.
4. Release the mouse button when the guide is at the desired location.
5. Repeat steps 3 and 4 until you have moved all the guides that you want to move on your artwork.

To move the ruler guides numerically

1. Choose the Guides... command from the View menu or double-click the mouse on any of the 
existing guides in your artwork.
The Guides dialog box will appear.

2. Select the guide from the list of horizontal or vertical guides that you want to move.
3. Enter the value of the new location inside the Guide field, in the desired units.
4. Click on Change.
5. Repeat steps 2, 3, and 4 until you have moved all the guides that you want to move on your 

artwork.
6. Click on OK, or press [ENTER] when you are finished.



Removing Ruler Guides

Having too many guides can clutter the artwork. For this reason, HiJaak Draw lets you remove unwanted 
ruler guides once you are finished using them.
There are two techniques for removing ruler guides:

You can drag the guides back to the rulers that they came from.
You can delete them from the list of horizontal and vertical guides inside the Guides dialog box.

To remove ruler guides by dragging

1. Select the Pointer tool.
2. Position the pointer on the guide that you want to remove.

If the Snap to Guides option is turned on, the pointer will snap to a guide when it is near the guide, 
and the pointer will change to a hollow arrowhead.

3. Press and hold the mouse button down, and drag the guide back on top of the ruler that it came 
from.

4. Release the mouse button when the guide is on top of the ruler.

To remove ruler guides using the Guides dialog box

1. Choose the Guides... command from the View menu or double-click the mouse on any of the 
existing guides in your artwork.
The Guides dialog box will appear.

2. Select the guide from the list of horizontal and vertical guides that you want to remove.
3. Click on Remove.

Clicking on Remove All causes all the guides to be deleted.
4. Repeat steps 2 and 3 until you have removed all the guides that you want to remove from your 

artwork.
5. Click on OK, or press [ENTER] when you are finished.



Column Guides

Column guides appear as dotted rectangles that run vertically on your artwork. They are useful for 
aligning large blocks of text. Column guides are placed by choosing the Guides... command from the 
View menu and then specifying the number of columns and column spacing inside the Guides dialog box.
As you draw, reshape or transform objects, the column guide behaves just like any other guide. The 
objects and cursor will snap to the column guides when they are near them.
Once you have placed your column guides, you can reposition them at any time by bringing up the 
Guides dialog box and specifying the new column parameters. Double-clicking the mouse button on any 
of the guides in your artwork will bring up the Guides dialog box.
When you finish using any of the column guides you can remove them so that your artwork does not get 
cluttered.

To place column guides

1. Choose the Guides... command from the View menu or double-click the mouse on any of the 
existing guides in your artwork.
The Guides dialog box will appear.

2. Specify the column guide parameters inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

To remove column guides

1. Choose the Guides... command from the View menu or double-click the mouse on any of the 
existing guides in your artwork.
The Guides dialog box will appear.

2. Select the Column Guides checkbox to disable the Column Guides option.
3. Click on OK, or press [ENTER] when you are finished.

To reposition column guides

1. Choose the Guides... command from the View menu or double-click the mouse on any of the 
existing guides in your artwork.
The Guides dialog box will appear.

2. Enter the new value for the number of columns or column spacing inside the Number of Columns 
and Space Between Columns fields.

3. Click on OK, or press [ENTER] when you are finished.
The Guides dialog box will disappear and the column guides will be redrawn to reflect the new 
parameters specified in the dialog box.



Grids

Grids are a series of equally spaced dotted lines that run horizontally and vertically across your artwork. 
Each dot represents a grid line.
Grid lines, in conjunction with the Snap To Grid option, help you precisely draw, reshape, transform and 
move objects. 
When you run HiJaak Draw for the first time, grid lines are not visible. You can display the grid lines at 
any time by choosing the Show Options/Show Grid command from the View menu. When the grid lines 
are visible, there is a checkmark located beside the Show Grid command inside the View menu. 

To show or hide grids

1. Choose the Show Options/Show Grids command from the View menu.
A checkmark will appear beside the Show Grids command inside the View menu when the grids are
visible.

Related Topics:
Grid Spacing
Rulers and Grids Dialog Box
Snap to Grid



Guides Dialog Box

The Vertical Guides List Box: Inside this list box you will see a list of locations of all the vertical guides 
that are currently being used on your artwork.
The Horizontal Guides List Box: Inside this list box you will see a list of locations of all the horizontal 
guides that are currently being used on your artwork.
The Guide field: Inside this field you enter the location of the guide in the desired units.
The Add buttons: There is one Add button for each of the vertical and horizontal guides boxes. Once 
you enter the location of the guide inside the Guide field, you click on the appropriate Add button to add 
the guide to either the horizontal or vertical guide list.
The Change button: Clicking on this button causes the location of the selected guide in the list box to 
change to the location entered inside the Guide field.
The Remove button: Clicking on this button causes the guides selected in the list box to be deleted.
The Remove All button: Clicking on this button causes all the guides in the list boxes to be deleted.
The Column Guides checkbox: Selecting this checkbox tells the program that you want to use column 
guides. The Number of Columns field and Space Between Columns field will be enabled.
The Number of Columns field: Inside this field you enter the number of columns.
The Space Between Columns field: Inside this field you enter the spacing between columns in the 
desired units.
The Show Guides checkbox: When this box is enabled, the Guides are visible on your screen. This 
option does the same thing as the Show Options/Show Guides option in the View menu.



Grid Spacing

You can change the spacing of the grid lines by choosing the Rulers and Grids... command from the View 
menu and specifying the spacing inside the Ruler and Grids dialog box. You can also turn the grid lines 
on, if they are not displayed already, or enable the Snap to Grid option inside the Rulers and Grids dialog 
box.

To change the grid lines spacing

1. Choose the Rulers and Grids... command from the View menu.
The Rulers and Grids dialog box appears.

2. Specify the grid lines and spacing parameters inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.



Snap To Grid

Using grid lines, and their points of intersection, in conjunction with the Snap To Grid option will help you 
draw, reshape, transform and move objects more accurately. The grids do not need to be visible in order 
for you to use the Snap To Grid option.
As you move objects near grid lines or points, the anchor handles will snap to the nearest grid line or grid 
point of intersection.
As you transform objects near grid lines or points, the anchor handles will snap to the nearest grid line or 
point of intersection.
As you reshape objects near grid lines or points, the handles will snap to the nearest grid line or grid point
of intersection.
As you place control points near grid lines or points, the control points will snap to the nearest grid line or 
point of intersection.
The Snap To Grid option is enabled by choosing the Snap To Grid command from the View menu or by 
pressing [F5]. When the Snap To Grid option is enabled, a checkmark will appear next to the Snap To 
Grid command inside the View menu. The Snap To Grid command is a toggle command that turns the 
Snap To Grid option on and off.
The Snap To Grid option can be used in conjunction with any number of the other precision tools, such as
Snap To Handles, guides, cross hairs and modifiers.

To enable or disable the snap to grid option

1. Choose the Snap To Grid command from the View menu or press [F5].
A checkmark will appear beside the Snap To Grid command inside the View menu when the Snap 
To Grid option is enabled.



Snap To Handles

Using the Snap To Handle option helps you locate anchor handles of other objects more easily.
As you move objects, the pointer will snap to anchor handles of other objects in your artwork.
As you transform objects, the anchor handles will snap to anchor handles of other objects in your artwork.
As you reshape objects, the handles snap to anchor handles of other objects in your artwork.
As you place control points near other objects, the control points snap to anchor handles of other objects 
in your artwork if they are near them.
The Snap To Handles option is enabled by choosing the Snap To Handles command from the View menu 
or by pressing [F6]. When the Snap To Handles option is enabled, a checkmark will appear next to the 
Snap To Handles command inside the View menu. The Snap To Handles command is a toggle command 
that turns the Snap To Handles option on and off.
During reshaping and moving of objects, when the pointer snaps to an anchor handle it will temporarily 
change to a hollow pointer. During transforming and drawing, the black arrowhead will temporarily change
to a hollow arrowhead when it snaps to a handle.
The Snap To Handle may be used in conjunction with any of the other precision tools, such as the Snap 
To Grid, guides, cross hairs and modifiers.

To enable or disable the snap to handles option

1. Choose the Snap To Handles command from the View menu or press [F6].
A checkmark will appear beside the Snap To Handles command inside the View menu when the 
Snap To Handles option is enabled.



Cross Hairs

Cross hairs are a pair of dotted horizontal and vertical lines that intersect at the pointer and extend all the 
way the edges of the document window.
When you move the pointer, the cross hairs will move with it. Cross hairs can be used to draw objects at 
precise locations and with certain dimensions, to resize objects accurately and to organize objects within 
your artwork.
With the cross hairs and the Snap To Cross Hairs option, you can use the objects already on your artwork
as guides to constrain the drawing, reshaping, transforming or moving operations. When the horizontal or 
vertical cross hair passes over a handle, the handle exerts a pull on the cross hair, slightly magnetizing 
the cross hair to the handle. The other cross hair retains its unhampered movement. In this way, the 
horizontal and vertical cross hairs will snap to handles independent of each other. Moving both cross hairs
over handles will cause them both to snap to anchor handles.
When you first run HiJaak Draw the cross hairs are disabled. You can switch cross hairs on or off by 
choosing the Show Cross Hairs command from the View menu, at any time during your work session.
When you save your artwork, the status of the Snap To Cross Hairs is saved with the artwork. If the Snap 
To Cross Hairs option is enabled at the time when you save your artwork, then it will be enabled the next 
time you open the document, as well.
You can hide and show the cross hairs at any time during your work session by choosing the Show 
Options/ Show Cross Hairs command from the View menu. When the cross hairs are visible a checkmark 
will appear beside the Show Cross Hairs command.

To show or hide the cross hairs

1. Choose the Show Options/ Show Cross Hairs command from the View menu.
A checkmark will appear beside the Show Cross Hairs command inside the View menu when the 
rulers are visible.

To enable or disable the Snap to Cross Hairs option

1. Choose the Snap To Cross Hairs command from the View menu or press [F8].
A checkmark will appear beside the Snap To Cross Hairs command inside the View menu when the
Snap To Cross Hairs option is enabled.



Modifiers

HiJaak Draw provides nine modifiers that help you create complex drawings easily. They help you locate 
exact points in your artwork. They can also constrain drawing, transforming, reshaping and moving of 
objects. The modifiers are located inside the modifier palette, right next to the drawing tool palette.
It is important to understand that modifiers can be used during virtually any operation that you perform. 
For example, you can use location modifiers to pick up an object by its center or corner and then move it, 
or to draw a line from the center of a circle to a corner of a rectangle. You can also move an anchor 
handle of an object to the intersection point of two lines while reshaping an object. You can use modifiers 
to help you draw a line parallel or perpendicular to a side of a rectangle or to resize an object along a line 
already on the artwork.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



    Null Modifier

The Null modifier is used to turn off the action of all other modifiers. All the other precision tools can still 
be used. 
The Null modifier is assigned to the [1] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



Center Modifier

The Center modifier is used for locating exact centers of any objects in your artwork. To locate the center 
of an object, you need to identify the object by positioning the pointer on top of it or its outline, and HiJaak
Draw will locate the exact center for you. When the center of the object is located, the cursor changes to 
a hollow arrowhead, and a flashing dot appears at the object's center. You can then click the mouse 
button to snap the current action to the center that has been located. 
The Center modifier is assigned to the [2] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



Corner Modifier

The Corner modifier can be used to locate corners or anchor handles of objects. To locate a corner or 
anchor handle of an object, position the pointer on top of the object, near the desired corner or handle, 
and HiJaak Draw will locate the exact location for you. When the corner of the object is located, the 
cursor changes to a hollow arrowhead, and the anchor handle flashes. You can then click the mouse 
button to snap the current action to the center that has been located.
The Corner modifier is assigned to the [3] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



Outline Modifier

The Outline modifier helps you locate points on the outlines of objects. To locate a point on the outline of 
an object, position the pointer on top of the object near its outline, and HiJaak Draw will locate the outline
for you. When the outline of the object is located, the cursor changes to a hollow arrowhead, and a 
flashing dot appears on the outline. Moving the cursor will alter the position of the flashing dot. You can 
then click the mouse button to snap the current action to the outline position that has been located.
The Outline modifier is assigned to the [4] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



The Percent Segment Modifier

The Percent Segment modifier is used to locate exact distances along line segments of objects. To do 
this, you need to specify the distance along the segment as a percentage value or as a distance from an 
end point inside the Line Segment dialog box. Then position the pointer on the outline of the object. When
the flashing dot appears, click the mouse button. The pointer will automatically jump to the position on the
segment that you specified inside the dialog box.

To set the distance parameter for the Percent Segment modifier

1. Double-click the mouse on top of the Percent Segment modifier.
The Line Segment dialog box will appear.

2. Specify the distance inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

To use the same settings again, you need only select the modifier and place the pointer on top of 
the line you wish to modify.

The Percent Segment modifier is assigned to the [5] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Perpendicular modifier



The Line Segment Dialog Box

The Percent Box: Inside this box you can choose the position as a percent from an end point. You can 
choose either a preset percentage value by selecting one of the preset value radio buttons, or you can 
select the Custom radio button and specify your own percentage value inside the custom field.
The From End checkbox and field: You can select the From end checkbox to tell the program that you 
want to specify the position in terms of units of measurement. You then enter the measurement in the field
located beside the checkbox.



Intersection Modifier

The Intersection modifier helps you locate the intersection point of two or more straight line segments.
The Intersection modifier is assigned to the [6] key on your keyboard. 

To locate an intersection point

1. Select the modifier
2. Place the pointer on top of one of the lines you want to find the intersection of.
3. Click and drag to the other line, and release the mouse button.

HiJaak Draw will locate the exact intersection point for you and the current action automatically 
snaps to the intersection location.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Null modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



Perpendicular Modifier

The Perpendicular modifier helps you constrain the drawing of an object so that it remains perpendicular 
to line segments or circles, ellipses and arcs in your artwork. To identify the perpendicular constraining 
object, you need to position the pointer near the object or line segment. When a flashing dot appears on 
the line you wish to stay perpendicular to, you can click the mouse button to snap the current action to a 
perpendicular position.
The Perpendicular modifier is assigned to the [7] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier



Parallel/Tangent Modifier

The Parallel/Tangent modifier helps constrain the drawing of an object so that it remains tangent to circles
and ellipses or parallel to straight lines segments in your artwork. To identify the parallel/tangent 
constraining line, you need to position the pointer on top of the line. When a flashing dot appears on the 
line you wish to stay parallel or tangent to the constraint has been located. You can then click the mouse 
button to snap the current action to the constraint.
The Parallel/Tangent modifier is assigned to the [8] key on your keyboard.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Numeric Entry modifier
Outline modifier
Percent Segment modifier
Perpendicular modifier



The Numeric Entry Modifier

HiJaak Draw provides a Numeric Entry modifier that lets you locate exact points by specifying the 
horizontal and vertical co-ordinates (X and Y coordinates), horizontal and vertical offsets from the current 
pointer location, or a distance and angle from the current pointer location.
You can use this modifier while drawing to place objects at exact locations, while reshaping to move 
anchor handles to an exact location or while moving objects to place an object at a specific point on the 
artwork.
The Numeric Entry modifier is assigned to key [9].

To Position using the Numerical Entry modifier

1. With a drawing or transformation tool selected, select the Numeric Entry modifier.
2. Place the pointer on the page and click the mouse button.

The Numeric Entry dialog box appears. This dialog box may take one of two forms. If you are 
placing the first handle of a new object, the dialog box will only contain the Horizontal and Vertical 
Co-ordinates box. If you are any other point in a drawing action, or transformation, the dialog box 
will contain three fields.

3. Specify the co-ordinates of the next point using one of the three methods.
4. Click on OK.

Related Topics:
Accessing Modifiers
Applying Modifiers
Center modifier
Corner modifier
Hide or Show Modifier Palette
Intersection modifier
Null modifier
Outline modifier
Parallel/Tangent modifier
Percent Segment modifier
Perpendicular modifier



The Numerical Entry Dialog Box

The Horizontal and Vertical Co-ordinated box: This box allows you to specify the X and Y co-ordinates 
of the next anchor handle.
The Horizontal and Vertical Offset box: This box allows you to specify the offset distance from the last 
handle. If you entered 2" for the dx value and 1" for the dy value, the next handle or point would be placed
2 inches to the right and one inch down.
The Angle box: This box allows you to place the next point by specifying the angle from the current point,
and the distance between the two points. The angle can be specified either numerically or by dragging the
line within the angle dial until it reflects the desired angle.



Accessing Modifiers

Modifiers can be selected by using the mouse or by pressing the keys from [1] through [9]. If you look 
closely at the icons inside the modifier palette, you will see small numbers in the upper right corner of 
each button. These indicate the keyboard key that you can press to select the modifier.
If you prefer to choose your modifiers with the mouse, HiJaak Draw allows you to choose modifiers 
quickly, without having to go all the way to the modifier palette each time. A special pop-up modifier 
palette will appear at the pointer's location any time you press and hold the [Spacebar]. Once the pop-up 
palette appears, you can choose the desired modifier in the same manner as described previously. The 
pop-up palette will disappear once you select a modifier or release the [Spacebar].
You can also enable a special floating modifier palette that can be resized and moved anywhere on the 
screen by clicking on the bar along the top of the pop-up palette modifier palette.



Hide or Show the Modifier Palette

You can hide the modifier palette by choosing the Screen Layout/Show Modifiers command from the View
menu. When the modifier palette is visible a checkmark will appear beside the Show Modifiers command 
inside the View menu. The Show Modifiers command is a toggle command that shows and hides the 
modifier palette.
Modifiers can be used in conjunction with any number of the other precision tools, such as Snap to 
Handles/ Snap to Cross Hairs, and guides.
You can use modifiers to constrain the starting point of an operation, such as to begin drawing a line from 
the center of a circle, or to modify a point in the middle of the operation, such as to constrain the end point
of the line to the corner of a rectangle.



Applying Modifiers

To begin drawing objects at a certain location, simply select the desired drawing tool and the desired 
modifier. Then position the mouse in the drawing area, on the object to which you wish to constrain your 
actions, and start drawing your object. The starting point will be constrained to the closest object 
depending on the type of modifier that you have selected.
While you are in the process of drawing the object, you can select other modifiers to help you locate the 
next point in the drawing process.

To apply modifiers while drawing

There are two possible situations that will occur when you use a modifier while drawing.
If you are performing an action that requires you to drag the mouse, drag the pointer to the modifier 
palette, position the pointer on the desired modifier, and release the mouse button to select the modifier.
If you are in the process of moving the mouse, you simply move the mouse over the desired modifier, and
click the mouse button to select it.

To applying modifiers during other actions

You can even use modifiers while moving objects. As an example, you can use the Pointer tool with 
Center modifier to pick up an object by its center and then move it to a new location. Similarly, modifiers 
can be used during transformations to place transformation origins or to snap the transformation to a 
specific point.



Pointer Tool

The Pointer tool, located at the top of the drawing tool palette, has several modes of operation:
The Normal Selection mode lets you select objects and anchor handles, as well as move and 
reshape the selected objects and handles.
The Resize mode lets you resize all of the selected objects simultaneously.
The Shear/Rotate mode lets you shear and rotate all of the selected objects simultaneously.

When you select the Pointer tool from the drawing tool palette, you are immediately in the Normal 
Selection mode and may select any objects and anchor handles in the artwork.
Once you have selected an object, pressing and releasing the mouse button on any selected object for 
slightly longer than a normal click, will toggle between the Normal Selection mode and the Resize mode. 
In the Resize mode, the selected objects will be enclosed by the resize bounding box.
Once you are in the Resize mode, clicking on any of the handles of the Resize bounding box, without 
moving them, will toggle between the Resize mode and the Rotate/Shear mode. In the Rotate/Shear 
mode, you will see small direction arrows replace the anchor handles of the resize bounding box.

Related Topics:
Marquee Selection Tools
Rotating Objects with the Pointer Tool
Scaling Objects with the Pointer Tool
Selecting Anchor Handles
Selecting Hidden Objects
Selecting Objects with Pointer Tool
Shearing Objects with the Pointer Tool



Selecting Objects with the Pointer Tool

You can select objects in your artwork by using the Pointer tool and the Object Selection method. There 
are two different techniques for selecting objects with the Pointer tool:

You can click on an object to select the object.
You can drag out a marquee to select several objects simultaneously.

A selected object will be enclosed by a bounding box consisting of small black squares, called anchor 
handles.
Once you have selected an object, you can apply most of the HiJaak Draw commands, or use any of the 
reshaping, and transforming tools to change its attributes, size, appearance, and location.

Clicking to Select Objects

Using the Pointer tool with the Object Selection method, you can select a single object by clicking inside 
the object or on top of the object outline.
Since you can click on an area where several objects can overlap, the object that is actually selected 
depends on the type of objects that overlap:
Clicking on an area where only hollow objects overlap, the topmost hollow object will be selected.
Clicking on an area where hollow and filled objects overlap, the topmost filled object will be selected.
Clicking on an area where only filled objects overlap, the topmost filled object will be selected.
The above mentioned situations will only arise in the Preview display mode. In the Outline display mode, 
only the outlines of the objects will be shown, and hence you will only encounter the first situation.
Clicking on the outline of any object selects the object, regardless of where it is in the drawing order.

Related Topics:
Dragging Marquee to Select Multiple Objects
Extending Handle Deselection with Pointer Tool
Extending Handle Selection with Pointer Tool
Extending Object Deselection with Pointer Tool
Extending Object Selection with Pointer Tools
Marquee Selection Tools



Dragging a Marquee to Select Multiple Objects

You can use the Pointer tool with the Object Selection method, to select several objects by dragging a 
marquee around them. A marquee is a defined area used to select all objects and handles falling within it. 
The Pointer tool's marquee must be drawn by clicking in an empty area of the document window and 
dragging a rectangle around the objects to be selected. To select several objects that are on top of other 
objects use one of the Marquee Selection tools.
There are two marquee selection techniques that you can use when selecting objects with the Pointer 
tool:

Dragging the marquee such that it encloses all of the objects that you want to select.
Holding the [CTRL] key down and dragging the marquee so that it encloses or crosses the objects 
that you want to select.

Holding down the [ALT] key will temporarily switch to the Handle Selection method, so that you can 
quickly select handles instead of having to switch methods.
If you drag the marquee away from any the objects in your artwork and it does not cover any objects, then
all previously selected objects will become deselected.

To select multiple objects by dragging a marquee

1. Select the Pointer tool and the Object Selection method.
2. Position the pointer where you want to start the selection, press and hold the mouse button down, 

and drag diagonally.
As you drag, a dotted marquee will grow with the movement of the mouse.

3. Release the mouse button when the marquee encloses all of the objects that you want to select.



Extending Object Selection with the Pointer Tool

At times it will be necessary to select several objects that are far apart in your artwork. If you drag a 
marquee so that it encloses all of the objects, some unwanted objects will be selected. Holding down the 
[SHIFT] key while you click or drag a marquee extends the selection process, allowing you to select 
objects that are not near each other in the artwork without affecting any of the already selected objects.
Clicking or dragging a marquee over the empty space of the drawing while holding down the [SHIFT] key 
has no effect.

To extend object selection

1. Select the first object by clicking or dragging a marquee.
2. Hold down the [SHIFT] key and select the second object, by clicking or dragging a rectangular 

marquee.
3. Repeat step 2 until you have selected all of the desired objects.
4. Release the [SHIFT] key when you are finished selecting all of the desired objects.

Related Topics:
Extending Object Deselection with Pointer Tool



Extending Object Deselection with the Pointer Tool

Just as you can extend object selection with the [SHIFT] key, you can extend object deselection. At times 
you may need to deselect some of the objects that you have already selected without deselecting the 
others.
Holding down the [SHIFT] key while you click or drag a marquee over already selected objects will 
deselect them without affecting the other selected objects.

To extend object deselection

1. Select the three objects by holding down the [SHIFT] key and clicking or dragging a marquee.
2. Hold down the [SHIFT] key and deselect one of the objects, by clicking or dragging a rectangular 

marquee.
3. Repeat step 2 until you have deselected all of the unwanted objects.
4. Release the [SHIFT] key when you are finished deselecting all of the unwanted objects.

Related Topics:
Extending Object Selection with Pointer Tools



    Selecting Anchor Handles 

Selecting handles with the Pointer tool

You can select anchor handles of objects by using the Pointer tool and the Handle Selection method. As 
for selecting objects, there are two different techniques for selecting handles with the Pointer tool:

You can hold down the [SHIFT] key and click on the handle of an object to select the handle.
You can drag out a marquee to select several handles simultaneously.

A selected handle will appear as a small hollow square. Once you have selected a handle, you can apply 
most of the HiJaak Draw commands, or use any of the reshaping, and transforming tools to change the 
shape of the object.

Clicking to Select Anchor Handles

Using the Pointer tool regardless of the method selected, you can select a single anchor handle by 
holding the [SHIFT] key down and clicking on the handle. Selected anchor handles will appear as hollow 
squares.
There are two ways that you can select anchor handles:

You can hold the [SHIFT] key down and click the pointer where an anchor handle would normally 
appear when the object is selected.
You can select the object first and then select the anchor handles by holding the [SHIFT] key down 
and clicking the pointer on the desired anchor handles.

Objects can not be selected if you are using the Handle Selection method with the Pointer tool. You can 
only select objects when using the Object Selection method.

Related Topics:
Anchor Handles



Dragging a Marquee to Select Multiple Handles

You can use the Pointer tool with the Handle Selection method, to select several anchor handles by 
dragging a rectangular selection marquee such that it encloses all of the handles that you want to select.
Holding down the [ALT] key will temporarily switch to the Object Selection method, so that you can quickly
select objects instead of having to switch methods.
If you drag the marquee away from any the handles in your artwork and it does not enclose any handles, 
then all previously selected handles will become deselected. Deselected handles appear as small black 
squares.

To select multiple handles by dragging a rectangular marquee

1. Select the Pointer tool and the Handle Selection method.
2. Position the pointer where you want to start the selection, press and hold the mouse button down, 

and drag diagonally.
3. Release the mouse button when the marquee encloses all of the anchor handles that you want to 

select.



Extending Handle Selection with the Pointer Tool

At times you will need to select several anchor handles that are far apart in your artwork. Dragging a 
marquee over the handles will select some unwanted handles. You can hold down the [SHIFT] key as you
click to select several handles one at a time. As well, you can hold down the [SHIFT] key as you drag a 
marquee to select multiple handles at a time.
Once again, clicking or dragging a marquee over the empty space of the drawing while holding down the 
[SHIFT] key has no effect.

To extend handle selection

1. Select several handles either by clicking or dragging a marquee.
2. Hold down the [SHIFT] key and select other handles, by clicking or dragging a rectangular 

marquee.
3. Repeat step 2 until all of the desired handles are selected.
4. Release the [SHIFT] key when you are finished selecting all of the desired handles.



Extending Handle Deselection with the Pointer Tool

You can use the [SHIFT] key to extend handle deselection, in exactly the same way as for objects.

To extend handle deselection

1. Select several handles either by clicking or dragging a marquee.
2. Hold down the [SHIFT] key and deselect some of the unwanted handles, by clicking or dragging a 

rectangular marquee.
3. Repeat step 2 until all of the unwanted handles are deselected.
4. Release the [SHIFT] key when you are finished deselecting all of the unwanted handles.



Marquee Selection Tools

HiJaak Draw provides two different marquee selection tools for selecting objects and handles:

The Rectangular Marquee Selection tool lets you select multiple objects and handles by dragging a 
rectangular marquee so that it encloses the objects or handles that you want to select

The Freehand Marquee Selection tool lets you select multiple objects and handles by drawing a freehand 
marquee which encloses the objects or handles that you want to select.



Rectangular Marquee Selection Tool

The Rectangular Marquee Selection tool only drags out a rectangular marquee to select objects and 
handles.
You can use two different selection techniques to select objects in your artwork:

Dragging the rectangular marquee such that it encloses all of the objects that you want to select.
Holding the [CTRL] key down and dragging the rectangular marquee so that it crosses or encloses 
or crosses the objects that you want to select.

There is only one technique for selecting handles:
Holding down the [ALT] key while dragging the rectangular marquee so that it encloses all of the 
handles that you want to select.

To drag out a rectangular marquee, simply position the pointer anywhere on the artwork, press and hold 
the mouse button down, and drag diagonally. The way that you drag out the marquee is identical to that of
dragging out a marquee with the Pointer tool. 
You can use the [SHIFT] key with the Rectangular Marquee Selection tool, to extend the 
selection/deselection of objects and handles.

Related Topics:
Freehand Marquee Selection Tool



Freehand Marquee Selection Tool

The Freehand Marquee Selection tool only drags out a freehand marquee to select objects and handles.
You can use two different selection techniques to select objects in your artwork:

Dragging the freehand marquee such that it encloses all of the objects that you want to select.
Holding the [CTRL] key down and dragging the freehand marquee so that it encloses or crosses the
objects that you want to select.

There is only one technique for selecting handles:
Holding down the [ALT] key while dragging the freehand marquee so that it encloses all of the 
handles that you want to select.

To drag out a freehand marquee, simply position the pointer anywhere on the artwork, press and hold the 
mouse button down, and drag in any direction, enclosing the objects.
You can use the [SHIFT] key with the Freehand Marquee Selection tool, to extend the 
selection/deselection of objects and handles.

To drag a freehand marquee

1. Select the Freehand Marquee Selection tool.
2. Position the pointer where you want to start the selection, press and hold the mouse button down, 

and drag out the freehand marquee until it entirely encloses all of the objects that you want to 
select.

3. Release the mouse button when the freehand marquee encloses all of the desired objects.

Related Topics:
Rectangular Marquee Selection Tool



Selecting Grouped Objects

You can use the Pointer tool to select single objects within a group, or in the case where groups are 
nested within each other, to select groups from within the group hierarchy. 
Once you select an object or a group, you can apply any of the HiJaak Draw commands and operations 
to the them to change their size, appearance, location, and attributes. Once you are finished editing the 
object or group, you simply double-click the mouse button on the white space of the artwork to restore the
grouping hierarchy.

To select objects from within a single group

1. Select the Pointer tool and the Object Selection method.
2. Position the pointer on an object within the group, and click the mouse button.
3. Position the pointer on the object that you want to select, and double-click the mouse button.

You have now entered the group and the object will now be selected.
4. Double-click the mouse button anywhere on the white space of the artwork when you are finished.

The group will be restored.

To select groups from within nested groups

1. Select the Pointer tool and the Object Selection method.
2. Position the pointer on an object within the large group, and click the mouse button.
3. Double-click the mouse button at the same place to select the inner group.

You have now dropped down one level within the grouping hierarchy and one of the inner groups is 
selected.

4. Double-click the mouse button on an object within the group to select the object.
5. Double-click the mouse button anywhere on the white space of the artwork when you are finished.

Related Topics:
Reshaping Groups
Reversing the Selection of Objects
Selecting All Objects
Selecting Objects by Ink Color



Selecting All Objects 

The Select All command found inside the Edit menu, lets you select all objects in the artwork. You cannot 
use the Select All command to select all of the handles in your artwork.

To select all objects in your artwork

1. Choose the Select All command from the Edit menu, or press [CTRL][A].
All of the objects in the artwork will now be selected.

SHORTCUT: You can double-click the mouse on the Pointer tool, or either of the marquee tools, to 
quickly select all of the objects in your artwork.

Related Topics:
Deselecting All Objects
Reversing the Selection of Objects
Selecting Objects by Ink Color



Deselecting All Objects or Handles 

At times you may wish to deselect all of the already selected objects or handles in the artwork.

To deselect all objects or handles

1. Click the mouse anywhere on the white space of the drawing.
All of the anchor handles and objects that were previously selected will now be deselected.



Reversing the Selection of Objects

You can use the Reverse Select command, located in the Edit menu, to select all objects that are 
currently deselected, and deselect all objects that are currently selected. If no objects are currently 
selected in the artwork, then the Reverse Select command will cause all of the objects in the artwork to be
selected.

To reverse the selection of objects

1. Choose the Reverse Select command from the Edit menu, or press [CTRL][SHIFT][A].
All of the currently selected objects will be deselected, and all of the previously deselected objects 
will now be selected.

Related Topics:
Selecting All Objects
Selecting Objects by Ink Color
Selecting Grouped Objects



Selecting and Deselecting Objects by Ink Color

The Select by Ink... command, located inside the Edit menu, lets you select and deselect all objects that 
are filled with the same spot color. The Select by Ink... command cannot be used if there are no objects in
the artwork that are filled with a spot color.
In particular, you can use the Select by Ink... command to select all objects that are filled with a particular 
spot color and then change the fill color to an equivalent process color or another spot color.

To select objects by ink color

1. Choose the Select by Ink... command from the Edit menu, or press [CTRL][SHIFT][A].
The Select by Ink dialog box will appear and all of the spot colors that have been used in the 
artwork will be listed inside the dialog box.

2. Click on the spot color(s) to identify the objects that you want to select.
3. Click on Select.

All objects that are filled with the spot color(s) chosen in step 2 will be selected.

To deselect objects by ink color

1. Choose the Select by Ink... command from the Edit menu, or press [CTRL][SHIFT][A].
The Select by Ink dialog box will appear and all of the spot colors that have been used in the 
artwork will be listed inside the dialog box.

2. Click on the spot color(s) to identify the objects that you want to deselect.
3. Click on Deselect.

Related Topics:
Selecting All Objects
Selecting Grouped Objects
Reversing the Selection of Objects



Reshaping Rectangles and Ellipses

To reshape a rectangle or ellipse, you simply select the rectangle or ellipse and drag one of the anchor 
handles to a new location. Moving an anchor handle will change the height and the width of the rectangle 
or ellipse, and therefore the aspect ratio (height to width). You can hold down the [SHIFT] key while 
dragging the handle to keep the aspect ratio the same.
Reshaping an ellipse is identical to reshaping a rectangle because you are really reshaping the bounding 
rectangle of the ellipse.
You can also hold down the [CTRL][SHIFT] keys as you drag the handles to constrain the dragging to 
directions that are increments of 90 degrees.

Related Topics:
Drawing Rectangles
Drawing Ellipses
Reshaping Rounded Rectangles



Reshaping Rounded Rectangles

When you reshape rounded rectangles, you can either change the size and shape of the rectangle or the 
size of the corner radius.
You reshape a rounded rectangle in the same way as a basic rectangle. Changing the height or width of a
rounded rectangle will not affect the size of the corner radius.

Related Topics:
Changing Corner Radius of Rounded Rectangles
Reshaping Rectangles



Changing the Corner Radius of Rounded Rectangles

To change the size of the corner radius for rounded rectangles, you have two options:
You can select the rounded rectangle, and then drag one of the corner style handles to a new 
location.
You can double-click the mouse on the rounded rectangle causing the Corner Radius dialog box to 
appear, and then enter the new corner radius value inside the Corner Radius field.



Reshaping Circles

Since circles are simply ellipses, you reshape circles in exactly the same way as ellipses. When you 
reshape circles, you can change the shape of the circle into an ellipse. Holding down the [SHIFT] key 
while dragging the handles, will preserve the circular shape. 

Related Topics:
Drawing Circles
Reshaping Ellipses



Reshaping Lines

Reshaping a line involves selecting the line and then dragging one of the end handles to change the 
length and slope. If you only want to change the length of the line without changing its slope, hold down 
the [SHIFT] key as you drag one of the end handles.
You can also hold down the [CTRL][SHIFT] keys as you drag an anchor handle to constrain the dragging 
to directions that are increments of 90 degrees.

Related Topics:
Drawing Lines



Reshaping Arcs

To reshape arcs, you have two options:
You can select the arc, and then drag one of the handles of the bounding box to change the size 
and shape of the arc.
You can select the arc, and then drag one of the end points of the arc to change the start and end 
angle, without changing the shape.

Moving a handle of the bounding box changes the height and width of the arc, and therefore the aspect 
ratio (height to width of the arc). If you happen to be reshaping a circular arc and you change the height 
and width so that they are not the same anymore, then the circular arc becomes an elliptical arc. Holding 
the [SHIFT] key down while moving a handle of the bounding box, will keep the aspect ratio the same. 
However, holding the [SHIFT] key down while moving one of the arc end points will constrain the start and
end points on angles that are increments of 45 degrees.
You can hold down the [CTRL] and [SHIFT] keys while dragging the anchor handles of the bounding 
rectangle to constrain the dragging to directions that are increments of 90 degrees. In this way you can 
constrain the reshaping to the exact vertical or horizontal directions.

Related Topics:
Drawing Circular Arcs
Drawing Elliptical Arcs
Drawing Fillets



Reshaping Polygons

Changing the shape of polygons involves dragging the anchor handles to new locations. Only the polygon
segments that connect at the anchor handle that you move will change in length and slope, while all other
segments will remain unaffected.
The [SHIFT] key can be used to constrain the dragging of the handles to angles that are increments of 45 
degrees.

To reshape polygons

1. Select the Pointer tool.
2. Select the polygon whose anchor handles you want to drag.
3. Position the pointer on the anchor handle that you want to move, press and hold the mouse button 

down, and drag the handle to a new location.
4. Release the mouse button when the handle is at the desired location.
5. Repeat steps 2 and 3 until you have moved all the desired handles.

Related Topics:
Drawing Polygons
Drawing Regular Polygons and Stars



Reshaping Curves

To reshape curves, you have three options:
You can select the curve, and then drag anchor handles to a new location. Only the curve 
segments that connect at the anchor handle will change in shape, while all other curve segments 
will remain unaffected.
You can select the curve, click on an anchor handle to display the tangent lines, and then adjust the
length and direction of the tangent lines of the selected handle. Dragging the tangent control points,
will change the length and direction of the tangent lines at the handle.
You can use the Pointer tool with the Handle Selection method to drag any point on a curve 
segment to a new location to change the shape of the segment.

You are not limited to moving a single handle at a time. HiJaak Draw lets you select several handles, 
even from different objects, and drag them simultaneously. However, you can only adjust the tangent lines
of one anchor handle at a time. 
Holding down the [SHIFT] key as you drag will constrain the dragging to directions that are increments of 
45 degrees.

To drag an anchor handle

1. Select the Pointer tool.
2. Select the curve whose anchor handles you want to drag.
3. Position the pointer on the anchor handle that you want to move, press and hold the mouse button 

down, and drag the handle to a new location.
4. Release the mouse button when the handle is at the desired location.
5. Repeat steps 2 and 3 until you have moved all the desired handles.

To change tangent lines

1. Click on the anchor handle whose tangent lines you want to change.
2. Position the pointer on the tangent control point that you want to move, press and hold the mouse 

button down, and drag the tangent control point to a new location.
3. Release the mouse button when the tangent control point is at the desired location.

To drag a curve segment

1. Select the Pointer tool and the Handle Selection method.
2. Position the pointer on the curve segment, press and hold the mouse button down, and drag the 

segment.
3. Release the mouse button when the segment is the desired size and shape.

Related Topics:
Changing Anchor Handle Types
Changing Curve Segment Type



Changing Anchor Handle Types

You can reshape a curve by changing the type of anchor handles that make up the curve. For example, 
you may need to introduce a sharp corner or cusp into a smooth curve, or give the smooth curve more 
freedom by changing a symmetric handle to a smooth handle.
Anchor handle type is changed inside the Anchor Handles dialog box. HiJaak Draw lets you choose 
among three types of anchor handles; corner handles, smooth handles, and symmetric handles.

To change the anchor handle type

1. Select the curve that contains the anchor handle that you want to change.
2. Double-click the mouse button on the anchor handle whose type you want to change.

The Anchor Handles dialog box will appear.
3. Click on the Corner, Smooth, or Symmetric button to choose the new anchor handle type.



Anchor Handles Dialog Box

The Corner, Smooth, and Symmetric buttons: Clicking on one of these buttons specifies the new 
anchor handle type. A checkmark will appear beside the current handle type. These buttons will be 
disabled if the selected handle is an end handle of an open curve.
The Remove button: Clicking on this button will remove the anchor handle where you double-clicked the 
mouse button. This button will be disabled if there are only two handles left on the curve.
The Cut button: Clicking on this button will cut the curve at the anchor handle where you double-clicked 
the mouse button.



Changing Curve Segment Type

You can change the shape of a curve by changing any of the curve segments from line to curve and vice 
versa. When you change a curved segment to a line, the curve between the two handles becomes a 
straight line. If you change a line segment to a curve, the end handles are changed to a corner type and 
you can adjust the tangent lines to change the shape of the segment.

To change a curve segment type

1. Double-click the mouse button on the curve segment whose segment type you want to change.
The Bezier Segment dialog box will appear.

2. Click on either the Curve or Line buttons to choose the new segment type.



The Bezier Segment Dialog Box

The Line and Curve button: Clicking on these buttons changes the curve segment type. A checkmark 
will appear beside the current segment type.
The Cut button: Clicking on this button will cut the curve segment where you double-clicked the mouse 
button.
The Add Handle button: Clicking on this button will add an anchor handle at the point on the line 
segment where you double-clicked the mouse button.



Adding Handles to Objects

You can add anchor handles to existing curve segments to get a more precise curve shape. As well, you 
can add handles to objects, such as rectangles, ellipses, lines, and arcs. When you add a handle to these
objects, they will automatically be converted to curves for you.
There are two ways of adding anchor handles:

You can use the Add Handle tool located inside the transformation palette, and click on the 
segment where you want to add a handle.
You can double-click the mouse button on a bezier curve causing the Bezier Segments dialog box 
to appear. Then you click on the Add Handle button inside the Bezier Segments dialog box to add a
handle at the location where you double-clicked the mouse button.

To add handles using the Add Handle tool

1. Select the Add Handle tool.
2. Position the intersection of the cross at the point on the object's outline where you want to add the 

handle, and click the mouse button.
3. Repeat steps 2 and 3 to insert additional handles on the curve.

To add handles using the Bezier Segments dialog box:

1. Select the Pointer tool.
2. Select the curve to which you want to add an anchor handle.
3. Position the pointer at the point on the curve where you want to add the handle, and double-click 

the mouse button.
The Bezier Segments dialog box will appear.
4. Click on the Add Handle button.

Related Topics:
Removing Anchor Handles From Objects



Removing Anchor Handles from Objects

If you want to delete handles, you can do so by using the Remove Handle tool, located to the right of the 
Add Handle tool; or the Anchor Handles dialog box.

To remove handles using the Remove Handle tool

1. Select the curve from which you want to remove an anchor handle.
2. Select the Remove Handle tool.
3. Position the intersection of the cross on the anchor handle that you want to remove, and click the 

mouse button.
4. Repeat steps 2 and 3 to remove additional handles on the object.

To remove handles by using the Anchor Handles dialog box

1. Select the Pointer tool.
2. Select the curve from which you want to remove an anchor handle.
3. Position the pointer on the anchor handle that you want to remove, and double-click the mouse 

button.
The Anchor Handles dialog box will appear.

4. Click on the Remove button.

Related Topics:
Adding Handles to Objects



Aligning Anchor Handles

The Align Handles... command, located inside the Arrange menu, lets you align several selected handles 
by moving them to a location that is the average of their current locations.
Aligning handles is useful for aligning the edges of several objects, such as blocks of text, rectangles, 
ellipses, circles and groups of objects.

To align anchor handles

1. Select the anchor handles that you want to align.
2. Choose the Align Handles... command from the Arrange menu, or press [CTRL][SHIFT][K].

The Align Handles dialog box will appear.
3. Specify the alignment parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

To distribute handles

You can also distribute handles    using the Distribute Handles option in the Arrange menu. This option 
brings up a dialog box allowing you to distribute the selected handles either horizontally, vertically, or 
both. This option will place equal amounts of space between selected handles.

Related Topics:
Aligning Objects



Converting Objects to Curves

Using the Convert to Curve command found in the Objects menu, you can simultaneously convert any 
number of objects into bezier curves. You can even convert text effects into curves so that you can edit 
characters.
Converting objects to curves is useful when the shape that you want to create is a slight modification of 
one of the basic objects.
When the object has been converted to a curve, you can change the anchor handle type of any of the 
anchor handles on the curve, or change the curve segment type of any of the segments. You can also 
add handles to and remove handles from the curve.

To convert an object to a bezier curve

1. Select the objects that you want to convert to a bezier curve.
2. Choose the Convert to Curve command from the Objects menu.



Reshaping Groups

You can reshape a group by moving any of the anchor handles of the group bounding box. When you 
reshape a group of objects, each of the objects in the group is reshaped in exactly the same way, 
maintaining their relationship with other objects in the group.
Moving any of the corner handles changes the height and width of the group, and therefore the aspect 
ratio (height to width of the group). Holding down the [SHIFT] key as you drag a corner handle will keep 
the aspect ratio the same.
Moving the middle handles on the left and right edge of the bounding box lets you resize the group in only
the horizontal direction. Moving any of the middle handles on the top or bottom edges of the bounding box
lets you resize the group in only the vertical direction.

To reshape a group

1. Select the Pointer tool.
2. Select the group that you want to reshape.
3. Position the pointer on one of the bounding box handles, press and hold the mouse button down, 

and drag the handle to a new location.
4. Release the mouse button when the bounding box is the desired size.

Related Topics:
Selecting Grouped Objects
Grouping and Ungrouping Objects



Reshaping by Moving Several Anchor Handles Simultaneously

You can drag several selected handles of a single object, or several different objects simultaneously. To 
drag multiple handles, select all the handles that you want. Drag the selected handles in the same way 
that you would drag a single anchor handle. As you drag the handle the remaining selected handles will 
follow in unison. HiJaak Draw will move the handles, retaining the basic shape of the objects.

To drag multiple handles

1. Select the anchor handles that you want to drag.
2. Position the pointer on one of the selected anchor handles, press and hold the mouse button down,

and drag the handle to a new location.
3. Release the mouse button when the handles are at the desired location.



Joining Objects

The Join command, located inside the Arrange menu, has many uses:
You can join end handles of open objects.
You can join open objects that are placed end-to-end to create a single object.
You can close an open object
You can join text effects to curves.



Joining End Handles

The Join command lets you join two specific end handles of open objects to create a single object. The 
two end handles can lie on top of each other (coincident), or they can be separated from each other (non-
coincident).
When you join two open objects with non-coincident end handles, a line is drawn between the two 
handles.
Joining two open objects with coincident end handles joins the two objects to form a larger object and the 
coincident end handles are replaced by a single anchor handle.

To join non-coincident end handles

1. Select the two end handles.
2. Choose the Join command from the Arrange menu, or press [CTRL][J].

To join coincident end handles

1. Select the coincident end handles by dragging a marquee.
2. Choose the Join command from the Arrange menu, or press [CTRL][J].



Joining Multiple Objects Simultaneously

You can use the Join command to join selected open objects, such as arcs, lines, and cut portions of 
objects to form larger objects. The selected objects must be placed end-to-end with their end points 
touching in order for them to be joined.

To join objects together

1. Place the objects that you want to join so that their end points are touching.
2. Select the objects.
3. Choose the Join command from the Arrange menu, or press [CTRL][J].



Closing Open Objects

You can use the Join command to close open objects quickly and easily. When you close an open object, 
a line will be drawn between the two end handles.

To close an open object

1. Select the open object that you want to close.
2. Choose the Join command from the Arrange menu, or press [CTRL][J].



Joining Text Effects to Curves

You can use the Join command to join text effects with curves. When you join text effects with a single 
curve, the text will be wrapped along the curve and the baseline of the text will change to the shape of the
curve. The original curve will remain unaffected.
When you join text effects with two curves, the text will be fit between the two curves, and the curve that 
was drawn first will be used as the baseline. Again, the original curves will be unaffected. When you join 
text effects with two curves, make sure that the two curves are drawn in the same direction, otherwise the
text between the curves will appear twisted or flipped over.

To join text effects with curves

1. Select the text effects and curves that you want to join.
2. Choose the Join command from the Arrange menu, or press [CTRL][J].

If you join text with a single curve then the text will be wrapped along the curve. However, if you join
text with two curves, then the text will be fit between the curves.



Cutting Objects

Using the Scissors tool, located inside the transformation palette, you can cut the outline of objects. When
you cut closed objects, they will be split into one or more open objects.
You can cut objects at a single point, or drag a line across their outlines to cut them in several places. 
When you cut at a point where several object outlines overlap, HiJaak Draw allows you to choose which 
objects to cut.
The cut options are specified inside the Cut Objects dialog box. To specify the cut options, double-click on
the Scissors tool to bring up the Cut Objects dialog box.
After you cut an object, HiJaak Draw places two coincident (overlapping) anchor handles at the point 
where you cut the object. You can then drag either of the anchor handles to separate the two split 
segments.
You can cut curve segments by double-clicking the pointer where you want to cut the segment, and then 
click on the Cut button inside the Bezier Segments dialog box. As well, you can cut curves at anchor 
handles, by double-clicking the pointer on an anchor handle, and then click on the Cut button inside the 
Anchor Handles dialog box.

To cut objects at a single point

1. Select the Scissors tool.
2. Position the cross on the outline of the object that you want to cut, and click the mouse button.

The object will be cut according to the cutting options that you have specified inside the Cut Objects
dialog box.

To cut objects at several points simultaneously

1. Select the Scissors tool.
2. Position the cross where you want the cut to start, press and hold down the mouse button, and 

drag out a line across the objects that you want to cut.
3. Release the mouse button when the line crosses all the desired objects.

NOTE: You must re-join filled objects between multiple cuts. The Scissors tool applies itself to the object's
outline, creating line segments instead of smaller objects when you cut. This can alter the fills. To avoid 
any problems, select the new object and then Arrange/Join before cutting it again.



Cut Objects Dialog Box

The Topmost Object radio button: Selecting this radio button cuts the outline of only the topmost object.
The Selected Objects radio button: Selecting this radio button cuts through the outlines of all the 
objects.
The All Objects radio button: Selecting this radio button cuts the outlines of only the selected objects.
The Cut Point Only radio checkbox: Selecting this radio button cuts at a point only. You will not be able 
to drag out a cut line.



Rotating Objects

Rotating objects turns them in a clockwise or counterclockwise direction around a specified rotation origin.
The Rotate tool, located inside the transformation palette, lets you rotate objects by specifying a fixed 
origin about which the rotation is to take place, and then dragging in a clockwise or counterclockwise 
direction.
The Transform/Rotate command, located inside the Edit menu, lets you rotate objects numerically by 
specifying the rotate parameters inside the Rotate Objects dialog box.
While using the Rotate tool, you can rotate a copy of the objects by holding down the [C] key as you 
release the mouse button to complete the rotate operation. If you are numerically rotating the objects, you
can rotate multiple copies of the selected objects by specifying the number of copies inside the Rotate 
Objects dialog box. When you numerically rotate multiple copies, each successive copy will be rotated by 
the specified angle with respect to the last copy.
When you rotate copies of objects, the original objects will be unaffected by the rotation. Copying while 
rotating is useful for creating objects that are radially symmetric, such as the spokes of a bicycle wheel, or
the petals of a flower.

To rotate objects using the Rotate tool

1. Select the objects that you want to rotate.
2. Select the Rotate tool, position the cross at the location around which you want the rotation to take 

place, and click the mouse button.
The rotation origin will appear at the location where you clicked the mouse button.
Double-clicking on the rotate origin at any time will bring up the Rotate Objects dialog box.

3. Move the black arrowhead away from the rotation origin.
4. Press and hold the mouse button down, and drag the black arrowhead in a clockwise or 

counterclockwise direction around the rotation origin.
5. Release the mouse button when you are finished rotating.

To rotate objects numerically

1. Select the objects that you want to rotate.
2. Choose the Transform/Rotate... command from the Edit menu.

The Rotate Objects dialog box will appear.
3. Enter the rotation parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Rotating Anchor Handles
Rotating Objects with the Pointer Tool
Rotation Shortcuts



The Rotate Objects Dialog Box

The Preset Rotation Angle radio buttons: You can select any of these radio buttons to choose a 
standard rotation angle. Positive angles denote rotation in a clockwise direction. Negative angles denote 
a counter-clockwise rotation.
The Custom radio button: Selecting this radio button tells the program that you want to specify a custom
rotation angle.
The Custom field and dial: Inside the custom field you can enter your custom rotation angle in degrees. 
You can also specify the angle by dragging the dial in a clockwise or counterclockwise direction.
The Objects Center checkbox: Selecting this checkbox tells the program that you want to use the center
of the objects as the origin, and to disregard the current reflection origin location.
The Copy button and field: Clicking on this button tells the program that you want to rotate copies of the
selected objects. You enter the number of copies inside the Copy field.



Rotating Objects with the Pointer Tool

Since you will rotate objects extensively while creating your artwork, HiJaak Draw lets you rotate with the 
Pointer tool, without having to select another tool.
You can rotate a copy of the selected objects instead of the original objects, by holding down the [C] key 
as you release the mouse to terminate the rotate operation.

To rotate objects by using the Pointer tool

1. Select the objects that you want to rotate.
2. Position the pointer on one of the selected objects and press and release the mouse button for 

slightly longer than a normal click.
You are now in Resize mode. The resize bounding box will appear and will enclose all of the 
selected objects.

3. Position the pointer on any one of the resize bounding box anchor handles, and click the mouse 
button.
You are now in Rotate/Shear mode. The rotate/shear bounding box will appear and will enclose all 
of the selected objects and a rotation origin. This bounding box will have small direction arrows at 
the locations where anchor handles used to be located.

4. Drag the rotation origin to the location around which you want the rotation to take place, and 
release the mouse button.

5. Position the pointer on any of the corner anchor handles, press and hold the mouse button, and 
drag in a clockwise or counterclockwise direction to rotate the objects.

6. Release the mouse button when you are finished rotating.

Related Topics:
Rotating Objects



Rotating Anchor Handles

You can use the same Rotate tool and Rotate Objects dialog box to rotate anchor handles.
The procedure for rotating anchor handles is exactly the same as that of objects, except that you cannot 
rotate a copy of the handles.



Rotation Shortcuts

This section summarizes the various shortcuts that you can use to access the Rotate Objects dialog box.
Double-clicking the mouse on the Rotate tool brings up the Rotate Objects dialog box, and the rotation 
origin is assumed to be located at the center of the selected objects.
Once you place the rotation origin, double-clicking on the rotation origin at any time brings up the Rotate 
Objects dialog box.
After you select the Rotate tool, double-clicking the mouse on the artwork brings up the Rotate Objects 
dialog box, and the rotation origin is assumed to be located at the center of the selected objects.



Scaling Objects

Scaling changes the size of objects in a horizontal direction, vertical direction, or in both simultaneously.
The Scale tool, located inside the transformation palette, lets you scale objects by specifying a fixed origin
from which the scaling is to take place, and then dragging away from the origin to scale the objects.
The Transform/Scale... command, located inside the Edit menu, lets you scale objects numerically by 
specifying the scaling parameters inside the Scale Objects dialog box.
When you scale objects, you can scale the objects uniformly, keeping the aspect ratio the same, or non-
uniformly, changing the aspect ratio of the objects.
You can use the [SHIFT] key to scale the objects uniformly, or to constrain the scaling to directions that 
are increments of 45 degrees.
While you are using the Scale tool, you can scale a copy of the selected objects by holding down the [C] 
key as you release the mouse button to complete the scaling operation. If you are numerically scaling the 
objects, you can scale multiple copies of the selected objects by specifying the number of copies inside 
the Scale Objects dialog box. When you scale multiple copies, each successive copy will be scaled with 
respect to the last copy.
When you scale copies of objects, the original objects will remain in their original position and will be 
unaffected by the scaling. Copying while scaling is useful for creating different sized images of the same 
object.
HiJaak Draw has the ability to scale the outline thickness of the objects to reflect the new size of the 
objects. Enlarging the objects will cause the outline to become thicker, while reducing the objects causes 
the outline to become thinner. To scale the outline with the object, you need to enable the Scale Line 
Width option inside the Preferences dialog box. If you are scaling objects numerically, you can choose the
Scale Line Width option inside the Scale Objects dialog box.

To scale objects by using the Scale tool

1. Select the objects that you want to scale.
2. Select the Scale tool and position the cross at the location about which you want the scaling to take

place, and click the mouse button.
3. Move the black arrowhead away from the scale origin.
4. Press and hold the mouse button down, and drag the black arrowhead in the direction that you 

want to scale the objects.
5. Release the mouse button when you are finished scaling.

To scale objects numerically

1. Select the objects that you want to scale.
2. Choose the Transform/Scale... command from the Edit menu.
The Scale Objects dialog box will appear.
3. Enter the scaling parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Scaling Anchor Handles
Scaling Objects with the Pointer Tool



Scaling Shortcuts



The Scale Objects Dialog Box

The Percent radio buttons: You can select these radio buttons to quickly choose a standard scaling 
factor.
The Custom radio button: Selecting this radio button tells the program that you want to specify a custom
scaling factor.
The horizontal, and vertical fields: Inside these fields you enter the custom horizontal and vertical 
scaling factors as percentages.
The Uniform Scale checkbox: Selecting this checkbox tells the program that you want to scale the 
selected objects uniformly. You enter the custom uniform scaling factor in either the horizontal or vertical 
fields. You only need to enter one value and the value that you enter will be used for both directions.
The Preserve line width checkbox: Selecting this checkbox tells the program not to scale the outline 
with the objects.
The Scale line width checkbox: Selecting this checkbox tells the program to scale the outline with the 
objects.
The Copy button and field: Selecting this button tells the program that you want to scale copies of the 
selected objects. You enter the number of copies inside the Copy field.



Scaling Objects with the Pointer Tool

Since you will scale objects extensively while you create your artwork, HiJaak Draw lets you scale with 
the Pointer tool, without having to select another tool.
The Pointer tool has three modes of operation: the Normal Selection mode, the Resize mode, and the 
Rotate/Shear mode. In the Resize mode you can scale selected objects in a horizontal direction, vertical 
direction, or both.
You can scale a copy of the selected objects instead of the original objects, by holding down the [C] key 
as you release the mouse to terminate the scaling operation.

To scale objects by using the Pointer tool

1. Select the objects that you want to scale.
2. Position the pointer on one of the selected objects and press the mouse button for slightly longer 

than a normal click and release the mouse button.
You are now in Resize mode. The resize bounding box will appear and will enclose all of the selected 

objects.
3. Position the pointer on any of the anchor handles of the bounding box, press and hold the mouse 

button, and drag to scale the selected objects.
4. Release the mouse button when you are finished scaling.

Related Topics:
Scaling Objects



Scaling Anchor Handles

You can use the same Scale tool and Scale Objects dialog box to scale anchor handles. When you scale 
anchor handles, you are merely moving the anchor handle apart, and not scaling them in size.
The procedure for scaling anchor handles is exactly the same as that of objects, except that you cannot 
scale a copy of the handles.



Scaling Shortcuts

This section summarizes the various shortcuts that you can use to access the Scale Objects dialog box.
Double-clicking the mouse on the Scale tool brings up the Scale Objects dialog box, and the scale origin 
is assumed to be located at the center of the selected objects.
Once you place the scale origin, double-clicking on the scale origin at any time brings up the Scale 
Objects dialog box.
After you select the Scale tool, double-clicking the mouse on the artwork brings up the Scale Objects 
dialog box, and the scale origin is assumed to be located at the center of the selected objects.



Shearing Objects

Shearing objects slants the objects in a horizontal direction, vertical direction, or both. 
The Shear tool, located inside the transformation palette, lets you shear objects by specifying a fixed 
origin from which the shearing is to take place, and then dragging away from the origin to shear the 
objects.
The Pointer tool lets you shear objects in either the horizontal or vertical directions. 
The Transform/Shear... command, located inside the Edit menu, lets you shear objects numerically by 
specifying the shearing parameters inside the Shear Objects dialog box.
While you are using the Shear tool, you can shear a copy of the selected objects by holding down the [C] 
key as you release the mouse button to complete the shearing operation. If you are numerically shearing 
the objects, you can shear multiple copies of the selected objects by specifying the number of copies 
inside the Shear Objects dialog box. When you shear multiple copies, each successive copy will be 
sheared with respect to the last copy.
When you shear copies of objects, the original objects will be unaffected by the shearing.

To shear objects using the Shear tool

1. Select the objects that you want to shear.
2. Select the Shear tool and position the cross at the location from which you want the shearing to 

take place, and click the mouse button.
The shear origin will appear at the location where you clicked the mouse button.

3. Move the black arrowhead away from the shear origin.
4. Press and hold the mouse button down, and drag the black arrowhead in the direction that you 

want to shear the objects.
5. Release the mouse button when you are finished shearing.

To shear objects numerically

1. Select the objects that you want to shear.
2. Choose the Transform/Shear... command from the Edit menu.

The Shear Objects dialog box will appear.
3. Enter the shearing parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Shearing Anchor Handles
Shearing Objects with Pointer Tool
Shearing Shortcuts



The Shear Objects Dialog Box

The Shear Angle field and dial: Inside the Shear Angle field you enter your custom shear angle in 
degrees. You can also specify the angle by dragging the dial in a clockwise or counterclockwise direction. 
The shear angle is the angle that is to be applied to the selected objects, relative to a line that is 
perpendicular to the shear direction.
The Custom radio button: Selecting this radio button tells the program that you want to specify a custom
shearing direction.
The Custom field and dial: Inside the Custom field you enter your custom shear direction in degrees. 
You can also specify the custom shear direction by dragging the dial in a clockwise or counterclockwise 
direction.
The horizontal, and vertical direction radio buttons: You can select these radio buttons to choose a 
horizontal or vertical shear direction.
The Copy button and field: Selecting this button tells the program that you want to shear copies of the 
selected objects. You enter the number of copies inside the Copy field.



Shearing Objects with the Pointer Tool

HiJaak Draw lets you shear with the Pointer tool, without having to select another tool.
You can shear a copy of the selected objects instead of the original objects, by holding down the [C] key 
as you release the mouse to terminate the shear operation.

To shear objects by using the Pointer tool

1. Select the objects that you want to shear.
2. Position the pointer on one of the selected objects and press and release the mouse button for 

slightly longer than a normal click.
You are now in Resize mode. The resize bounding box will appear and will enclose all of the 
selected objects.

3. Position the pointer on any one of the resize bounding box anchor handles, and click the mouse 
button.
You are now in Rotate/Shear mode. The rotate/shear bounding box will appear and will enclose all 
of the selected objects. This bounding box will have small direction arrows at the locations where 
anchor handles used to be located.

4. Position the pointer on any of the middle anchor handles, press and hold the mouse button, and 
drag to shear the objects.

5. Release the mouse button when you are finished shearing.

Related Topics:
Shearing Objects



Shearing Anchor Handles

You can use the same Shear tool and Shear Objects dialog box to shear anchor handles.
The procedure for shearing anchor handles is exactly the same as that of objects, except that you cannot 
shear a copy of the handles.



Shearing Shortcuts

Double-clicking the mouse on the Shear tool brings up the Shear Objects dialog box, and the shear origin 
is assumed to be located at the center of the selected objects.
Once you place the shear origin, double-clicking on the shear origin at any time brings up the Shear 
Objects dialog box.
After you select the Shear tool, double-clicking the mouse on the artwork brings up the Shear Objects 
dialog box, and the shear origin is assumed to be located at the center of the selected objects.



Reflecting Objects

Reflecting objects creates a mirror image of the objects about a specified axis of reflection.
HiJaak Draw provides two techniques for creating mirror images of objects:
The Reflection tool, located inside the transformation palette, lets you reflect objects by specifying a 
reflection origin and then specifying the axis of reflection.
The Transform, Reflect... command, located inside the Edit menu, lets you reflect objects numerically by 
specifying the reflection parameters inside the Reflect Objects dialog box.
HiJaak Draw lets you reflect a copy of the selected objects. While you are using the Reflection tool, you 
can reflect a copy by holding down the [C] key as you release the mouse button to complete the reflection
operation. If you are numerically reflecting the objects, you can click on Copy inside the Reflect Objects 
dialog box to tell the program to reflect a copy, instead of the actual objects. When you reflect a copy, the 
original objects will be unaffected by the reflecting. Copying while reflecting is useful for creating a mirror 
image of the same object.

To reflect objects using the Reflection tool

1. Select the objects that you want to reflect.
2. Select the Reflection tool and position the cross on one endpoint of the invisible axis of reflection, 

and click the mouse button.
The reflection origin will appear at the location where you clicked the mouse button.
You can move the reflection origin at this point, by dragging it to a new location.

3. Move away from the origin, click and hold the mouse button down to specify another point on the 
axis of reflection.

4. Drag the black arrowhead.
5. Release the mouse button when the image is in the desired position.

To reflect objects numerically

1. Select the objects that you want to reflect.
2. Choose the Transform/Reflect... command from the Edit menu.

The Reflect Objects dialog box will appear.
The Reflect Objects dialog box will show the reflection parameters of the last reflect operation. If no 
reflect operation was performed previously, then it will display the default parameters.
The reflection will be performed from the center of the selected objects unless the reflection origin 
was placed.

3. Enter the reflection parameters inside the dialog box.
As shown, the object will be reflected about a custom axis of reflection of 60 degrees.

4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Reflecting Anchor Handles
Reflection Shortcuts



Reflecting Anchor Handles

You can use the same Reflection tool and Reflect Objects dialog box to reflect anchor handles. Reflecting
anchor handles is useful for creating mirror images of only a portion of the object.
The procedure for reflecting anchor handles is exactly the same as that of objects, except that you cannot
reflect a copy of the handles.

Related Topics:
Reflecting Objects
Reflection Shortcuts



Reflection Shortcuts

This section summarizes the various shortcuts that you can use to access the Reflect Objects dialog box.
Double-clicking the mouse on the Reflection tool brings up the Reflect Objects dialog box, and the 
reflection origin is assumed to be located at the center of the selected objects.
Once you place the reflection origin, double-clicking on the reflection origin at any time brings up the 
Reflect Objects dialog box.
After you select the Reflection tool, double-clicking the mouse on the artwork brings up the Reflect 
Objects dialog box, and the reflection origin is assumed to be located at the center of the selected 
objects.

Related Topics:
Reflecting Anchor Handles
Reflecting Objects



Skewing Objects

The Skew tool, located inside the transformation palette, allows you to stretch, slant or twist objects 
uniformly. This is done by dragging any number of the skew bounding box handles, one at a time, to a 
new location. The selected objects will be distorted to reflect the shape of the new bounding box.
While using the Skew tool, you can skew a copy of the objects by holding down the [C] key as you 
release the mouse button to complete the skew operation. The original objects will remain in their original 
positions and will be unaffected by the skew.

To skew objects using the Skew tool

1. Select the objects that you want to skew.
2. Select the Skew tool.
3. Position the pointer on one of the corner handles of the bounding box, press and hold the mouse 

button down, and drag the handle to a new location.
4. Release the mouse button when the handle is at the desired location.
5. Repeat steps 3 and 4 until all of the corner handles have been moved and the new bounding box is

the desired size and shape.
6. Click the mouse button away from the bounding box to exit skew mode when you are finished.

Related Topics:
Skewing Anchor Handles



Skewing Anchor Handles

You can use the Skew tool and to skew anchor handles. When you skew handles, the selected anchor 
handles are simply redistributed to reflect the new skew bounding box.
The procedure for skewing anchor handles is exactly the same as that of objects, except that you cannot 
skew a copy of the handles. 



Aligning Objects

Using the Align Objects... command located inside the Arrange menu, or pressing [CTRL][K], you can 
precisely align selected objects horizontally and vertically.
Objects can be aligned to each other, to the page or to the grid. You can also align objects to each other 
with the grid or to the page with the grid by selecting the To Grid checkbox and one of the other options.
When you align objects to each other and to the grid, the bounds of the objects are lined up as specified, 
snapping to the nearest grid point.
Similarly, if you align objects to the page and to the grid, the bounds of the objects are lined up with the 
page in the way that you specify snapping to the nearest grid point.
If you align objects just to the grid, you specify the way that the bounds of the objects line up with the 
horizontal and vertical grid lines.

To align objects

1. Select the objects that you want to align.
2. Choose the Align Objects... command from the Arrange menu, or press [CTRL][K].

The Align Objects dialog box will appear.
3. Specify the alignment options inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Distributing Objects
Nudging Objects



The Align Objects Dialog Box

The Vertical Alignment Box: Inside this box you select the desired vertical alignment option: by the left 
sides, right sides, centers, or none.
The Horizontal Alignment Box: Inside this box you select the desired horizontal alignment option: by the
tops, bottoms, centers, or none.
The To Each Other checkbox: You can align the bounds of the selected objects to each other by 
selecting the To Each Other checkbox and selecting the desired alignment.
The To Page checkbox: You can align the bounds of the selected objects to the page by selecting the To
Page checkbox and selecting the desired alignment option.
The To Grid checkbox: You can align the bounds of the selected objects to the nearest grid points by 
selecting the To Grid checkbox and selecting the desired alignment option. 
The Preview Box: The Preview Box displays a sample of the way that the objects will be aligned 
according to the parameters that you have specified inside the Align Objects dialog box.



Distributing Objects

Using the Distribute Objects... command, located inside the Arrange menu, you can distribute objects 
horizontally and vertically in your artwork.
You specify the way that the objects are distributed horizontally and/or vertically, inside the Distribute 
Objects dialog box. If you distribute objects vertically by their tops, the tops of all the objects would be 
equally spaced apart.

To distribute objects

1. Select the objects that you want to distribute.
2. Choose the Distribute Objects... command from the Arrange menu.

The Distribute Objects dialog box will appear.
3. Specify the distribute options inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Aligning Objects
Distributing Handles



The Distribute Objects Dialog Box 

The Horizontal Distribution Box: Inside this box you select the desired horizontal distribution option: by 
the left sides, right sides, centers, spacing or none. The spacing option distributes the objects in the 
horizontal direction such that the spacing between the objects is the same. When the objects overlap, the 
distribute by spacing will in effect be negative spacing, or in other words the amount of overlap will be the 
same.
The Vertical Distribution Box: Inside this box you select the desired vertical horizontal distribution 
option: by the tops, bottoms, centers, spacing or none. The spacing option distributes the objects in the 
vertical direction such that the spacing between the objects is the same. When the objects overlap, the 
distribute by spacing will in effect be negative spacing, or in other words the amount of overlap will be the 
same.



Grouping and Ungrouping Objects

You may combine several objects to form a group that is treated as a single object. Any operations that 
you perform on the group will be performed on all the objects within the group.
Clicking on any object in the group results in all the objects in the group being selected. When a group is 
selected, only a single highlighting box will appear enclosing all the objects in the group.
You can have groups within groups to form larger groups. HiJaak Draw remembers the sub-levels of 
grouping for you so that when you use the Ungroup command, groups are ungrouped one level at a time.
You should group objects once you have created a complete entity, such as logos. When you create a 
group, you prevent the individual components from being accidentally changed or selected. The objects 
within the group will always maintain their relative positioning with respect to other objects in the group.
At times you may want to make changes to several objects within the group without changing them all. To 
do this, you simply double-click the mouse on an object within a group to select the individual object, or 
you can ungroup the objects. 
When you save your artwork, all the objects that were grouped will be saved as groups. The next time 
that you open your artwork, the objects will still be grouped.

To group objects

1. Select the objects that you want to group.
2. Choose the Group command from the Arrange menu, or press [CTRL][G].

To ungroup objects

1. Select the groups that you want to ungroup.
2. Choose the Ungroup command from the Arrange menu, or press [CTRL][U].

Related Topics:
Reshaping Groups
Selecting Grouped Objects



Hiding and Showing Objects

You may hide objects so that they are not visible in your artwork. If there are objects that are obstructing 
your view of a portion of the artwork, you can hide the obstructing objects. You can also hide several of 
the objects that are close together or overlap so that you do not accidentally select or alter one of the 
objects while you work with another.
Objects will remain hidden until you choose to show them again. When you decide to show the objects 
again, all previously hidden objects will be shown. You can not show the objects one at a time.
NOTE: The Hide and Show All commands can not be undone with the Undo command. If you accidentally
Hide objects, choose the Show All command to undo the Hide.

To hide objects

1. Select the objects that you want to hide.
2. Choose the Hide command from the Objects menu, or press [CTRL][H].

To show all objects

1. Choose the Show All command from the Objects menu, or press [CTRL][SHIFT][H].



Locking and Unlocking Objects

You may lock objects so that they can not be moved. If several objects overlap, you can lock some of the 
objects so that you can select the remaining objects more easily.
You can select the Select Objects command in the Preferences dialog box, and then you will be able to 
select, but not move locked objects. This allows you to perform some actions on them, without unlocking 
the objects. If this option is not selected, the    locked objects can not be selected.
You can lock individual objects or groups of objects. When you save your artwork, all the objects that 
were locked will be saved as locked objects. The next time that you open your artwork, those objects will 
still be locked.
The Unlock All command can be used to unlock all the previously locked objects.
NOTE: The Lock and Unlock All commands can not be undone with the Undo command. If you 
accidentally Lock objects, choose the Unlock All command to undo the Lock.

To lock objects

1. Select the objects that you want to lock.
2. Choose the Lock command from the Objects    menu, or press [CTRL][L].

To unlock all objects

1. Choose the Unlock All command from the Objects menu, or press [CTRL][SHIFT][L].



Moving Objects

You can use the Pointer tool to change the position of a selected object, several objects or groups of 
objects by dragging them to a new location on the artwork.
You can use any of the precision tools to help you locate precise points or to move objects in specific 
relationships to other objects on your artwork.
The Snap to Handle option and Snap to Cross Hair options are useful for moving objects and aligning 
them to the handles and bounds of other objects.
Modifiers are useful for moving objects to exact locations, centers, corners, outlines and intersection 
points of other objects in the artwork.
Ruler Guides and Grids can be used to align objects and move objects accurately anywhere in the 
artwork.

To move objects

1. Select the objects that you want to move.
2. Position the pointer on the selected objects, press and hold the mouse button down, and drag to 

the new location.
3. Release the mouse button when the objects are at the desired location.

Related Topics
Moving Objects by Nudging



Rearranging the Drawing Order of Objects

The drawing order is the order in which the objects are placed on the artwork. When you create your 
artwork, you stack objects one on top of another. Objects that are placed first are at the very back of the 
drawing order, while the object that you placed most recently is at the very front of the drawing order. By 
changing the location of various objects in the drawing order, you change the appearance of your 
illustration.
You can move a selected object, several objects, or groups of objects to the very front or to the very back 
of the drawing order. When you move several objects to the very front or back, all the selected objects are
moved to the new position but maintain their relative order.
You can also move objects forward and backward by a single position in the drawing order. When you 
move several objects up or down by one position, all the selected objects are simultaneously moved 
forward or backward as if you moved them one at a time.
You can move objects to specific positions in the drawing order by moving selected objects in front of the 
highest selected object, or moving the selected objects below the lowest selected object.

To move objects to the front

1. Select the objects that you want to move to the front of the drawing order.
2. Choose the Bring to Front command from the Arrange menu, or press [F2].

To move objects to the back

1. Select the objects that you want to send to the back of the drawing order.
2. Choose the Send to Back command from the Arrange menu, or press [F3].

To move objects forward by one position

1. Select the objects that you want to move forward by one position in the drawing order.
2. Choose the Order Objects/Up One Position command from the Arrange menu, or press [SHIFT]

[F2].

To move objects backward by one position

1. Select the objects that you want to move backward one position in the drawing order.
2. Choose the Order Objects/Down One Position command from the Arrange menu, or press [SHIFT]

[F3].

To move objects in front of highest selected object

1. Select the objects that you want to move, including the object above which you want to move all 
the selected objects (This must be the highest selected object in the drawing order).

2. Choose the Order Objects/In Front Of Highest command from the Arrange menu, or press [CTRL]
[F2].

To move objects behind lowest selected object

1. Select the objects that you want to move, including the object behind which you want to move all 
the selected objects (This must be the lowest selected object in the drawing order).

2. Choose the Order Objects/Behind Lowest command from the Arrange menu, or press [CTRL][F3].
The higher selected objects will be moved behind of the lowest selected object.



Duplicating Objects

Using the Duplicate command, located inside the Edit menu, you can duplicate any of the objects in your 
artwork. When you duplicate objects, a replica of the selected object or objects is made and placed on top
of the original.
If you transform a copy of an object and then immediately duplicate the object, the transformation will be 
remembered and performed on each successive duplication.

To duplicate objects

1. Select the objects that you want to duplicate.
2. Choose the Duplicate command from the Edit menu, or press [CTRL][D].



Replicating Objects

Using the Replicate commands from the Edit menu, you can create multiple copies of objects. HiJaak 
Draw provides three different ways to replicate objects:

The Replicate/Linear Array... command lets you replicate objects along a single line or in two 
directions.
The Replicate/Grid Array... command lets you replicate objects across a grid.
The Replicate/On Curve... command lets you replicate objects on a curve.



Replicating Objects Along a Line

Using the Replicate/Linear Array... command located inside the Edit menu, you can replicate the selected 
objects along a single line or in two linear directions.
To replicate along a single line, simply specify the number of copies to be made, and the spacing between
copies. The illustration that follows demonstrates two typical linear replicates.
When you replicate in two directions, HiJaak Draw replicates along a single line, and then replicates the 
linear array according to a second set of replicate parameters that you specified. In the illustration below, 
one of the linear arrays from the example above will be used to demonstrate a few simple two directional 
replicate.
All the necessary linear replication parameters are specified inside the Linear Replicate dialog box.

To replicate along a single linear direction

1. Select the objects that you want to replicate.
2. Choose the Replicate/Linear Array... command from the Edit menu.

The Linear Replicate dialog box will appear.
3. Enter the single direction linear replicate parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.

To replicate along two different linear directions

1. Select the objects that you want to replicate.
2. Choose the Replicate/Linear Array... command from the Edit menu.

The Linear Replicate dialog box will appear.
3. Specify the single linear replicate parameters inside the dialog box.
4. Specify the second direction parameters inside the dialog box.
5. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Replicating Objects Along a Curve
Replicating Objects Along a Grid



The Linear Replicate Dialog Box

Single Direction radio button: Selecting this button tells the program that you only want to replicate 
along a single, specified line.
Copies field: Inside this field you enter the number of copies to be made.
Spacing Method field: Inside this field you select either the Increment or Distribute spacing method. 
When you choose the Incremental method, you specify the X and Y offsets between copies. When the 
Distribute method is chosen, you can specify the location of the last copy inside the X and Y fields. HiJaak
Draw will distribute the remaining copies in between the original object and the specified location.
X and Y fields: If you select the Increment spacing method, the values that you enter in the X and Y 
fields will be used as offsets between each copy. Whereas, if you select the Distribute spacing method, 
then the X and Y values will be used as the location of the last copy and the program will distribute the 
remaining copies in between the original and the specified position.
The Preview box: The Preview box will display a preview of the way that the objects will be replicated 
according to the parameters that you specified in the dialog box.
The Two Directions box: Inside this box you specify the number of copies of the linear array to be made,
and the spacing between each copy. Remember that with two directional replications, the original, single 
direction array is replicated according to the parameters that you specify in the Two Directions box.



Replicating Objects Along a Grid

Using the Replicate/Grid Array... command located inside the Edit menu, you can replicate the selected 
objects along a grid. This is done by specifying the number of rows and columns, spacing between rows 
and columns inside the Grid Replicate dialog box.

To replicate objects along a grid

1. Select the objects that you want to replicate along a grid.
2. Choose the Replicate/Grid Array... command from the Edit menu.

The Grid Replicate dialog box will appear.
3. Specify the grid replicate parameters inside the dialog box.
4. Click on OK or press [ENTER] when you are finished.

Related Topics:
Replicating Objects along a Curve
Replicating Objects along a Line



The Grid Replicate Dialog Box

The Rows field: Inside the Rows field you specify the number of rows of the desired grid.
The Row Spacing field: Inside the Row Spacing field you specify the spacing between rows.
The Columns field: Inside the Column field you specify the number of columns of the desired grid.
The Column Spacing field: Inside the Column Spacing field you specify the spacing between columns.
The Preview box: The Preview box displays a preview of the grid according to the parameters that you 
specified in the dialog box. You can also click or drag on the grid inside the Preview Box to set the 
number of rows and columns.



Replicating Objects Along a Curve

Using the Replicate/On Curve... command located inside the Edit menu, you can replicate selected 
objects along any curve in your artwork. To replicate along a curve, you simply select the objects that you 
want to replicate, specify the number of copies to be made inside the Replicate On Curve dialog box.
However, unlike the other replicate features you cannot control the spacing between copies when you 
replicate along a curve. The HiJaak Draw program distributes the copies along the curve for you.

To replicate objects along a curve

1.. Select the objects that you want to replicate along a curve.
2. Choose the Replicate/On Curve... command from the Edit menu.

The Replicate On Curve dialog box will appear.
3. Specify the replicate on curve parameters inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.
5. Click the choose pointer on the curve along which you want to replicate.

Related Topics:
Replicating Objects along a Grid
Replicating Objects along a Line



The Replicate On Curve Dialog Box

The Rows field: Inside the Rows field you specify the number of rows of the desired grid.
The Row Spacing field: Inside the Row Spacing field you specify the spacing between rows.
The Columns field: Inside the Column field you specify the number of columns of the desired grid.
The Column Spacing field: Inside the Column Spacing field you specify the spacing between columns.
The Preview box: The Preview box displays a preview of the grid according to the parameters that you 
specified in the dialog box. You can also click or drag on the grid inside the Preview Box to set the 
number of rows and columns.



Color Files

Color files are user-definable color files containing a list of colors each with its own color name and CMYK
(Cyan, Magenta, Yellow, Black), process color values that you specify yourself, or one of the PANTONE 
MATCHING SYSTEM printer color files. They are stored as separate files, with the extension .PDC and 
are not saved with the artwork.
When you first run HiJaak Draw, a default color file is opened and the colors are displayed inside the color
palette, color bar, and all of the color dialog boxes. When you quit the program, whatever color file was 
being used at the time will become the new default color file.
You can open color files at any time during your work session. However, you can only have one color file 
open at any one time.
As your artwork progresses, you can add new colors to the color file, remove unwanted colors, or copy 
colors from any other existing color file. You can create any number of color files that are tailored to your 
particular needs.

Related Topics:
Palette Editor
Rearranging Colors in the Color Palette



Document Colors

As you use new colors during your work session, the list of document colors will automatically be updated
with the new colors.
The list of document colors is useful in situations where you decide that you want to use one of the colors 
that you have already used. By switching to the document colors, HiJaak Draw will display only the colors 
that have been used in your artwork, inside the pop-up color palette, color bar, and color dialog boxes.



The Pop-up Color Palette

HiJaak Draw provides a pop-up color palette that you can use to select fill and outline colors quickly.
The pop-up color palette will appear when you press or click the mouse button on the Color button 
located at the upper left corner of the document window, above the drawing tool palette. Once the palette 
appears, it will remain on the screen until you select a color, click the mouse button, or press [ESC].
The Palette Pop-up menu: The Palette Pop-up Menu will appear when you press and hold the mouse 
button down on the pop-up menu button (located on the right edge of the color palette, and at the top of 
the color bar). From this menu you can choose the Spot Color and Process Color commands to assign 
process or spot colors, the Document Colors command or the current color file name to switch between 
displaying the colors of the current color file or the document colors, the Show Names toggle command to
display the colors by their names, the Open Palette... and    Edit... commands allow you to open and edit 
existing color files.
The Solid Fill button: Clicking on this button brings up the Fill Color dialog box that lets you numerically 
specify the fill color.
The Line Color button: Clicking on this button brings up the Line Color dialog box that lets you 
numerically specify the line color. The Line Color dialog box is identical to the Fill Color dialog box, except
that it is used to specify line colors.
The Linear Graduated Fill button: Clicking on this button brings up the Linear Graduated Fill version of 
the Fill Color dialog box that lets you specify the linear graduated fill parameters.
The Radial Graduated Fill button: Clicking on this button brings up the Radial Graduated Fill version of 
the Fill Color dialog box that lets you specify the radial graduated fill parameters.
The Pattern Fill button: Pressing the mouse button on this button brings up the Pattern Fill dialog box 
that lets you choose the pattern and specify the pattern fill parameters.
The PostScript Fill button: Clicking on this button brings up the PostScript Fill dialog box that lets you 
choose special PostScript fill effects.
The No Fill/Line Color icon: Clicking on this icon with the left mouse button turns off all fill attributes for 
the default fill or for the selected objects, while clicking with the right mouse button turns off all line 
attributes for the default outline or the selected objects.
In the pop-up color palette, you can choose to display the currently opened color file, or only the colors 
that have been used during your work session. To switch between displaying the currently opened color 
file and the document color palette, you choose either the name of the color file from the pop-up menu or 
the Document Colors command from the pop-up menu.
You can also use more than one color file during your work session. Existing color palette files, can be 
opened by choosing the Open Palette... command from the pop-up menu. Only one color file is open at 
any one time.
To edit the current color file, choose the Edit... command from the palette pop-up menu. When you edit a 
palette file, you can add and remove colors from a color file, change the color name, component values, 
or move colors between color files.
Any of the colors in the pop-up color palette can be used as process or spot colors. Choosing the Process
Color command from the palette pop-up menu, will assign the next colors that you select as process 
colors, while choosing the Spot Color command will assign the next selected colors as spot colors.

Related Topics:
Opening Color Files
Tear-off Color Palette



Color Fills

To assign a fill color or outline color to objects in your artwork, you simply select the objects, and then 
select fill or outline color by clicking the mouse button on the desired color. Clicking on a color with the left
mouse button will select the color as a fill color, while clicking with the right mouse button will select the 
color as an outline color.
When you are using the colors as spot colors, HiJaak Draw provides a quick way of adjusting the tint at 
the same time as you select the color. When you press and hold either the left or right mouse button on 
top of one of the colors, the Tint box will appear. Inside the Tint Box you can either enter the new tint 
value inside the Tint field or click on one of the ten color tint representations to select a tint value from 10 
to 100 percent.
A palette may contain more colors than can be shown at one time. In these situations you can either use 
the scroll bars to scroll through the entire palette, or you can drag the pointer beyond the bottom edge of 
the palette while you are selecting a color, causing the palette to autoscroll for you.
The buttons that run across the top of the pop-up color palette allow you to fill selected objects with linear 
and radial graduated fills, pattern fills, and PostScript fills. You can specify fill and line colors numerically 
by clicking the mouse button on top of the Solid Fill or Line Color buttons and then entering the 
component values inside the Fill Color and Line Color dialog boxes. 

To assign a fill or outline color to objects from the pop-up color palette

1. Select the objects whose fill or outline color you want to change.
2. Click the mouse button on the Color button.

The pop-up color palette will appear.
3. Click the mouse button on the desired colored square.

Clicking with the left mouse button will fill the selected object with the chosen color, while clicking with the 
right mouse button will change the outline color of the selected object with the chosen color.

Related Topics:
Color Bar
Fill Color Dialog Box



The Tear-off Color Palette

HiJaak Draw lets you tear-off the pop-up color palette so that it will remain visible on the screen at all 
times. When you tear-off the color palette, an extra Close command is added to the palette pop-up menu. 
Use the Close command to make the tear-off palette disappear when you are finished using it.
You can drag any of the corners of the tear-off palette to resize the palette thus controlling the number of 
colors being displayed at any one time.
Once you have torn off the color palette, you can move the palette to a new location by positioning the 
pointer on the title bar, pressing and holding down the mouse button, and dragging to a new location.
Colors are assigned from the tear-off palette in the same way as with the pop-up color palette.

To tear-off the color palette

1. Click the mouse button on the Color button.
2. Position the pointer on the title bar located to the left of the color palette, press and hold down the 

mouse button, and drag away from the palette.
3. Release the mouse button when the bounding box is at the desired location.



Color Bar

HiJaak Draw provides a color bar that you can use to select fill and outline colors. The color bar runs 
along the left side of the document window, and can be hidden depending on your own personal 
preference. The color bar has its own pop-up menu that is identical to that of the pop-up color palette. 
Just as with the pop-up color palette, you can assign process color and spot colors by enabling the 
appropriate command from the pop-up menu.
To assign a fill color or outline color to objects in your artwork, you simply select the objects, and then 
select fill or outline color by clicking the mouse button on the desired color from the color bar. Clicking on 
a color with the left mouse button will select the color as a fill color, while clicking with the right mouse 
button will select the color as an outline color.
You can hold down the mouse button on the color to bring up the Tint Box in which you can specify a new 
tint value.
The arrows on the top and bottom of the color bar lets you scroll through the colors.



Opening Color Files

New color files can be opened at any time during your work session. All of the PANTONE MATCHING 
SYSTEM printer color files are opened in this way. When you open a new color file, the current color file is
replaced by the file that you open, and the new colors are displayed inside the pop-up color palette, color 
bar, and all color dialog boxes. Opening a new color file does not affect any of the colors that you have 
used in your artwork.
New color files can be opened from either the pop-up menu of the color palette, color bar or from the 
Palette menu of any of the color dialog boxes.

To open an existing color file

1. Choose the Open Palette... command from the palette pop-up menu, the color bar pop-up menu, or
from the Palette menu of any color dialog box.
The File Open dialog box will appear.

2. Choose the color file to be opened.
You can either use the mouse to locate the appropriate directory inside the Directory list box and 
then locate the color file inside the File list box, or you can enter the name of the color file and the 
path inside the Filename and Path fields.

3. Click on Open, or press [ENTER].



Fill Color Dialog Box

The Fill Color dialog box is an important dialog box in the HiJaak Draw program, since all of the other 
color features that require you to specify colors, such as specifying the line color, the linear and radial 
graduated fills, and extrude, are mere extensions of this dialog box.
The Palette menu: From this menu you can choose the Document Colors command to display only the 
colors contained in your artwork, the color file name to display the colors of the currently opened color file,
the Open Palette... command to open existing color files, or the Edit... command to bring up the Palette 
Editor. A checkmark will be located beside either the Document Colors command or the color file name, 
depending on which colors are currently displayed.
The Colors menu: From this menu you can choose the Show Names command to toggle between 
displaying the colors in palette form or in a list of names inside the Color List Box, and change between 
the CMYK, HSB, and RGB color models for specifying process colors. If the colors are listed by name, the
Show Names command will have a checkmark beside it, and the currently selected color model will also 
have checkmark beside it.
The Options menu: From this menu you can choose the Halftone Screen... command to specify your 
own halftone screen specifications, the Overprint command to enable the overprint option.
The Ink Box: Inside the Ink Box you select the appropriate radio button to specify the way that the fill 
color is to be printed or assigned: as a process color, spot color, or gray scale by choosing the black or 
paper option.
The Values Box: What appears inside this box depends on what is chosen inside the Ink Box. If you 
have chosen the process color option, you numerically specifying the component percentage values using
either the CMYK, HSB, or RGB color models. If you have chosen the spot color, or black option, then you 
specify the tint value inside the Values Box.
The Color List Box: The Color List Box will display either the colors of the currently opened color palette 
file or the document colors, depending on the which one you have chosen to display from the Palette 
menu. The colors can be displayed in palette form or listed by name.
The Color Preview Box: The Color Preview Box shows a sample of the current color.
The Fill Type Selection Box: Inside this box you can quickly change the type of color fill that you want to
use: solid, linear graduated, or radial graduated fill.
The "Search by Name" field: When you enter a string in this field, HiJaak Draw will search for colors 
that contain this string in their name. You can enter portions of color names or full names.
The Find button: Clicking on this button tells the program to find the next matching color in the color list 
that contains the string that you entered inside the Search by Name field.
The Atlas Button: This button appears inside the Values Box only when you are using the process color 
ink option. Clicking on this button causes the color atlas to appear that you can use to help you locate a 
specific process color. The type of atlas that appears depends on the type of color model that you have 
selected inside the Colors menu.
The As Default button: Clicking on this button tells the program to make the color that you have selected
or specified as the default color. All of the objects that you draw from this point on, will automatically be 
filled with this default color until you change the default.
Any other dialog box that requires you to specify colors, such as the Linear and Radial Graduated Fill 
dialog boxes, will be based on the Fill Color dialog box.



Gray Scale Colors

When you intend to print your artwork in black and white, HiJaak Draw allows you to choose the tint (gray 
level) with the Black or Paper radio buttons in the Ink Box of the Fill Color dialog box.
When you fill objects with grays, you need to specify the tint value inside the Values Box. HiJaak Draw 
also provides a Paper radio button in the Ink Box of the Fill Color dialog box to help you select the paper 
color fill without having to specify a tint value of 0 percent.
When you create your color separations, objects that are filled with gray scale colors or paper colors will 
be printed on the black or K layer of the four color separation.
If you select the gray scale printing method and click on a color inside the Color List Box, then the Values 
Box will show the gray value of the selected color. The Preview Box will only display the equivalent gray 
value of the color and the color will actually be printed as the gray value.



Color Atlases

HiJaak Draw provides an atlas for each of the three color models: CMYK (Cyan, Magenta, Yellow, Black), 
HSB (Hue, Saturation, Brightness), and RGB (Red Green, Blue). The color atlases allow you to visually 
select the desired fill or line color.
Clicking on the Atlas... button will bring up the appropriate color atlas for the color model you are using.



CMYK Color Atlas

The CMYK atlas will help you visually locate specific process colors and find their component values.
The Color Range combo box: You select the CMYK color mixing pairs that are to be displayed across 
the top and left of the CMYK atlas. The available choices are: Magenta-Cyan, Yellow-Magenta, and 
Yellow-Cyan.
The Black Color Box: The black color is displayed inside the narrow box located to the right of the atlas. 
Clicking in this box will adjust the black color component.
The Remaining Color Box: The remaining color is displayed inside the narrow box located underneath 
the atlas. Clicking in this box will adjust the remaining color component.
The CMYK Atlas: The CMYK atlas displays a sample of the possible colors of the selected color range. 
You select a color from the atlas by clicking the mouse on the color position in the atlas. You can use the 
atlas to pick colors in 1% increments.
The Preview Box: The Preview Box displays a sample of the current color.
The Cyan, Magenta, Yellow, and Black fields: When you select a color from the CMYK atlas, the CMYK
component values of the selected color will be displayed inside these fields. You can directly enter the 
component values in these four fields, and the program will locate the color in the atlas for you.
The Remove Gray Component checkbox and field: Selecting the Remove Gray Component checkbox 
tells the program to perform automatic gray component replacement. The amount of gray component 
replacement is specified inside the gray component field, located directly underneath the checkbox.
The Show Names checkbox and field: Selecting the Show Names checkbox causes hollow squares to 
appear inside the CMYK atlas. These squares mark the locations of the colors contained in the currently 
opened color file. When you click on one of these markers, the name of the color will appear inside the 
field located directly underneath the Show Names checkbox.



HSB Color Atlas

The HSB atlas will help you visually locate specific colors by varying the hue, saturation, and brightness 
components.
The Hue Box: You click inside the Hue Box to select the hue that is to be displayed inside the HSB atlas. 
Hues range from 0 to 360 degrees. Red corresponds to a hue of 0 degrees.
The HSB Atlas: The HSB atlas displays a small portion of hues horizontally, with the currently selected 
hue at the center. The saturation component varies vertically, with 100% at the top, and 0% at the bottom.
The colors at the top of the atlas are purest, while the colors at the bottom are diluted. Clicking the mouse
to the left or the right relative to the center of the atlas, has the effect of rotating the hue angle. You select 
a color from the atlas by clicking the mouse on the color position in the atlas.
The Brightness Box: The brightness component is displayed inside the narrow box located to the right of
the atlas. Clicking in this box will adjust the brightness component.
The Preview Box: The Preview Box displays a sample of the current color.
The Hue, Saturation, and Brightness fields: When you select a color from the HSB atlas, the HSB 
component values of the selected color will be displayed inside these fields. You can also directly enter 
the component values in these four fields, and the program will locate the color in the atlas for you.
The Show Names checkbox and field: Selecting the Show Names checkbox causes hollow squares to 
appear inside the HSB atlas. These squares mark the locations of the colors contained in the currently 
opened color file. When you click on one of these markers, the name of the color will appear inside the 
field located directly underneath the Show Names checkbox.



RGB Color Atlas

The RGB atlas will help you visually locate specific colors by varying the red, green, and blue 
components.
The Color Range combo box: You select the RGB color mixing pairs that are to be displayed across the 
top and left of the RGB atlas. The available choices are: Red-Green, Red-Blue, and Green-Blue. The 
remaining color is displayed inside the narrow box located underneath the atlas. Clicking inside the 
narrow box will adjust the remaining color component.
The Remaining Color Box: The remaining color is displayed inside the narrow box located underneath 
the atlas. Clicking in this box will adjust the remaining color component.
The RGB Atlas: The RGB atlas displays a sample of the possible colors of the selected color range. You 
select a color from the atlas by clicking the mouse on the color position in the atlas.
The Preview Box: The Preview Box displays a sample of the current color.
The Red, Green, and Blue fields: When you select a color from the RGB atlas, the RGB component 
values of the selected color will be displayed inside these fields. You can directly enter the component 
values in these four fields, and the program will locate the color in the atlas for you.
The Show Names checkbox and field: Selecting the Show Names checkbox causes hollow squares to 
appear inside the RGB atlas. These squares mark the locations of the colors contained in the currently 
opened color file. When you click on one of these markers, the name of the color will appear inside the 
field located directly underneath the Show Names checkbox.



Palette Editor

HiJaak Draw lets you edit the colors in the currently opened color file, and customize your color file to 
your own needs. To edit the current color file, choose the Edit... command from the palette pop-up menu, 
color bar pop-up menu or the Palette menu in any of the color dialog boxes. The Palette Editor dialog box 
will appear.
The Palette menu: From this menu you can choose the New... command to create a new color file, the 
Open Palette... command to open existing color files, the Open Copy... command to open a copy of a 
color file, the Save command to save the current color file, the Save As... command to save a copy of the 
current color file with a different name, and the Revert command to revert the current color file to the last 
saved version.
The Colors menu:  This menu contains the Show Names toggle command that is used to switch 
between displaying the colors in palette form or by their names. It also contains the CMYK, HSB, and 
RGB commands that switch between the various color models.
The Sort menu: This menu contains the sort command that sorts the selected colors in the current color 
file according to the sorting methods that are also choose from this menu.
The Current Color Preview box: This box displays a sample of the current color.
The Add Current Color button: Clicking on this button will add the current color to the color file.
The Change Current Color button: The Change button has two uses. First, it can be used to change the
color component values of the selected color. It can also be used to change the name of the selected 
color. This button is enabled only if you have one color selected in the palette.
The Current Color Name field: This field is used to change existing color names. When you select a 
new color, it will display the name of the currently selected color.
The Current Color Component Value fields: In these fields you specify the color component 
percentage values using either the CMYK, HSB, or RGB color models. The color models are chosen from
the Colors menu.
The Find button: You can enter a string in the Color Name field and then click on the Find button. HiJaak
Draw will search for colors that contain this string in their name. You can enter a portion of the color name
or the full names.
The Atlas button: Clicking on this button causes the color atlas to appear. You can use the atlas to locate
a specific color visually. The type of atlas that appears depends on the type of color model that you have 
selected from the Colors menu.
The Palette Name field: Editing this field will change the palette name of the color file. The field shows 
the name of the currently opened color file. The palette name is not the filename, and can be longer and 
more descriptive. If you have specified a palette name, then the palette name will appear inside the 
Palette menu instead of the color file filename.
The Color Palette: The Color Palette will display the colors of the currently opened color file.
The Remove button: You can select a color or range of colors from the Color Palette and then click on 
the Remove button to delete the selected colors from the palette.
The Copy From... button: Clicking on this button brings up the File Open dialog box from which you can 
open another color palette file, select a range of colors, and copy them to the current palette.
The Color Mixer: The color mixer will mix the four colors located at its corners to create a range of 
colors. You can select and add a range of these mixed colors to the current color file. 
The Color Mixer Add button: You can select a range of colors from the Color Mixer and then click on 
Add to add the selected colors to the end of the palette.
The Color Mixer Set button: The Set button is used to specify new mixing colors at the corners of the 
Color Mixer. Once you select a color from the Color Palette, or specify the color component values in the 
component fields, you can click on one of the corners of the Color Mixer to select the mixer color that you 
want to change. Click on the Set button to perform the change.



You can use the Palette Editor dialog box to:
Create new color files.
Delete colors from the current color file.
Add colors to the end of the current color file.
Move and rearrange colors within the current color file.
Mix new colors using the Color Mixer, and add them to the end of the current color file.
Copy a range of colors from other existing color files.

Once you make the desired changes to the current color file, you can make the changes permanent by 
saving the file.



Color Mixer

The color mixer will mix four colors, located at its corners, to create a range of colors. You can then select 
a range of intermediate colors and add them to your color palette.
You have two options to specify which colors are mixed.
First, you can click on one of the corners of the color mixer to select it. Next, click on a color inside the 
color palette to select it, press and hold the mouse button down on the color, and drag it to the selected 
corner of the color mixer. The color that previously located at the corner will be replaced by the new color.
You can click on one of the corners of the color mixer to select it. Next, enter the color numerically inside 
the color component fields inside the Current Color box, and then click on the Set button to replace the 
old color with the color that you specified.
You can select individual colors by holding the [CTRL] key down and clicking on the color. To select a 
range of colors, hold the [SHIFT] key down and dragging over the desired colors in the color mixer.
Once you have selected a color from the color mixer, you can click on the Add button to add the selected 
colors to the end of the color palette.
You can even use one of the colors from within the color mixer as one of the four mixing colors. To do this,
simply position the pointer on the desired color, press and hold the mouse button down, and drag to one 
of the corners.



Rearranging Colors in the Color Palette

You can use the Palette Editor to rearrange colors within the color palette. HiJaak Draw provides two 
methods for rearranging colors within your color palette.
You can drag colors to new locations within your color palette.
You can use the commands in the Sort menu to sort the colors by their names or color components.
If no colors are selected when you choose one of the sort commands, then all the colors in the color 
palette will be sorted. However, if a range of colors is selected when you choose one of the sort 
commands, then only the selected colors will be sorted.
You can choose the Save command from the Palette menu to save the changes to the color file.

To move colors within the color palette

1. Select the colors that you want to move.
To select individual colors, simply hold down the [CTRL] key and click the mouse on the desired 
color.
To select a range of colors, hold down the [SHIFT] key and drag the pointer over the colors that you
want to select.

2. Position the pointer on one of the selected colors, press and hold the mouse button down, and 
drag to the new location.

3. Release the mouse button when the pointer is at the desired location.

To sort colors within the color palette

1. Choose either the Ascending or Descending commands from the Sort menu to tell the program in 
which direction the colors are to be sorted.

2. Choose one of the sorting methods from the Sort menu.
The available sorting methods are: Sort Names, Reverse Order, Hue, Saturation, Brightness, Cyan,
Magenta, Yellow, Black, Red, Green, and Blue color components.



Copying Colors from Existing Color Files

You can copy a range of colors from existing color files to the current color file.

To copy colors from an existing color palette file

1. Click on the Copy From... button in the Palette Editor dialog box.
The Open Color Palette dialog box will appear.

2. Open the desired color file.
3. Select the colors that you want to copy.



Removing Colors from the Color File

From the Palette Editor dialog box, you can remove unwanted colors from the currently opened color file.
If you accidentally remove colors, you can choose the Revert command from the Palette menu to return 
the color file to the last saved version of the color file.

To remove colors from the color file

1. Select the colors from the color palette that you want to remove.
You can hold down the [CTRL] key and click on a color to select individual colors. Hold down the 
[SHIFT] key and drag the pointer over several colors to select a range of colors.

2. Click on Remove.



Halftone Screens

You can use the Halftone Screen... from the Objects menu or from the Options menu in any of the color 
dialog boxes, to set the halftone screen parameters. When you print your artwork you can specify the 
halftone screen parameters for the entire artwork. However, if you set the halftone parameters for any 
individual objects, these parameters will override the global parameters.

To set the halftone screen parameters of objects in your artwork

1. Select the objects whose halftone parameters you want to change.
2. Choose the Halftone Screen... command from the Objects menu, or from the Options menu of any 

of the color dialog boxes.
The Halftone Screen dialog box will appear.

3. Specify the halftone screen parameters.
4. Click on OK, or press [ENTER] when you are finished.



Halftone Screen Dialog Box

The Printer Default radio button: Selecting this radio button tells the program to use the default printer 
halftone screens.
The Custom radio button: Selecting this radio button tells the program that you want to specify your own
halftone screen parameters. You can specify your own parameters inside the Type, Angle, and Frequency
fields.
The Type combo box: From this combo box you select the shape of the halftone cells, such as, circles, 
ellipses, squares, lines, etc.
The Angle field: Inside this field you enter the screen angle in degrees.
The Frequency field: Inside this field you enter the density of the halftone screen in lines per inch.



Overprinting Objects

When you create an illustration you will have many overlapping objects. Normally, HiJaak Draw prints 
over the bottom object with white so that the color of the top object will appear as it should. However, in 
some situations you may want to have the two colors of the objects printed on top of each other, so that 
their colors blend with each other. For this reason, HiJaak Draw provides the Overprint feature. You apply 
the Overprint feature to the topmost object of overlapping objects, telling the program to print the bottom 
objects as they are.
Overprinting is only used when the artwork is color separated, and has no effect when printing black and 
white, or composites. The overprinted object should be light in color to achieve the best results. You 
should be careful of overprinting more than one object, since you are likely to get moire patterns and 
excessive ink build-ups.

To overprint objects

1. Select the object that you want to overprint.
2. Choose the Overprint command from the Objects menu, or from the Options menu in any of the 

color dialog boxes.



Compound Objects

Compound objects are used to create holes in your objects so that the background shows through. To 
create compound objects, you select several overlapping painted objects and choose the Make 
Compound command from the Objects menu, or press [CTRL][SHIFT][G]. In the areas where an even 
number of painted objects overlap, a hole appears; whereas in areas where an odd number of painted 
objects overlap, no hole appears.
You can break a compound object back into separate curves by using the Release Compound command 
from the Objects menu, or pressing [CTRL][SHIFT][U].
NOTE: If you have used simple objects such as rectangles, ellipses, and arcs, to create a compound 
object, these objects become bezier curves when you release the compound object.

To create compound objects

1. Select the objects that you want to combine into a compound object.
2. Choose the Make Compound command from the Objects menu, or press [CTRL][SHIFT][G].

To release compound objects

1. Select the objects that you want to release.
2. Choose the Release Compound command from the Objects menu, or press [CTRL][SHIFT][U].



Masks

HiJaak Draw lets you use objects in your artwork as masks. When you mask objects, only the portions of 
the objects that fall within the bounds of the masking object, will be visible.
To specify which object is to be used as a masking object, simply select the masking object and choose 
the Mask command from the Objects menu. The masking object can have the normal fill and attributes as
well.
There are two methods of creating masks:

In the first method, you mark the object that is to be used as a mask, select it with the objects that 
you want to mask, and then group them. The mask will be created after you group the objects 
together. Until the masking objects are grouped, the mask will have no effect.
In the second method, you can use the Paste into Mask command from the Edit menu to paste 
objects on the clipboard, into the selected masking object. When you mask objects from the 
clipboard, only the portions of the clipboard objects that fall within the boundary of the masking 
objects will be visible.

To mask objects in your artwork

1. Select the object that you want to use as the masking object.
2. Choose the Mask command from the Objects menu.
3. Select the masking object and the objects that you want to mask.

Make sure that the objects overlap the masking object.
4. Choose the Group command from the Arrange menu, or press [CTRL][G].

To mask objects on the clipboard

1. Select the object that you want to use as the masking object.
2. Choose the Paste into Mask command from the Edit menu.

NOTE: Make sure that the objects on the clipboard overlap the masking object, otherwise the mask
will be empty.



Linear Graduated Fills

HiJaak Draw provides multi-color linear graduated fills. You can fill objects by specifying a fill direction and
any number of colors. HiJaak Draw will fill the object by blending between each set of colors in the 
specified direction. You can control the smoothness of the graduated fill by controlling the number of 
blending steps that are used to blend from the start color to the end color.
Linear graduated fills allow you to specify the start position, and angle of the fill directly on the drawing. 
You do not have to estimate the angle and margins inside a dialog box.
The linear graduated fill colors and parameters are specified inside the Fill Color    dialog box. This dialog 
box is similar to the Fill Color dialog box used for solid color fills, but has an extra portion for specifying 
the linear graduated fill parameters. 
You can use process colors or spot colors to create linear graduated fills. If you use spot colors, then the 
various blend colors will be overprinted to simulate the graduated fill. Using multiple spot colors in a linear
graduated fill can cause problems during printing unless the color separation screen angles are set 
properly.
The direction or angle of the linear graduated fill can be specified inside the Fill Color dialog box or on the 
artwork itself. If the object that is filled with the linear graduated fill is rotated, then the fill angle is 
automatically rotated with the object.
You can have constant, accelerating, or decelerating linear graduated fills. You can control the number of 
blending steps used to create the graduated fill -- the greater the number of bands the smoother the linear
graduated fill will look. You can also control the starting and ending margins so that you can compact the 
fill and show more of the start and end colors.

To fill objects with a linear graduated fill

1. Select the objects that you want to fill with the linear graduated fill.
2. Click on the Color button.
3. Click on the Linear Graduated Fill button.

The Fill Color dialog box will appear.
4. Specify the linear graduated fill parameters.

Related Topics:
Linear Fill Direction
Linear Graduated Fill Dialog Box
Multiple Color Selection
Radial Graduated Fills
Number of Bands in Graduated Fill
Number of Bands in Screen Display



Linear Graduated Fill Dialog Box

The Last menu: Inside this menu you will find the last eight graduated fills that you used in your artwork. 
When you first run HiJaak Draw, eight default fills will be shown inside the menu. You can also "pin down" 
the fills so that they will not be replaced as you use new fills. This allows you to keep a file of frequently 
used fills.
The Multi Color Preview Box: The Multi Color Preview Box displays a full color preview of the way that 
the linear graduated fill will look with the colors that you specify and their location along the fill direction.
The Color Location Markers: These markers show the location of the colors that are being used in the 
linear graduated fill. The location is shown as a percentage value relative to the start and end of the fill.
The Fill Angle field: In this field you can enter the fill angle or direction in degrees. The fill angle is 
measured in a clockwise direction.
The Fill Angle Dial: The Fill Angle Dial will show the fill direction, starting from the center and going out, 
as it would look on the artwork. You can specify the fill direction by dragging the dial in either a clockwise 
or counterclockwise direction.
The Position on Drawing checkbox: Selecting this checkbox tells HiJaak Draw that you want to specify 
the fill direction on the artwork as opposed to specifying the fill angle inside the dialog box.
The Options... button: Clicking on this button causes the Linear Fill Options dialog box to appear in 
which you can specify the ramp type, number of bands, and the starting and ending margin.

Related Topics:
Multiple Color Selection



Multiple Color Selection

Graduated fills require you to specify multiple colors. HiJaak Draw provides a multiple color selection bar 
to specify the location of the color for each of the colors.
When specifying multiple colors, you specify start and end colors, and any number of intermediate colors. 
When you specify intermediate colors, the program will blend between each pair of colors for you.
You can place the intermediate colors anywhere between the start and end colors, and you can change 
their location or color. The location of each of the intermediate colors is marked along side the Multiple 
Color Preview, and the exact location is shown as a percentage. There is always a marker at 0 and 100 
percent, designating the start and end colors. Intermediate colors can be added and removed. In the 
illustration, the Fill Color dialog box is shown with its Multiple Color Preview labeled.

To change one of the existing colors

1. Click on its marker to select the color.
2. Change the color by choosing a color from the palette, or specifying the numerical component 

values inside the Values Box.

To add an intermediate color

1. Click on the empty area beside the Multiple Color Preview, between the 0 and 100 percent markers
to place a new marker.

2. Select a color for that marker.

To move a color

1. Position the pointer on a marker, press and hold the mouse button down, and drag the marker up 
and down to the new location.

To remove a color

1. Position the pointer on a marker, press and hold the mouse button down, and drag the marker 
away from the preview until the marker disappears.
NOTE: You can not remove the 0 and 100 percent markers.

To remove all intermediate colors

1. Double-click the mouse button on the Multiple Color Preview.



Linear Fill Direction

The fill direction determines how the that the linear graduated fill is oriented inside the selected object. 
You can specify the fill direction inside Fill Color dialog box or directly on your artwork.
When you specify the fill direction inside the dialog box, you have two options:

Entering the fill angle in degrees, measured clockwise, inside the Fill Angle field.
Dragging the dial inside the Fill Direction Preview, to reflect the desired angle.

To specify the fill direction inside the dialog box

1. Enter the fill angle in degrees inside the Fill Angle field or drag the dial in a clockwise or 
counterclockwise direction.
If you drag the dial to specify the fill angle, the angle value inside the Fill Angle field will change to 
reflect the angle of the dial.

To specify the fill direction on the artwork

1. Select the Position On Drawing checkbox to turn this option on. HiJaak Draw will allow you to 
specify the fill direction on the artwork.

2. Click on OK, or press [ENTER] when you are finished.
3. Position the pointer on one of the handles of the bounding box, press and hold the mouse button 

down, and drag in either a clockwise or counterclockwise direction to specify the fill direction.
The arrow designates the fill direction, with the start color being located at the base of the arrow 
and the end color at the tip.

4. Position the pointer on one of the ends of the arrow. Press and hold the mouse button down, drag 
inwards or outwards to show more of the start and end colors in the linear graduated fill.

5. Click anywhere away from the bounding box when you are finished.



Linear Graduated Fill Options

Clicking on the Options... button inside the Fill Color dialog box brings up the Linear Fill Options dialog 
box. In this dialog box you can change the ramp type, specify the number of bands or blending iterations 
from start to end, and specify the start and end margins.



Ramp Type

You have a choice of three ramp types when using linear graduated fills: constant, accelerating, and 
decelerating.
A constant ramp means that the colors will be blended evenly from the start color to the end. In other 
words, each of the bands or blend steps will be equally spaced from start to end.
An accelerating ramp creates a linear graduated fill that is concentrated mostly near the end color. The 
separation between the bands or blend steps decreases as you go from the start to end color.
A decelerating ramp creates a linear graduated fill that is concentrated near the start color. The separation
between the bands or blend steps increases as you go from the start to end color.

To specify the ramp type

1. Click on the Options... button inside the Fill Color dialog box.
The Linear Fill Options dialog box will appear.

2. Choose the desired ramp type.
3. Click on OK, or press [ENTER] when you are finished.



Linear Fill Options Dialog Box

The Ramp Type Box: You select the appropriate radio button to specify the ramp type. The available 
ramp types are: a constant ramp, accelerating ramp, and decelerating ramp.
The # Bands field: Inside this field you enter the number of bands to be used for the linear graduated fill.
The Start Margin field: Inside this field you enter the start margin as a percent value relative to the 
length of the linear graduated fill. With larger values, more of the start color will be contained in the linear 
graduated fill.
The End Margin field: Inside this field you enter the end margin as a percent value relative to the length 
of the linear graduated fill. With larger values, more of the end color will be contained in the linear 
graduated fill.



Number of Bands

HiJaak Draw lets you control the number of bands or number of blend steps that are used to create your 
linear graduated fill. The larger the number of bands, the smoother your linear graduated fill will look when
printed. On the other hand, the lower the number of bands, the harsher your linear graduated fill will look 
since the change from one color to the next will be much more abrupt.

To specify the number of bands

1. Click on the Options... button inside the Fill Color dialog box.
The Linear Fill Options dialog box will appear.

2. Enter the number of bands that you want inside the # Bands field.
3. Click on OK, or press [ENTER] when you are finished.

You can also control the number of bands displayed on your screen, without changing the actual number 
of printed bands in the Preferences dialog box. This allows you to increase the number of bands for a 
more perfect graduated look on the screen, or decrease the number of bands to speed up the screen 
redraw time.



Start and End Margins

Changing the start and end margins lets you numerically adjust the amount of start and end color that are 
visible on your linear graduated fill. Specifying a large start margin will show more of the start color and 
less of the blended portion and end color. Specifying a larger end margin will show more of the end color 
and less of the blended portion and start color.
Changing the start and end margins is equivalent to changing the length of the arrow when you specified 
the fill direction on the artwork.
The start and end margins are specified as percentage values with respect to the distance between the 
start and end color.

To numerically specify the start and end margin

1. Click on the Options... button inside the Fill Color dialog box.
The Linear Fill Options dialog box will appear.

2. Enter the desired start and end margins as percentage values inside the Start Margin and End 
Margin fields.
The margins are measured as percentages with respect to the distance between the start and end 
color.

3. Click on OK, or press [ENTER] when you are finished.

To specify the start and end margins on the artwork

With the linear graduated fill bounding box visible:
1. Position the pointer on one of the ends of the arrow. Press and hold the mouse button down. Drag 

inwards to show more of the start and end colors in the linear graduated fill, or outwards to show 
less of the start and end colors.



Radial Graduated Fills

Radial graduated fills are similar to linear graduated fills, except that the blending is done in a radial 
direction. The radial graduated fill parameters are specified in a similar manner to linear graduated fills. 
You specify a fill origin that consists of a starting color and an ending color, as well as any number of 
intermediate colors. Then the program blends radially between each set of colors beginning with the 
starting color and ending with the last color at the outer circle.
You can also create radial graduated fills that start from an inner circle of a user-definable size, fill.
You can specify the position of the fill origin or the inner circle inside the Fill Color dialog box or on the 
artwork itself.
You can also have constant, accelerating, or decelerating radial graduated fills. You can control the 
number of blending iterations to create the graduated fill -- the greater the number of bands the smoother 
the radial graduated fill will look. You can also specify the location of the inner circle center and radius 
numerically. Since these fill options are the same as that of the linear graduated fill they will not be 
discussed here. 

To fill objects with a radial graduated fill

1. Select the objects that you want to fill with the radial graduated fill.
2. Click on the Color button.
3. Click on the Radial Graduated Fill button.

The Fill Color dialog box will appear.
4. Specify the radial graduated fill parameters.

Related Topics:
Radial Fill Options
Radial Fill Positions



Radial Graduated Fill -- Fill Color Dialog Box

The Multi Color Preview box: The Multi Color Preview box displays a full color preview of the way that 
the radial graduated fill will look with your current specifications.
The Color Location Markers: These markers show the location of the colors that are being used in the 
radial graduated fill. The location is shown as a percentage value relative to the inner and outer circle.
The Inner Radius field: Inside this field you can enter the size of the inner circle radius as a percentage 
value relative to the size of the outer circle radius. The Inner radius circle will be composed of the color 
specified at 0 in the Multi Color Preview box.
The Position On Drawing checkbox: Selecting this checkbox tells HiJaak Draw that you want to specify
the fill direction on the artwork as opposed to specifying it inside the dialog box.
The Options... button: Clicking on this button causes the Radial Fill Options dialog box to appear. In this 
dialog box you can specify the ramp type, number of bands.
The Last menu: Inside this menu you will find the last eight graduated fills that you used in your artwork. 
When you first run HiJaak Draw, eight default fills will be shown inside the menu. You can also "pin down" 
the fills so that they will not be replaced as you use new fills.



Radial Fill Positions

The position of the inner and outer circles relative to each other, determines the way that the radial 
graduated fill is oriented inside the selected object. When HiJaak Draw creates the radial graduated fill, it 
blends from the inner circle to the outer along a line that connects the centers of the two circles.
You specify the size of the inner circle inside Fill Color dialog box while you can choose between 
specifying the fill positions either inside the dialog box or on the artwork itself. The inner circle is the 
amount shown of the color specified at 0 in the Multi Color Preview box. When you specify the fill position,
you are simply moving the inner circle so that the line connecting the centers of the inner and outer circle 
is at the desired position.
To specify the fill position on the artwork you first select the Position On Drawing checkbox inside the 
dialog box. When you leave the dialog box and return to the artwork, you move the circles so that they are
at the desired position. The intermediate colors that you specify will be placed radially between the outer 
and inner circles.
When specifying the position on the artwork, you can also use the pointer to adjust the size of either the 
inner and outer circles by dragging the handles on the outlines of the circles.

To specify the fill position inside the dialog box

1. Enter the radius of the inner circle as a percentage of the outer circle inside the Inner Radius field 
of the Fill Color dialog box.

2. Click on Options....
The Radial Fill Options dialog box will appear.

3. Specify the location of the inner circle center relative to the outer circle.
4. Click on OK, or press [ENTER] when you are finished.

To specify the fill position on the artwork

1. Specify the size of the inner circle radius inside the Inner Radius field of the Fill Color dialog box.
If the inner circle radius is set to zero then the fill will be created from a point to the outer circle.

2. Select the Position On Drawing checkbox to tell HiJaak Draw that you want to specify the fill 
position on the artwork.

3. Click on OK, or press [ENTER] when you are finished.
4. Drag either of the circles by their outlines to a new location to specify the fill position.
5. Click anywhere away from the two circles when you are finished.



Radial Fill Options

The Inner Fill Origin Box: You enter the location of the inner circle center inside the X and Y fields.
The Inner Fill Origin Preview: You can drag the center origin in the preview to specify the location of the
inner circle.



Outline Colors

Assigning outline colors is much the same as assigning object fill colors. You can assign line colors that 
are either process or spot color by using the color pop-up palette, color bar or by specifying the color 
numerically inside Line Color dialog box.
To assign outline colors to selected objects, you simply click with the right mouse button on the desired 
color in the color palette or color bar. You can also click on the Line Color button inside the color palette, 
and then numerically specify the color inside the Line Color dialog box.

Related Topics:
Outline Styles



Outline Styles

From the pop-up line palette, you can set line or outline styles such as line thickness, line caps, line joints,
dashes, and place arrowheads along line segments.
The pop-up line palette appears any time you click the mouse button on the Outline button located at the 
upper left of the document window, right next to the Color button.
The Line Style button: Clicking on the Line Style button causes the Line Style dialog box to appear. You 
can specify custom line thicknesses, line caps, line joints and miter limits, as well as dashed line styles, 
line colors, and arrowheads in this dialog box.
The Dashed Line button: Clicking on this button causes the Dash Editor dialog box to appear from 
which you can select a dashed line style or create your own custom dashes.
The Arrow button: Clicking on the Arrow button causes the Arrow dialog box to appear. In this dialog box
you can specify the arrowhead type that is to be placed on your line segments and where along the line 
segment it is to be placed.
The Line Style Toggle: Selecting one of the line representation turns the outline on or off, the dashes on 
or off or solid line on or off for the selected object.
The Line Thickness palette: You can click on one of these basic line thickness representations to 
quickly change the outline thickness.
The Arrows palette: You can click on one of these standard arrow styles to quickly assign arrows to 
outlines.



The Line Style Dialog Box

All the line styles can be set inside the Line Style dialog box, however HiJaak Draw provides other ways 
of specifying dashed line styles, and arrowheads.
The Line Width field: Inside this field you specify the outline thickness in the desired units.
The Line Preview Box: The Line Preview Box will display a sample of the way that the line will look 
according to the parameters that you specify inside the dialog box.
The Line Style Box: Inside this box you set the cap styles and line joints, specify the miter limit, set 
whether to place the line stroke behind the fill of the object and whether to scale the line thickness with 
the object.
The Dashes... button: Clicking on the Dashes... button brings the Dash Editor dialog box that lets you 
choose from predefined dash styles or create your own.
The Arrows... button: Clicking on the Arrows... button brings up the Arrows dialog box that lets you 
specify the location and styles of arrowheads on your line.
The Color... button: Clicking on the Color... button brings up the Line Color dialog box that lets you 
specify the line color numerically.
The Scale with Object checkbox: Selecting this checkbox tells the program to scale line widths when 
you scale objects. If this checkbox is not selected, the line width will remain constant.
The Draw Behind Fill checkbox: Selecting this checkbox tells the program to draw the outline behind 
the object's fill.
The Default button: Clicking on the Default button tells HiJaak Draw to apply the default line styles that 
are defined inside the Preferences dialog box.
You can bring up the Line Color, Arrows, and Dash Editor dialog boxes from the pop-up line palette. This 
allows you to specify these parameters all at once instead of specifying the various components 
individually.



Line Cap Style

The line cap style controls the way that the end points of lines and open curves will look. To specify the 
line cap style, you simply click on the radio button of the desired cap style inside the Line Style dialog box.
HiJaak Draw provides three types of line cap styles:
The Butt cap.
The butt cap is square at the ends and does not extend beyond the end of the line.
The Round cap.
The round cap is a semi-circular cap with the diameter of the semi-circle equal to the line thickness. The 
round cap extends beyond the end of the line.
If you use the round cap with dashed lines, the caps will extend beyond the dash and into the space 
between the dashes.
The Extended cap.
The extended cap is a square cap that extends beyond the end of the line by a distance equal to one-half 
of the line thickness.
If you use the extended cap with dashed lines, the caps will extend beyond the dash and into the space 
between the dashes.

To set the cap style

1. Select the objects whose cap style you want to change.
2. Click on the Outline button.

The pop-up line palette will appear.
3. Click on the Line Style button.

The Line Style dialog box will appear.
4. Select one of the Butt, Round, or Extended Caps radio buttons inside the Style Box to select the 

desired cap style.
5. Click on OK, or press [ENTER] when you are finished.

The Line Style dialog box disappears and the cap style of the selected object changes to reflect the 
cap style that you specified inside the dialog box.



Line Joint Style

The line joint style controls the way corners and of lines and open curve joints will look. To specify the line
joint style, click on the radio button of the desired joint style inside the Line Style dialog box.
HiJaak Draw provides three types of line joint styles:
The Miter joint.
The ends of the two connecting line segments are extended until they meet. You can control the amount 
that the two end points are extended by specifying a Miter Limit. Specifying the Miter Limit will be 
discussed in the next section. If the miter joint extends beyond the miter limit, the miter joint becomes a 
bevel joint.
The Round joint.
The round joint rounds the corner or bends with a circular arc whose diameter is equal to the line 
thickness.
The Bevel joint.
The bevel joint can be thought of as a miter joint with the corners slightly cut off.

To set the joint style

1. Select the objects whose joint style you want to change.
2. Click on the Outline button.

The pop-up line palette will appear.
3. Click on the Line Style button.

The Line Style dialog box will appear.
4. Click on either the Miter, Round, or Bevel joint radio buttons inside the Style Box to select the 

desired joint style.
5. Click on OK, or press [ENTER] when you are finished.



Miter Limit

When you use miter joints, the end points of the two connecting segments are extended until they 
connect. When the two segments meet at a sharp angle, a long spike appears beyond where the two end 
points actually meet. By specifying a miter limit, you are in essence specifying where the miter joint is 
chopped off, thus becoming a beveled joint.
The miter limit can only be specified if you are using the miter joint. Otherwise, the Miter Limit field is 
grayed out inside the Line Style dialog box.
The miter limit is specified in terms of a number of times the current line length. The lower the miter limit, 
the sooner the miter joint becomes a beveled joint.

To specify a miter limit

1. Select the objects whose miter limit you want to change.
2. Click on the Outline button.

The pop-up line palette will appear.
3. Click on the Line Style button.

The Line Style dialog box will appear.
4. Select the Miter joint radio button inside the Style Box.
5. Enter the miter limit inside the Miter Limit field.
6. Click on OK, or press [ENTER] when you are finished.



Arrowheads

You can place arrowheads on lines and open curves. HiJaak Draw provides seven different shapes of 
arrowheads that you can place at either end or the center of line segments. Arrowhead shapes and 
locations are specified inside the Arrows dialog box.
You have two options for specifying the dimensions of the arrowheads. You can enter the width and 
length of the arrowheads numerically in the Width and Length fields inside the Arrows Box.
Furthermore, you can use the pointer to reshape the arrowheads in any of the preview boxes. To reshape 
the arrowhead, position the pointer near one of the corner points on the arrowhead, press the mouse 
button down, and drag. As you drag, the Width and Length field values will change to reflect the changing 
dimensions of the arrowhead. When the arrowhead is the desired size and shape, release the mouse 
button. The process of reshaping arrowheads is identical to reshaping any of the standard objects.
If you have selected the Resize all checkbox, all arrowheads will be resized together when you resize one
arrowhead.

To place arrowheads on line segments

1. Select the line segments or curves on which you want to place arrowheads.
2. Click on the Outline button.

The pop-up line palette will appear.
3. Click on the Arrows button.

The Arrows dialog box will appear.
4. Click on one of the Arrow Style buttons to select the type of arrowhead that you want.
5. Click on the Start, Center or End Preview Box inside the Arrows Box to tell the program where you 

want the arrowhead to be placed.
6. Repeat steps 4 and 5 until you have specified all the locations where you want arrowheads to be 

located on the line segment.
7. Specify the size and shape of the arrowheads.
8. Click on OK, or press [ENTER] when you are finished.



Arrows Dialog Box

The Arrow Shape buttons: Click on one of these buttons to select the arrow shape that you want to use.
Some of these buttons have a pop-up palette containing other styles. These palettes usually give you 
options of hollow or filled arrowheads. Buttons that have a pop-up palette are marked with a small black 
arrowhead in the lower right corner of the button. To display the pop-up choices, click and hold the mouse
button. Then select the desired style.
The Arrow Box: Inside this box you click on the location where you want the arrowhead to be placed: at 
the start, center or end of the line segment. You can also select the whether you want double arrowheads 
by selecting the Double checkbox, and numerically specify the dimensions of the arrowhead inside the 
Width and Length fields.
The Start, Center, and End Preview Box: The various preview boxes display samples of how the 
arrowhead will look. You can also drag any of the arrowheads inside any of the preview boxes to resize 
them.
The Resize All checkbox: Selecting this checkbox causes all the arrowheads to be resized in the same 
way, when you resize one arrowhead.
The Same Ends checkbox: Selecting this checkbox ensures that the start and end arrowheads are the 
same. When you change the size and style of the arrowhead at one end, the other end is automatically 
changed so that it is the same.
The At Every segment checkbox: Selecting this checkbox tells HiJaak Draw to place the specified 
arrowheads on every segment of an open curve and not just its start and end points.
The Scale with Line Width checkbox: Selecting this checkbox tells the program to also scale the 
arrowheads when you scale the line thickness.



Dash Editor

Dashed line styles are specified inside the Dash Editor dialog box. When you define dash styles, you can 
choose one of the predefined dash style from the list of predefined dash styles inside the pop-up line 
palette. You can also specify your own custom dash styles inside the Dash Editor dialog box.
The Preview Box: The Preview Box displays a sample of how the dashed line will look.
The Edit Box: Inside this box you set the dash style by specifying pattern of dashes and spaces. 
The Scale Box: In the scale box you can magnify the dash style that is displayed inside the Edit Box, so 
that you can see the length of the dashes and spaces precisely.
The Dash Ruler: The ruler is 5 inches long. The ruler has two scroll arrows that let you scroll to the left 
and right. Ruler units can be set inside the Units combo box.
The Units combo box: You can choose the new dash ruler units from this combo box.
The Dash Style List Box: Inside this box you will see the representations of all the custom dash styles 
that are available to you. You can add your own styles to the list, delete existing styles from the list, and 
replace existing styles with new dash styles that you create. 
The Add... button: Clicking on the Add... button lets you name the new style and add it to the dash style 
list.
The Delete button: Clicking on the Delete button will delete the selected dash style from the dash style 
list.
The Replace... button: Clicking on the Replace... button will replace the selected dash style in the dash 
style list, with the style that you just created.
The Ruler: You can use the ruler to help you specify dashes and spaces of precise length. The ruler units
can be changed inside the Scale Box by clicking on the down arrow to bring up the pop-up units menu. 
Then simply click on the desired unit from the pop-up menu.
The Dash markers: By moving the black dash markers, you change the length of the dashes.
The Space markers: By moving the white space markers you change the size of the gaps or spaces.
The Dash Ruler: The dash ruler provides a guide for the placement of your dashes and spaces. It can 
display up to five inches, and its units can be changed at any time by choosing new units from the Units 
combo box.
The Scroll Arrows: You can use the scroll arrows to scroll through the dash pattern.
The dash styles that you create and add to the dash style list are saved in a file called DASH.PDI. HiJaak 
Draw program comes with a DASH.PDI file that contains some of the more standard dash styles.
You can create and add your own dash styles to the dash style list from the Dash Editor dialog box. You 
can also delete existing styles or replace them with your own styles. When you replace or delete an 
existing style, any artworks that already contain the old style will not be affected. You should not delete or 
replace existing dash styles unless you are certain that you don't want to use them again.

Related Topics:
Modifying Dash Styles



Dash Patterns

To create your own custom dash styles, specify the pattern of dashes and gaps between the dashes 
inside the Edit Box of the Dash Editor dialog box.

To specify a dash pattern

1. Position the pointer on the Dash Marker, press and hold the mouse button down, and drag until the
dash is the desired length.

2. Position the pointer on the Space Marker, press and hold the mouse button down, and drag near 
the Dash Marker until the distance between the two is the desired gap size.
The distance between the Dash Marker and the Gap Marker defines the gap size.

3. Repeat steps 1 and 2 until you have specified all the different dashes and gaps for your dash 
pattern.

You should only specify additional dashes if they are going to be a different size than the first. The pattern
that you specify will be repeated regularly to generate the entire dashed line.
Up to ten markers can be used at a time.

To add new markers

You have two options for adding markers:
Drag the marker from the extreme right of the Edit Box.
Double-click to the right of the last marker.

Double-clicking to the left of a marker will move that marker to where you double-clicked the mouse 
button.

To remove existing markers

You have two options for removing existing markers:
Drag the rightmost marker to the extreme right of the Edit Box, until it disappears.
Double-click on the rightmost marker to delete it.



Adding New Dash Styles 

You can customize the Dash Style List to meet your needs by adding your own custom styles to the list. 
When you add a new style, the style will appear inside the Dash Style List Box and is saved in the 
DASH.PDI file so that it can be retrieved and used later. The styles are arranged in alphabetical order 
inside the Dash Style List Box.

To add a new style to the dash style list

1. Specify the dash pattern inside the Edit Box.
2. Click on Add....

The Enter Dash Style Name dialog box will appear.
3. Enter the name of the new dash style inside the Dash Name field.
4. Click on OK, or press [ENTER] when you are finished.



Modifying Dash Styles 

HiJaak Draw lets you modify and rename an existing style. It is not recommended that you modify existing
styles unless you are certain that you will never use it again. If you need to modify an existing style, we 
suggest that you adjust the style and then add it under a new name instead of replacing the existing style.
If you do replace an existing style, dashes in older artworks will not be affected.

To modify an existing dash style

1. Click on the dash style in the Dash Style List Box that you want to replace.
2. Change the dash pattern inside the Edit Box.
3. Click on Replace....

The Enter Dash Name dialog box will appear. If you want to save the style under a different name, 
enter a new name inside the Dash Name field. If you want to save it under the same name, click on 
OK, or press [ENTER].
The selected dash style will be replaced by old pattern.

To rename an existing dash style

1. Click on the dash style in the Dash Style List Box that you want to replace.
The dash style will be highlighted indicating that it is selected.

2. Click on Replace....
The Enter Dash Name dialog box will appear.

3. Enter the new name inside the Dash Name field.
4. Click on OK, or press [ENTER] when you are finished.



Deleting Dash Styles

If you find that you don't seem to use some of the dash styles in the dash style list, you can delete them 
from the list. When you delete existing dash styles, any of the old artworks that used the style will not be 
affected. However, deleting the style removes from the list permanently.

To delete an existing dash style

1. Click on the dash style in the Dash Style List Box that you want to delete.
2. Click on Delete.

The dash style will be delete from the dash style list and the DASH.PDI file. It will also be removed 
from the Dash Style List Box.



Pattern Fills

Patterns consist of objects that are arranged and repeated regularly to create a continuous design. You 
can create patterns using any objects you have created, or using any of the library symbols. You can also 
use any of the predefined patterns that are included with the HiJaak Draw program.
Patterns can be stored in the libraries for quick retrieval later. You can store all of your patterns in their 
own pattern libraries, away from other library symbols and artworks.
Patterns used in a particular artwork will be stored inside the document pattern palette and saved with the
document. Even if you erase all objects that are filled with a particular pattern, the pattern will still remain 
in the document pattern palette and can be used later.
To build a pattern, you specify the pattern tile bounds inside the Pattern Editor. If the bottom most object is
a non-rotated rectangle, its bounds will be set initially as the tile bounds. You can of course change the tile
bounds inside the Pattern Editor. It is useful to use the rectangle to specify the tile bounds on the drawing 
rather than inside the dialog box. HiJaak Draw provides two different tiling methods to create patterns:
You can tile the entire objects and have adjacent tiles overlap to create the pattern.
You can tile portions of the objects and have the tiles arranged side-by-side without overlapping to create 
the pattern.
Sometimes when you place the tiles side-by-side you get a pattern with seams. Having the ability to 
overlap tiles is useful since you can move the tiles closer together and eliminate the seams.
You can edit the pattern tiling at any time during your work session. When you alter the tiling of a pattern, 
all objects that are filled with that particular pattern are updated with the new pattern.
Once you create a pattern, you can resize and transform the pattern.
When you transform objects that are filled with patterns, you can have the pattern transform with the 
objects.

Related Topics:
Create Patterns Dialog Box
Creating Patterns
Filling Objects with Patterns



Create Pattern Dialog Box

You can create patterns using any of the existing library symbols or using any of the objects that you have
already created in HiJaak Draw. Patterns are created inside the Create Pattern dialog box.
The File menu: Using the commands found inside this menu, you can create new libraries, open existing 
libraries, close the current library, and switch between using the currently opened libraries and the 
document pattern list. 
The Options menu: From this menu you can choose the Snap to Handles and Snap to Cross Hairs 
precision tools to help you adjust the bounds of the pattern tile accurately and overlap the pattern tiles in 
specific relationships. 
The Pattern Editor box: Inside this box, you either specify the portion of the symbol to be used as the 
pattern tile or the way that the pattern tiles overlap, depending on the type of tiling method that you have 
selected. Double-clicking the mouse on the tile bounds will set the tile bounds to the bounds of all the 
selected objects.
The Pattern Preview box: The Pattern Preview box displays a preview of the way that the pattern will 
look with the settings currently used in the Pattern Editor box. The preview is not to scale.
The Tile Entire Graphic checkbox: This checkbox lets you select between the two tiling methods. When
the Tile Entire Graphic option is selected, then the entire symbol is used as the pattern tile and you can 
overlap the pattern tiles. When the option is not selected, you can specify the portion of the symbol that is 
to be used as the pattern tile and arranged the tiles without overlapping to create the pattern.
The Show Edit Handles checkbox: Selecting this checkbox causes the tile handles to be visible on the 
tile bounding rectangle inside the Pattern Editor Box.
The Name field: Inside this field you enter the name of the pattern that you are creating. The pattern 
name can consist of up to twenty characters.



Pattern Tiling Methods

HiJaak Draw provides two different tiling methods that you can use to create patterns:
You can tile the entire objects and have adjacent tiles overlap to create the pattern.
You can tile portions of the objects and have the tiles arranged side-by-side without overlapping to create 
the pattern.
The Tile Entire Graphic checkbox inside the Create Pattern dialog box switches between the two tiling 
methods. When the Tile Entire Graphic option is selected, then the entire symbol is used as the pattern 
tile and can be overlapped to create the pattern. If the option is not selected, portions of the object can be 
tiled and aligned, but not overlapped.
Depending on the tiling method that you are using, you either align and overlap the tiles, or align the tile 
bounds on the objects being used to create the pattern. HiJaak Draw provides the Snap To Handles and 
Snap to Cross hair options to help you align tiles and tile bounds accurately.

To tile entire objects and overlap adjacent tiles

1. Select the Tile Entire Graphic checkbox.
Inside the Pattern Editor Box four images of the objects will appear. The four images represent four 
adjacent tiles and can be moved to specify how they are to overlap.

2. Drag the objects until the adjacent tiles overlap the way that you want.

To tile portions of objects

1. Deselect the Tile Entire Graphic option.
Inside the Pattern Editor Box an image of the objects will appear and they will be surrounded by the
tile bounding rectangle.

2. Specify the portion of the objects that you want to use as the pattern tile by enclosing it with the tile 
bounding rectangle.

You can resize the tile bounding rectangle by dragging any of the corners of the rectangle or move the 
entire bounding rectangle by dragging it to a new location.
Double-clicking on the tile bounding box will set the bounds equal to the size of the selected objects.



Creating Patterns from Existing Library Symbols

You can create patterns from existing library symbols by selecting the desired symbol and then specifying
the tiling method. The pattern that you create will automatically be stored in the library for retrieval later.

To create a pattern from an existing library symbol

1. Choose the Libraries... command from the File menu.
The Library dialog box will appear and it will display the currently selected open library. If no 
libraries are open, then the Library dialog box will be empty.

2. Select the name of the library that contains the symbol that you want to use from the list of libraries
inside the File menu.

3. Select the symbol that you want to use to create the pattern.
4. Choose the Edit As Pattern... command from the Symbol menu of the dialog box.

The Create Pattern dialog box will appear.
5. Specify the pattern tiles.
6. Enter the pattern name inside the Name field.
7. Click on OK, or press [ENTER] when you are finished.



Creating Patterns

When you create a pattern from scratch, you use the objects that you have already created in your 
artwork to make the pattern.

To create patterns

1. Select the objects in your artwork that you want to use to create the pattern.
2. Choose the Create Pattern... command from the Objects menu.

The Create Pattern dialog box will appear.
3. Specify the pattern tiles.
4. Enter the pattern name inside the Name field.

If you want to save the pattern inside a library, make sure that you select the library from the dialog 
box File menu before leaving the dialog box. Otherwise the pattern will only be saved as part of the 
document pattern list.

5. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Creating Patterns from Existing Library Symbols



Filling Objects with Patterns

To fill an object with a pattern, click on the Pattern Fill button in the color pop-up palette. Then select the 
pattern that you want to use as the fill inside the Pattern Fill dialog box.
You can use patterns from any of the libraries or from the document pattern list as fill patterns. Switching 
between the document pattern list and any of the libraries is done inside the File menu of the Pattern Fill 
dialog box. To use the patterns in the document pattern list you choose the Document Pattern List 
command. To use patterns from a library, choose the name of the library from the list of currently opened 
libraries. 
Once you have switched to either the document pattern list or the desired library, all the patterns will be 
listed inside the Pattern List box. To select the pattern simply click on the name of the pattern that you 
want. When you select a pattern, you will see the pattern in the Pattern Preview.
When you have selected the pattern that you want to use, you can transform the pattern before filling the 
object. You can shift the entire pattern horizontally and vertically by specifying X and Y offsets in terms of 
a tile. For example, a 50 % offset in the X and Y direction will shift the entire pattern horizontally and 
vertically by a half tile.
You can scale the pattern in the horizontal and vertical direction. A 10 % scaling in the X and Y (horizontal
and vertical) direction will reduce the pattern such that the resulting pattern tiles are one-tenth the size of 
what they were before scaling.
You can rotate the pattern by specifying the rotation angle in degrees in the Angle field inside the 
Transformations box. You can also rotate the pattern by dragging the direction line, inside the Pattern 
Angle Preview, in a clockwise or counterclockwise direction. The transformation does not change the 
pattern itself, so you can use the same pattern with different transformations in the same artwork.
Selecting the Transform with Object checkbox will cause the selected pattern to be transformed with the 
object when you transform objects that are filled with that particular pattern.
You can edit the selected pattern by clicking on the Edit... button to bring up the Create Pattern dialog box
that lets you tile the pattern again. 

To fill objects with a pattern

1. Select the objects that you want to fill.
2. Click on the Color button.

The pop-up color palette will appear.
3. Click on the Pattern Fill button.

The Pattern Fill dialog box will appear.
4. Select the pattern that you want to use as the fill.

You can switch to either the document pattern list or one of the currently opened libraries from 
inside the File menu.

5. Transform and edit the pattern until it looks the way that you want.
6. Click on OK, or press [ENTER] when you are finished.

Related Topics:
Creating Patterns



The Pattern Fill Dialog Box

The Transformation box: Inside this box you can specify the pattern offset in the horizontal and vertical 
direction, scale the pattern horizontally and vertically, rotate the entire pattern. You can also enable the 
Transform with Object option that causes the pattern to be automatically transformed with the object when
you transform the object that is filled with that particular pattern.
The Pattern Angle Preview: The Pattern Angle Preview shows the way that the pattern is angled with 
respect to the horizontal. Note that the preview may not be to scale.
The Transform with Object checkbox: Selecting this checkbox tells the program to the pattern when 
you transform objects filled with this particular blend.
The Edit... button: Clicking on this button brings up the Create Pattern dialog box that lets you edit a 
selected pattern before filling an object. If you edit a pattern from the document pattern list you will be 
asked if you want to replace the original, in which case all objects using the old pattern will change to 
reflect the new pattern.
The Pattern List box: Inside the Pattern List box you will see a list of pattern names contained in the 
currently selected library or document pattern list.
The Pattern Preview box: Inside the Pattern Preview box you will see a sample of the selected pattern. 
The pattern preview may not be to scale.



PostScript Fills

PostScript Fills are created by sending a series of parameters to a PostScript printer. These fills are often 
complicated designs that are difficult to create in any other way. PostScript fills can only be printed on a 
PostScript printer, and will not show up on your screen. Objects filled with a PostScript fill will be 
displayed containing containing the name of the fill that is used.

To fill objects with PostScript fills

1. Select the objects that you want to fill.
2. Click on the Color button.

The pop-up Color Palette will appear.
3. Click on the PostScript Fill button in the Color Palette.

The PostScript Fill dialog box will appear.
4. Select the fill style and set the parameters appropriately. 

The default parameters are set for optimum speed, so we suggest you use defaults whenever 
possible. 

5. Click on OK, or press [ENTER] when you are finished.
The PostScript Fill dialog box will disappear and the selected objects will be filled with a series of 
"PS"s.



PostScript Fill Dialog Box

Fill Styles List Box: Choose the PostScript Fill style that you want to use from this list.
Parameters box: This box contains the parameters that can be set for the select fill style. The 
parameters contained will change depending on what fill style is selected. The default parameters are set 
for optimum speed, so we suggest you use defaults whenever possible. You should note that the more 
complex you make your PostScript fill, the longer it will take to print.



Blend

Using the Blend... command located inside the Special menu, you can blend one selected object into 
another by having the program create intermediate shapes and colors between the two selected objects. 
The number of intermediate shapes and colors that are created depend on the number of blend steps that
you specify.
HiJaak Draw's blend feature allows you to blend along a curve and rotate the intermediate shapes while 
blending.
When you blend between two objects, the blending is performed from the selected object that is furthest 
back in the drawing order to the one that is closest to the front.
You can blend between objects that are filled or outlined with spot colors or process colors. Blending 
between an object that is filled or outlined with a spot color and one that is filled with a process color, 
creates intermediate blend shapes that are filled and outlined with process colors. You can also specify 
the intermediate colors for fills and outlines in the same way as that of linear and radial graduated fills. 
This feature allows you to create complex fill effects very easily.
HiJaak Draw gives you complete control over the way that your blend is created. You can specify start 
nodes, which are the starting handles on the first and the last object.
When the two objects do not have the same number of handles, additional handles are automatically 
inserted by the program. Sometimes you may want to control exactly how the handles map onto each 
other, and for this reason HiJaak Draw lets you specify matching nodes or handles. The matching nodes 
option allows you to maintain some specific characteristics or features of the objects.
HiJaak Draw lets you specify the direction in which the blend is to take place. The blend direction is 
important to the outcome of the blend. If the blend directions for the two objects are not the same, then 
you will get a blend that looks as if one of the objects is flipped over. You can use the Reverse Blend 
Direction option to correct this problem.
The distribution of the blend steps can be constant, accelerating, and decelerating. You can introduce a 
rotation angle to improve the blend smoothness or to create a twisting effect.
You can control how far from the first object the intermediate blend shapes are to start and how far from 
the last object they end, by specifying start and end margins.
All the blend parameters are specified inside the Blend dialog box.

To blend between two objects

1. Select the two objects that you want to blend.
2. Choose the Blend... command from the Special menu.

The Blend dialog box will appear.
3. Specify the blend parameters inside the Blend dialog box.

Related Topics:
Blend Options Dialog Box
Blending Along a Curve



The Blend Dialog Box

The First Box: The First Box shows the object from which the blend will start, the one furthest back in the
drawing order.
The Last Box: The Last Box shows the object at which the blend will end, the one closest to the front in 
the drawing order.
The Number of Steps field: Inside this field you enter the number of intermediate steps of the blend.
The Rotate field: Inside this field you enter the rotation angle for the blend. The blend will be performed 
in such a way so that the last intermediate blend shape is rotated by the angle you specify relative to the 
first intermediate blend shape.
Specify Matching Nodes checkbox: Selecting this checkbox tells the program that you want to specify 
matching nodes or handles on the first and last objects.
Reverse Blend Direction checkbox: Selecting this checkbox tells the program to reverse the blend 
direction of the first object relative to the last object.
Options... button: Clicking on this button causes the Blend Options dialog box to appear. IN this dialog 
box you can specify the type of blend: constant, accelerating, decelerating, locations of the first and last 
step, and the location of intermediate fill and outline colors.
On Curve button: Clicking on this button tells the program that you want to blend the first and last 
objects along a curve.



Blend Start Nodes

Inside the First and Last Boxes of the Blend dialog box, you will see images of the two selected objects. 
The blend will be performed from the first to the last object in the number of steps that you specify inside 
the Number of Steps field.
You will see a large arrow located at one of the nodes on both the first and last objects. This node 
represents the starting node of the blend. The red node indicates the first node of the object, and the 
orange node indicates the second node, showing the direction of the blend.
For open objects, the arrow can only be located at the start or end nodes, whereas for closed objects, the 
arrow can be located at any of the nodes.
By dragging the arrows around each of the objects, you can specify different matching starting nodes.

To specify a different starting node

1. Position the pointer on the arrow designating the starting node.
2. Press and hold the mouse button down, and drag the arrowhead around the object.
3. Release the mouse button when the arrowhead is at the desired starting node.

Perform the above procedure until you have specified the desired starting nodes for both the first and last 
objects.



Blend Direction

When you blend between objects, you are really blending individual points on the first object to points on 
the last object. Therefore, it is important in which direction (clockwise or counterclockwise) you blend the 
points on the first and last object. The blending direction coincides with the direction in which the objects 
were drawn.
When the blend directions are the same for both objects, either both clockwise or both counterclockwise, 
then you will generate a smooth blend.
However, if the blend directions are reversed or not the same, then you will create a blend that appears 
as if it is flipped over or has a twist in it.
If you blend the objects and you get a flipped over or twisted image, then the blend directions of the two 
objects are not the same. You can correct this problem by choosing the Reverse Blend Direction option.
HiJaak Draw uses a specially marked orange node to designate the second node of the blend. The blend 
will be performed starting from the starting node marked by the arrow and proceeding to the second node 
that is marked orange in color.

To reverse the blend direction

1. Select the Reverse Blend Direction checkbox inside the Blend dialog box.
The blend direction of the object will be reversed.



Blend Matching Nodes

When the objects that you are blending do not have the same number of nodes or handles, the program 
will automatically insert additional handles so that the blend can be performed. By specifying matching 
nodes, you can control which nodes or handles blend onto each other. Using the matching nodes you can
create very smooth blends where the unique characteristics of the blending objects are maintained 
throughout the blend.
Matching nodes are displayed in black. The are specified in pairs by clicking on a node on the object 
inside the First Box followed by its corresponding matching node on the object inside the Last Box. To 
specify matching nodes, simply click on top of the desired node.
You should pay strict attention to specify the matching nodes sequentially in the direction of the blend.

To specify matching nodes

1. Select the Matching Nodes checkbox.
2. Click on one of the nodes on the first object inside the First Box.
3. Click on one of the nodes on the last object inside the Last Box to specify the corresponding 

matching node.
4. Repeat steps 1 and 2 until you have specified all the desired matching nodes.



Blending with Rotation

When you blend with rotation, the intermediate blend shapes are rotated incrementally so that the last 
step would have been rotated through the specified angle from the first step. The blend rotation angle is 
specified inside the Rotation field in the Blend dialog box.
You can also generate some interesting special effects by introducing a rotation angle greater than 320 
degrees to create a spiraling blend.

To blend with rotation

1. Specify the blend parameters inside the Blend dialog box.
2. Enter the rotation angle inside the Rotate field in the Blend dialog box.
3. Click on OK, or press [ENTER] when you are finished.

Each intermediate blend shape will be rotated incrementally such that the last step would have 
been rotated through the specified angle from the first step.



Blend Options Dialog Box

Clicking on the Options... button inside the Blend dialog box causes the Blend Options dialog box to 
appear.
The Blend Ramp Types Box: From the Blend Ramp Types Box you can select the appropriate radio 
button to select the type of blend ramp that you want to use: constant, accelerating, decelerating. 
The First Step and Last Step fields: Inside these fields you enter a percentage value representing how 
far from the first object you want the first intermediate blend shape to be located. You can also specify 
how far from the last object you want the last intermediate blend shape to be located.
The Fill Colors... button: Clicking on this button brings up the Blend Fill Mid-Colors dialog box to appear.
This dialog box allows you to specify the locations of any of the intermediate fill colors and/or add 
additional intermediate fill colors. You specify the locations of these colors in exactly the same way as for 
linear and radial graduated fills. 
The Line Colors... button: Clicking on this button brings up the Blend Line Mid-Colors dialog box to 
appear. This dialog box allows you to specify the locations of any of the intermediate outline colors and/or 
add additional intermediate line colors. You specify the locations of these colors in exactly the same way 
as for linear and radial graduated fills.



Blend Ramp Types

When you create a blend you have the option of creating a blend that has constant, accelerating, or 
decelerating blend steps. A constant blend is one in which the intermediate blend shapes are spaced out 
evenly with equal spacing between each intermediate blend shape.
An accelerating blend is one where the spacing between intermediate blend shapes decreases as you 
approach the last blend object.
A decelerating blend is one where the spacing between intermediate blend shapes increases as you 
approach the last object.



Blending Along a Curve

HiJaak Draw can blend two objects along any curve in your artwork, just as easily as along a straight line.

To blend objects along a curve

1. In the document window, draw the curve you want to blend the objects along.
2. Select the objects that you want to blend along a curve.
3. Choose the Blend... command from the Special menu.

The Blend dialog box will appear.
4. Specify the blend parameters inside the Blend dialog box.

Refer to the earlier sections on how to specify the various blend parameters.
5. Click on On Curve.
6. Click the pointer's plus sign on the curve you want to blend along.



Distort

Using the Distort command, located inside the Special menu, you can distort objects and text using a 
predefined set of free-form or perspective envelopes. You can also create your own envelopes by 
distorting the objects using one of the predefined envelopes and then editing it to get the desired 
distortion. The Distort feature is particularly useful in generating perspective and wavy text effects.
You can also introduce vertical and horizontal curvatures to your distortion. These curvatures are useful 
for simulating objects wrapped on a cylinder or sphere.
When you select objects that have already been distorted, the objects are selected and the envelope is 
displayed as well. You can edit the envelope at any time using any of the four envelope editing methods. 
You can also remove the envelope of the distorted objects at any time, to restore the distorted objects to 
their original form.

To distort objects

1. Select the objects that you want to distort.
2. Choose the Distort/New Envelope... command from the Special menu.

The Select Envelope dialog box will appear.
3. Find the desired envelope by scrolling through the list of available envelopes.
4. Click on OK, or press [ENTER] when you are finished.

You can now edit the shape of the envelope to create your own custom envelope. The shape of the 
envelope can be edited at any time during your work session.

Related Topics:
Removing the Envelope



Select Envelope Dialog Box

The Free-Form checkbox: Selecting this checkbox lets you create free-form distortions. The various 
free-form envelopes will be displayed inside the preview box.
The Perspective checkbox: Selecting this checkbox lets you create perspective distortions. The various 
perspective envelopes will be displayed inside the preview box.
The Horizontal and Curvature representations: These representations are located to the right of the 
dialog box. You select from these representations to specify the horizontal and vertical curvature. Each of 
these representations will show a grid that has lines of different spacing. Where the lines are closest 
together is where the curvature will be most pronounced. For example, if you are distorting text, where the
curvature lines are closest together, the spacing between characters will be smallest.
The Replace Existing Envelope checkbox: If you attempt to distort objects that have already been 
distorted, you can either replace the old envelope, or you can place a new envelope over the old one and 
further distort the object.
The Envelope Preview Box: The Envelope Preview Box will display a sample of how the envelope will 
look. You can use the scrollbar to scroll through the list of envelopes.



Editing the Envelopes

You can create your own distort envelopes by editing the shape of one of the predefined envelopes or you
can edit the envelope of any objects that you already distorted. HiJaak Draw provides four different 
editing methods in the Distort sub-menu, located in the Special menu.
The object's imaginary bounding rectangle assumes the shape of the envelope that you specify and 
therefore the objects are distorted to fit inside this envelope.
The Bezier method lets you edit the envelope in the same manner as a bezier curve.
The Straight method lets you move any of the handles of the envelope while keeping the line segments 
between as straight lines.
The Two Curves method lets you move any handles of the envelope while allowing two directions of 
curvature.
The Single Curve method lets you move any of the handles of the envelope while keeping only one 
direction of curvature.
The best way to illustrate the different editing modes is by showing their effect on a piece of text.
You can change the shape of envelopes that have already been distorted at any time. When you select 
objects that have already been distorted, the envelope will be selected as well. You can then use any of 
the editing methods described above to change the shape of the envelope.
If you distort objects and then choose the Convert to Curve command from the Objects menu, the objects 
will be converted to curves and the envelope will be removed.



Removing the Envelope

Using the Remove Envelope command located in the Distort sub-menu, you can remove the envelope 
from the selected objects that have been distorted. This returns them to their original shape. You can 
remove envelopes at any time.

To remove an existing envelope

1. Select the distorted objects whose envelope you want to remove.
2. Choose the Distort/Remove Envelope command from the Special menu.

The envelope will be removed and the objects will be returned to their original shape.



Extrude

You can use the Extrude command located inside the Special menu to give your objects a three 
dimensional appearance. The extrude feature is particularly useful to create three dimensional title text for
posters and banners. 
HiJaak Draw provides two types of extrudes; using the Extrude/Shaded Block... command you can 
generate shaded extrudes or the Extrude/Solid Block command to create solid extrudes.
The solid extrude creates an extrude that simply paints the extruded contours all one color, while a 
shaded extrude shades the extruded contours according to the light source location that you specify. The 
latter provides more realistic looking three dimensional shapes.

Related Topics:
Remove Hidden Extrude Surfaces



Solid Block Extrude

The solid block extrude generates a three-dimensional object whose extruded contours are filled with a 
solid color that you specify. You drag an image of the selected objects to specify the depth and 
perspective of the extruded object and then the program generates the extruded contours for you.
You can drag any of the handles of the bounding box to resize the extrude image giving an illusion of 
perspective.
The object will be extruded and the extruded contours will be painted according to the currently selected 
default color. You can change the color of the solid block extrude at any time by selecting the extrude and 
then a color from the palette or color bar.
The extruded contours will be created as a group of objects, independent of the initial selected object, and
the extruded contours will remain selected.
It is suggested that you group both the initial objects from which the extrude was generated and the 
extruded contours. By grouping the contours and the initial object together, you will prevent the possibility 
where you may accidentally move one and not the other.

To create a solid block extrude

1. Select the objects that you want to extrude.
2. Choose the Extrude/Solid Block command from the Special menu.

The extrude image is placed directly on top of the selected object and it has a dashed outline and 
an extrude origin at its center.

3. Position the pointer on the extrude origin, press and hold the mouse button down, and drag away 
from the selected objects.
When you drag the origin, the extrude image moves with it.

4. Release the mouse button when the image is far enough away from the original to create the 
required appearance of depth.

5. Click anywhere away from the bounding box when you are finished.



Shaded Block Extrude

The shaded extrude simulates the effect of a light source shining on the extruded contours. The surfaces 
that are perpendicular to the light source are the highlights, and the surfaces that are parallel to the light 
source are the shadows. When you specify the shading colors, you specify the highlight color (the color 
for the portions of the objects closest to the light source) and the shadow color (color of the portions that 
are furthest from the light source). You can also specify any number of intermediate colors along the 
shading direction.
Specifying the shading colors is identical to specifying the blend colors of the linear or radial graduated 
fills. The Extrude Colors dialog box is similar to the Linear Graduated Fill dialog box.
To give more realistic looking three dimensional shapes, you can specify the location of a light source so 
that the extrude contours are shaded properly according to the location of the light source.
Once you have specified the extrude colors and the location of the light source, it is time to extrude the 
objects. When you extrude the objects, you simply move an image of the object to specify the depth and 
then the program creates the extruded contours for you. To create receding and expanding three 
dimensional representations, resize the extruded image to create the proper impression.

To create a shaded block extrude

1. Select the objects that you want to extrude.
2. Choose the Extrude/Shaded Block... command from the Special menu.

The Extrude Colors dialog box will appear.
3. Specify the shaded extrude parameters.
4. Click on OK, or press [ENTER] when you are finished.

The Extrude Colors dialog box will disappear.
5. Extrude the selected objects.

The method of extruding the selected objects is the same as that of a solid block extrude.



The Extrude Colors Dialog Box

The Light Source field: Inside this field you enter the location of the light source in degrees. The light 
source is located at the top of the artwork page when you specify 0 degrees, and at the bottom when you 
specify 180 degrees, to the left when you specify -90 degrees, and to the right when you specify 90 
degrees.
The Light Source Dial: Instead of numerically entering the location of the light source, you can drag the 
dial in a clockwise or counterclockwise direction to specify the location of the light source. The values in 
the Light Source field will change as you rotate the direction line to reflect the changing light source 
location.
The Multi Color Preview: The Multi Color Preview displays a full color preview of the way that the 
shading will look with the colors that you specify and their location along the shading direction.



Color Control

The Color Control command located inside the Special menu lets you manipulate the colors of selected 
objects. You can convert colors to gray scale, change a spot color to an equivalent process color, invert 
colors to create a negative, adjust the brightness or contrast, change the color balance, and posterize the 
colors.
These color control features are very useful for manipulating the colors of entire clip art drawings and 
illustrations. As an example, you can make the colors of an entire illustration lighter, and then use the 
illustration as a background.



Converting Fill and Outline Colors to Gray Scale

Using the Color Control/To Gray Scale command located inside the Special menu, you can convert the fill 
and outline colors of objects to an equivalent level of gray.
This feature is particularly useful in situations where you want to use an existing illustration or clip art 
drawing as a faded gray background for your new artwork. The gray background is created by converting 
the entire illustration to gray scale and then adjusting its brightness and contrast.

To Convert Fill and Outline Colors of Objects to Gray Scale

1. Select the objects that you want to convert to gray scale.
You can select all the objects in your illustration to convert them to gray scale simultaneously.

2. Choose the Color Control/To Gray Scale command from the Special menu.
The fill and outline colors of the selected objects will be converted to an equivalent level of gray.



Converting Spot Color Fills and Outline Colors to Process Color Equivalents

Using the Color Control/To Process Colors command located inside the Special menu, you can convert 
the spot color fill and outline colors (of selected objects) to process color equivalents.
For example, you may have an illustration that contains both spot colors and process colors but, to 
reduce the printing costs, you decide that you only want to use process colors. It would be a very time 
consuming process if you had to convert each spot color object into its process color equivalent. HiJaak 
Draw lets you convert entire illustrations into process colors instantaneously.
When you convert a PANTONE spot color to the process color equivalent, the exact CMYK values will 
depend on the PANTONE palette from which the spot color was obtained. This arises because not all 
printers are the same so each one requires its own PANTONE palette to reproduce the spot colors 
correctly.

To convert spot color fills and outline colors of objects into process color equivalents

1. Select the objects whose spot colors you want to convert to process color equivalents.
2. Choose the Color Control/To Process Colors command from the Special menu.



Inverting Fill and Outline Colors of Objects

Using the Color Control/Invert Colors command, located inside the Special menu, you can invert the 
colors of selected objects.
In the case of spot colors, only the tint of the color is inverted. As an example, a spot color with a tint of 
100 % will be changed to have a tint of 0 %, but the actual color does not change.
In the case of process colors, the color is converted to its CMYK complement. 
This feature is very useful for creating negatives of existing illustrations and clip art drawings. By selecting
the entire illustration and inverting the colors, you will create a negative of the illustration.

To Invert fill and outline colors of objects

1. Select the objects whose colors you want to invert.
You can select several objects in your illustration to invert them all simultaneously.

2. Choose the Color Control/Invert Colors command from the Special menu.
The colors of the selected objects will be inverted.



Adjusting Brightness and Contrast

Using the Color Control/Brightness/Contrast... command, located inside the Special menu, you can adjust
the color brightness and contrast levels of selected objects. The levels are adjusted inside the 
Brightness/Contrast dialog box where you can use the scroll bars to specify brightness and contrast 
levels. You can also specify the values numerically inside the brightness and contrast fields.
Being able to adjust the brightness and contrast levels of fill and stroke colors is useful. It allows you to 
create a faded effect in situations where you want to use one of your existing illustrations or clip art 
drawings as a background for your artwork. You can simply select the entire illustration, fade it, and then 
overlay other objects and text to create your new artwork.

To adjust the brightness and contrast levels of fill and outline colors of objects

1. Select the objects whose brightness and contrast you want to adjust.
2. Choose the Color Control/Brightness/Contrast... command from the Special menu.

The Brightness/Contrast dialog box will appear.
3. Specify a new brightness and contrast inside the Brightness/Contrast dialog box.
4. Click on OK, or press [ENTER] when you are finished.



The Brightness/Contrast Dialog Box

The Brightness scroll bar: You can move the scroll box inside the Brightness scroll bar to specify new 
levels of brightness. Increasing the brightness of spot colors reduces the tint, while decreasing the 
brightness increases the tint.
The Brightness field: Inside this field you can enter a specific level of brightness.
The Contrast scroll bar: You can move the scroll box inside the Contrast scroll bar to specify new levels 
of contrast. Increasing the contrast increases the difference between tints. Decreasing the contrast 
decreases the difference between tints, bringing them closer to gray.
The Contrast field: Inside this field you can enter a specific level of contrast.
The Apply button: Once you specify a new value for the brightness and contrast, clicking on the Apply 
button applies the new brightness and contrast values to the selected objects, leaving the 
Brightness/Contrast dialog box on the screen.



Adjusting the Color Balance

Using the Color Control/Adjust Color Balance... command, located inside the Special menu, you can add 
or subtract color components from an object. This feature is useful in situations where your original 
artwork or clip art has too much of one color and not enough of another, the color balance is not what you 
desire.
This feature is useful for colorizing black and white illustrations. For instance, you can select an entire 
illustration and then adjust the color balance by adding more blue to create a gray scale illustration in a 
tint of blue.

To adjust the color balance of objects

1. Select the objects whose color balance you want to adjust.
You can select several objects in your illustration to adjust their color balance simultaneously.

2. Choose the Color Control/Adjust Color Balance... command from the Special menu.
The Adjust Color Balance dialog box will appear.

3. Specify a new color balance inside the Adjust Color Balance dialog box.
4. Click on OK, or press [ENTER] when you are finished.



The Adjust Color Balance Dialog Box

The CMYK/RGB scroll bars: You can move the scroll box away from the center point to increase either 
the CMYK component or RGB component depending on which direction you move the scroll box. Moving 
the scroll box to the left increases the CMYK component, while moving it to the right increases the RGB 
component.
The CMYK value fields: Inside these fields you can enter the exact CMYK component values. Entering 
negative values has the effect of reducing the CMYK component values, or effectively increasing the RGB
values.
The Apply button: Once you specify new color balance values, clicking on the Apply button applies the 
new color balance to the selected objects, while leaving the Adjust Color Balance dialog box on the 
screen.



Posterizing Colors

Using the Color Control/Posterize Colors... command, located inside the Special menu, you can limit the 
number of colors or levels of gray in your artwork. This feature is useful when you have an existing gray 
scale illustration or clip art that is well graduated and you want to create a chunky look by reducing the 
number of levels of gray.
The number of colors or gray levels is specified inside the Posterize Colors dialog box.

To posterize colors of objects

1. Select the objects whose colors you want to posterize.
2. Choose the Color Control/Posterize Colors... command from the Special menu.

The Posterize Colors dialog box will appear.
3. Specify the limiting number of colors or gray levels inside the Number of Levels field.
4. Click on OK, or press [ENTER] when you are finished.



Library Window

When you choose the Libraries... command from the File menu, a Library window appears with the name 
of the current library inside its title bar. If no library has been opened or created, the window will be empty.
Inside the window you will see a preview of each of the symbols contained in the library. You can set the 
preview for the symbols as black and white or 16 colors, as well as the size of the preview.
The Symbols Box: Each of the symbols contained inside the library will be displayed inside their own 
box. Clicking on the symbol will highlight the box, indicating that the symbol is selected. You can use the 
scrollbar to scroll through the list of symbols in your library.
The File menu: From this menu you can choose the New... command to create a new library, the Open... 
command to open existing libraries, the Close command to close the current library, the Manager... 
command to bring up the Library Manager, and the Library Info... command to set the various library 
settings and to display the statistics for the library. The list of all opened libraries will appear at the end of 
the menu, with a checkmark beside the current library. To change the current library, simply choose the 
name of the new library from the list, and the library will appear inside the Library window.
The Symbol menu: From this menu you can choose the Place command to place the selected symbol 
on the artwork, the Add... command to add a new symbol to the current library, the Delete... command to 
delete the selected symbol, the Rename... command to rename the selected symbol, the Edit As 
Pattern... command to create a pattern fill with the selected symbol, and the Find... command to search 
for a specific symbol.
The Category button: Clicking on this button will bring up the category list that contains a list of libraries 
that have been organized as categories.

Related Topics:
Creating New Libraries
Rearranging Symbols in the Library



Opening Existing Libraries

HiJaak Draw lets you open up to ten libraries at any one time. A list of all currently opened libraries will be 
provided inside the File menu of the Library window. Existing libraries can be opened by choosing the 
Open... command from the File menu of the Library window.

To open existing libraries

1. Choose the Open... command from the File menu of the Library window.
The Open Library File dialog box will appear.

2. Select the library you want to open.
3. Click Open, or press [ENTER] when you are finished.



Creating New Libraries

HiJaak Draw lets you create any number of your own libraries. When you create new libraries, you specify
the name and path of the library, the symbol preview style and size, and whether you want to name each 
of the symbols or want the program to number them sequentially.

To create a new library

1. Choose the New... command from the File menu of the Library window.
The Create Library File dialog box appears.

2. Click Create, or press [ENTER] when you are finished.
The Create Library File dialog box will disappear and the New Library Parameters dialog box will 
appear.

3. Click on OK, or press [ENTER] when you are finished.



Create Library File Dialog Box

The Library Name/Description field: Inside this field you can enter a more descriptive name of the 
library. This name will be shown in the category list, if the library is included in the category list.
The Preview Size Box: From this box you can select the size of the symbol previews: Small, Large, or 
Custom. When you select a custom preview size, you enter the width and height of the preview inside the 
Width and Height fields.
The Preview Type Box: From this box you select the type of symbol preview, whether the preview is to 
be Black/White or in 16 Color. Color previews take four times as much disk space as black and white 
previews.
The User Named checkbox: Selecting this checkbox tells the program that you do want to name each of
the new symbols that you add to the library. If this option is not selected, the program will automatically 
number successive symbols for you. The Enter Symbol Name dialog box will not appear asking you for 
the symbol name.
The Compressed checkbox: Allows you to specify that library symbols will be saved compressed by 
default. You can compress any objects in your artwork.
The Squeezed checkbox: Selecting this checkbox allows you to compress certain types of artwork to a 
much smaller size than with the Compressed checkbox. However, graduated fills, patterns, spot colors, 
arrows, connection lines and text can not be saved in this format.
You can change whether symbols are compressed, squeezed, or saved normally at any time in the 
Library Info dialog box.



Adding Symbols to the Current Library

There are two methods for adding new symbols to the HiJaak Draw libraries:
You can drag the objects onto the Library window, and release the mouse button.
You can choose the Add... command from the Symbol menu of the Library window to make the 
selected objects into a symbol.

Symbols can be several objects contained in your artwork, or entire artworks. When you add a symbol to 
a    library, a preview of the symbol will appear inside the Library window. If the library requires you to 
name the symbol, the Enter Symbol Name dialog box will appear asking you to enter a symbol name.

Related Topics:
Adding Files To Libraries



Rearranging Symbols in the Library

You can only manually rearrange the symbols in your library, if the Sort Symbols option is not selected in 
the Library Info. To manually rearrange the symbols, simply drag the symbol to a new location in the 
Library window. The Library window will autoscroll if you drag beyond the edge of the Library window. 



Placing Symbols Onto Your Artwork

You can use the Place command from the Symbol menu of the Library window to place a selected 
symbol.
There are two methods of specifying the location and size of the symbol on your artwork page:

You can move the symbol bounding box to where you want to place the symbol, and click the 
mouse button.
You can place the bounding box and drag it to the proper size. The symbol will be scaled to fit 
inside the bounding box.

When you are placing symbols that contain Connection Sockets, and the Snap to Grid option is enabled 
in the View menu, the socket will snap to the grid instead of a handle on the symbol's bounding box. This 
allows you    accurately place irregularly shaped objects.
NOTE: You can double-click the mouse button on the symbol to select, and place on the artwork, without 
having to select the Place command.

To place a symbol on the artwork

1. In the Library window, select the symbol that you want to place on your artwork.
2. Choose the Place command from the Symbol menu of the Library window.

The symbol bounding box appears with the place symbol cursor located in the upper left corner. 
The bounding box is the same size as the original size of the symbol.

3. There are two options for specifying the location of the symbol.
First, you can move the bounding box to where you want to place the symbol, and click the mouse 
button.
Secondly, you can drag out a new bounding box at the location where you want to place the 
symbol. The symbol will be scaled to fit within the new bounding box.

Related Topics:
Sizing Library Symbols Before Placing



Deleting Symbols from the Current Library

You can use the Delete... command, located in the Symbol menu, to delete a selected symbol from the 
current library.

To delete symbols from the current library

1. Select the symbol that you want to delete.
2. Choose the Delete... command from the Symbol menu of the Library window.

The Delete Symbol dialog box will ask you to confirm the deletion.
3. Click on OK, or press [ENTER] when you are finished.



Renaming Symbols in the Current Library

You can rename a selected symbol in the current library by using the Rename... command located inside 
the Symbol menu of the Library window only if the User Named option is enabled in the Library Info dialog
box.

To rename a symbol in the current library

1. Select the symbol that you want to rename.
2. Choose the Rename... command from the Symbol menu of the Library window.

The Enter Symbol Name dialog box will appear.
3. Enter the new symbol name inside the Symbol Name field.
4. Click on OK, or press [ENTER] when you are finished.



The Library Manager

When you choose the Manager... command from the File menu of the Library window, the Library 
Manager dialog box will appear. The Library Manager lets you open two libraries at a time. From the 
Library Manager you can copy symbols from one library to another, create a new library and copy 
symbols from an existing library to the new library. You can also delete and rename symbols in a library.
The Library List Boxes: Inside each of the list boxes you will see a list of names of all symbols 
contained in the opened library. Clicking on a symbol name in the list boxes will select the symbol, and a 
preview of the symbol will appear inside the Preview Box. You can select a range of symbols by dragging 
over them in the list box. You can hold down the [CTRL] to extend symbol selection/deselection. You can 
only select symbols from one list box. If there are symbols selected in the other list box, they will be 
deselected.
The Preview Boxes: The Preview Boxes will show a sample preview of the selected symbol.
The Open... buttons: Clicking on this button brings up the Open Library File dialog box that lets you open
an existing library. When the library is opened, all the symbols contained in the library will be listed inside 
the corresponding list box.
The New... buttons: Clicking on this button brings up the Create Library File dialog box that lets you 
create a new library file. Once you have created a new library, you can now copy symbols from another 
library.
The Copy button: To copy symbols from one library to another, simply select a symbol from one of the 
libraries, and click the Copy button. The selected symbol will be copied to the other library.
The Rename button: To rename a symbol, select a symbol from the library symbol list, click on the 
Rename button, and enter the new name inside the Enter Symbol Name dialog box.
The Delete button: Clicking on this button will delete the selected symbols from the library.
The Done button: Clicking on this button tells the program that you are finished using the Library 
Manager, and the Library Manager will disappear.



The Library Info

When you choose the Library Info... command from the File menu of the Library window, the Library Info 
dialog box will appear. The Library Info dialog box contains information about the current library:

The name of the library, description, and size in bytes.
The type of symbol preview, and number of symbols contained in the library.
The various library preferences such as, whether to display symbol names, to auto-sort the 
symbols, whether the library is to be included in the category list, and to compact the library that 
has changed considerably.

The Filename field: Inside this field you will see the name of the current library. This field is for 
information only.
The Description field: In this field you can enter additional descriptive text for the current library. This 
name will be shown in the category list, if the library is included in the category list.
The Symbol Preview field: Inside this field you will see the type of symbol preview that is being used for 
the current library. The symbol preview is set when you create a new library, and cannot be changed.
The Total Size field: This field shows the size of the current library file in bytes.
The # Symbols field: This field displays the total number of symbols contained in the current library.
The User Named checkbox: Selecting this checkbox tells the program that you want to name each of 
the new symbols that you add to the library. If this option is not selected, the program will automatically 
number successive symbols for you. The Enter Symbol Name dialog box will not appear asking you for 
the symbol name.
The Show Names checkbox: Selecting this checkbox tells the program to show the symbol names or 
numbers inside the Library window.
The Sort Symbols checkbox: Selecting this checkbox tells the program to resort your library list 
whenever you make changes to the list, such as adding new symbols, or deleting symbols. You can select
either the Ascending or Descending radio buttons to tell the program in what order to sort the    symbols. If
the display is not sorted, you can manually drag symbols to new locations, to rearrange your symbols.
The Compressed, and Squeezed checkboxes: Selecting one of these checkboxes tells the program to 
save new symbols as compressed or squeezed. 
The Read Only checkbox: Selecting this checkbox tells the program not to let you do anything to change
the library file, such as delete symbols, or add new symbols.
The In Category List checkbox: Selecting this checkbox tells the program to include the library in the 
category list.



Categorizing Libraries

You may want certain libraries that you use frequently to be available in the category list every time you 
run the HiJaak Draw program. To do this, select the In Category List checkbox inside the Library Info 
dialog box, and the program will automatically add the library to the category list. You can see the 
category list by clicking on the Category button on the menu bar of the Library window.
If one of the libraries inside the category list is the current library, then you will see a checkmark beside it 
in the list. To choose another library as the current library, simply choose the name of the library from the 
list. A checkmark will appear beside the library name, indicating that the library is now the current library.



Styles Window

The Styles window will appear whenever you choose the Styles... command from the Edit menu. From 
the Styles window you can open existing style files, update existing style files, define new styles, remove 
styles, and apply styles to objects.
The File menu: From this menu you can choose the Open... command to open existing style files, the 
Save As... command to save any changes to the current style file, and the Close command to close the 
Styles window.
The Style menu: From this menu you can choose the Define... command to define a new style, the 
Remove command to delete a selected style, and the Apply command to apply the selected style to a 
selected object.
If no styles are present when the Styles window appears, the window will be empty. Otherwise, it will 
show all of the styles in the artwork.

Related Topics:
Copying Object Attributes



Opening Existing Style Libraries

To open an existing style library, choose the Open... command from the File menu of the Styles window. 
Then specify the file that you want to open inside the Open Styles dialog box.
When you open a new style file, the Styles window will adds the list of style names to the list.

To open an existing style library

1. Choose the Open... command from the File menu of the Styles window.
The Open Styles dialog box will appear.
The components of this dialog box are identical to those of the Open Drawing File dialog box.

2. Click on OK, or press [ENTER] when you are finished.
The names of the styles contained inside the opened style library will be added to the list inside the Styles
window.



Saving Style Libraries

To save a copy of this new updated style library, choose the Save As... command from the File menu of 
the Styles window. Specify the name of the file and where you want to save the file.
You can also use the Save As... command to save new style libraries.



Define Styles Dialog Box

You can use the Define... command from the Style menu of the Styles window to add the styles of a 
selected object to the style list. When you add styles to the style list, you specify the style name, and what
attributes are to be included inside the Define Style dialog box. If you define a style that has the same 
name as one that already exists, the program will ask you whether you want to replace the existing style. 
If you replace the existing style, then all objects in this artwork containing that style will be updated to 
reflect the change.
The Name field: Inside this field you enter the name of the style. The name will appear in the style list 
inside the Styles window.
The Objects Attributes box: Inside this box you select the various object attributes that you want to include
with the style. You have the choice of Fill and Stroke, and for stroke you can choose to include the Color, 
Style, and Arrows.
The Text attributes box: Inside this box you select the various text attributes that you want to include with 
the style. This is grayed out if there is no text selected. You have the choice of including Font, Size, Style, 
and Format.
The Envelope/Perspective checkbox: This checkbox is used for objects that are distorted. You can select 
this checkbox to include the distort envelope with the style. This feature is useful in situations where you 
want to apply the same distortion to another object. You can simply add the style of the first object to the 
style list, and then apply the style to the second object.



Removing Styles

HiJaak Draw lets you delete styles from the style list at any time during your work session. When you 
delete the style, it is removed from the list but the style file is not altered. If you want to make the changes
permanent you need to save them.

To remove styles

1. Select the style that you want to delete.
2. Choose the Remove command from the Style menu of the Styles window.



Applying Styles to Objects

When you apply styles to selected objects, only the style attributes that were included with the defined 
style will be applied.

To apply styles to objects

1. Select the objects whose style you want to change.
2. There are two methods of applying styles.

You can click on the style name inside the style list to select it, and then choose the Apply 
command from the Style menu of the Styles window.
Secondly, you can quickly apply a style by double-clicking the mouse button on the style name 
inside the style list.



Copying Object Attributes

You can use the Copy Attributes... command to copy attributes of a selected object. You specify which 
attributes are to be copied inside the Copy Attributes dialog box. Once you copy the attributes, you can 
use the Apply Attributes command to apply them to any number of objects. Only the attributes that were 
copied will change on the selected objects.

To copy attributes from one object to another 

1. Select the object whose attributes you want to copy.
2. Choose the Copy Attributes... command from the Edit menu, or press [CTRL][SHIFT][C].

The Copy Attributes dialog box will appear
.3. Select the attributes that you want to copy inside the dialog box.
4. Click on OK, or press [ENTER] when you are finished.
5. Select the objects to which you want to apply the copied attributes.
6. Choose the Apply Attributes command from the Edit menu, or press [CTRL][SHIFT][V].



The Copy Attributes Dialog Box

 This dialog contains the same options as the Define Style dialog box    but contains an extra button.
The As Default button: Clicking on this button makes the selected attributes the default. All objects 
drawn after this button is selected will contain these attributes.



Copying Objects onto the Clipboard

You can use the Copy command located inside the Edit menu to copy selected objects onto the clipboard.
The original objects in your artwork will remain unaffected.
Once you have copied objects onto the clipboard, you can use the Paste command to place the objects 
from the clipboard into another HiJaak Draw file. To do this, you simply copy the desired objects onto the 
clipboard, open a new file, and then choose the Paste command from the Edit menu. The objects from 
the clipboard will be pasted in the new file.
If you copy objects from HiJaak Draw and paste them into another application, HiJaak Draw will copy the 
objects in the Windows Metafile format.

To copy objects onto the clipboard

1. Select the objects that you want to copy onto the clipboard.
2. Choose the Copy command from the Edit menu, or press [CTRL][C].

Related Topics: 
Cutting Objects onto the Clipboard



Cutting Objects onto the Clipboard

The Cut command located inside the Edit menu will move the selected objects onto the clipboard, and 
remove the original objects from the artwork.
You can cut the selected objects from your artwork, and then use the Paste command to place the objects
from the clipboard into another HiJaak Draw file.
If you accidentally cut objects from your artwork, you can choose the Undo command from the Edit menu,
or press [CTRL][Z], to put the objects back in your artwork.

To cut objects onto the clipboard

1. Select the objects that you want to cut onto the clipboard.
2. Choose the Cut command from the Edit menu, or press [CTRL][X].

Related Topics:
Copying Objects onto the Clipboard



Pasting Objects from the Clipboard

You can use the Paste command located inside the Edit menu to paste objects onto the clipboard into 
your artwork.
The Cut, Copy, and Paste commands are very useful for swapping objects between different HiJaak Draw
files.
You can even copy objects from other applications onto the clipboard, and then paste them into HiJaak 
Draw. HiJaak Draw will accept the following formats:

Windows Metafile
Device Independent Bitmaps
Device Dependent Bitmaps
Text will be placed as text blocks

To paste objects from the clipboard

1. Choose the Paste command from the Edit menu, or press [CTRL][V].



Importing Illustrations from Other Sources

You can use the Import... command located inside the File menu, to import illustrations from other 
sources or applications. You choose the illustrations to be imported, and the desired import filter inside the
Import Files dialog box.
The type of files that you can import depends on the type of import filters that you installed during the 
installation procedure. 
The following is a list of some of the file formats that HiJaak Draw can import:

Adobe Illustrator (.AI)
Corel Draw (.CDR)
Encapsulated PostScript (.EPS)
Windows Metafile (.WMF)
CGM (.CGM)
HiJaak Draw (.PDW)
You can also import the following bitmap file formats:
PCX (.PCX)
TIFF (.TIF)
Windows 3.0 Bitmaps (.BMP)
GIF (.GIF)

When you import structured graphics, the objects contained in the graphic will be grouped and will be 
placed at the center of your document window. Imported bitmaps will also be placed at the center of your 
document window, however, they will not be grouped.

To import graphics and bitmaps

1. Choose the Import... command from the File menu.
The Import Files dialog box will appear.

2. Select the corresponding import file format, and choose the graphic that you want to import.
3. Click on OK, or press [ENTER] when you are finished.



Import Files Dialog Box

The Import Filter List Box: All the currently installed import filters will be listed inside this list box. They 
will be listed by their names, along with their corresponding file extensions. You click on the desired 
import file format to select it. The selected import filter will be highlighted. When you select an import file 
format, the File List Box will only display the filenames of the graphics that are that particular format.
The remaining components of this dialog box are identical to the File Open dialog box. 



Exporting HiJaak Draw Illustrations to Other Sources

You can use the Export... command located inside the File menu, to export any graphics that you create 
in HiJaak Draw to other sources or applications. You choose the file to be exported, and specify the 
export parameters inside the Export Files dialog box.
The following is a list of some of the file formats that HiJaak Draw can export:

Adobe Illustrator (.AI)
Encapsulated PostScript (.EPS)
Windows Metafile (.WMF)
SCODL (.SDL)
HPGL
HiJaak Draw (.PDW)
Animation Works Actors (.ACT)
You can also export to the following bitmap file formats:
PCX (.PCX)
TIFF (.TIF)
Windows 3.0 Bitmaps (.BMP)

When you export bitmaps, HiJaak Draw lets you control the resolution of the exported file inside the 
Export Files dialog box.
You can even export only selected objects from your artwork, as opposed to the entire artwork. To do this,
you select the objects within your artwork that you want to export, and then select the Selected only 
checkbox inside the Export Files dialog box.
Since the majority of the graphic file formats do not support multiple pages, HiJaak Draw only exports the 
current page.
Since most file formats do not support multiple layers, HiJaak Draw exports the objects from different 
layers as one layer. Hidden layers are not exported.
You cannot export radial graduated fills or patterns to DXF or SCODL.

To export graphics and bitmaps

1. Choose the Export... command from the File menu.
The Export Files dialog box will appear.

2. Select the graphic that you want to export, and select the corresponding export file format.
3. Click on OK, or press [ENTER] when you are finished.

Related Topics:
SCODL Export Dialog Box
Export Polygons Only Dialog Box
HPGL Mapping Dialog Box



The Export Files Dialog Box

The Export Filter List Box: All the available export filters will be listed inside this list box. They will be 
listed by their names, along with their corresponding file extensions. You click on the desired export file 
format to select it. The selected export filter will be highlighted, indicating that is selected.
The Type combo box: This combo box is used for selected export formats that have more than one type.
As an example, when exporting to Encapsulated PostScript format, this combo box will contain the three 
available types of preview: B/W Preview, No Preview, and Color Preview. The contents of this combo box 
will vary depending on the selected export format. This option may be disabled for some export formats.
The Resolution combo box: If the selected export format    involves bitmaps, this combo box will display 
various available bitmap resolutions in dots per inch. You can control the resolution of exported bitmaps 
by selecting the desired resolution from this combo box. This option may be disabled for some export 
formats.
The Selected only checkbox: Selecting this checkbox tells the program to export only the selected 
objects in your artwork, and not the entire drawing.
The remaining components of this    dialog box are identical to the File Open dialog box. 

Related Topics:
SCODL Export Dialog Box
Export Polygons Only Dialog Box
HPGL Mapping Dialog Box



Printer Setup

Before you print, you should make sure that the appropriate printer and port are selected. There are two 
methods of selecting the desired printer and port:

You can use the Control Panel in Windows.
You can use the Printer Setup... command located inside the File menu.

You choose the desired printer from the list of currently installed printer drivers, inside the Printer Setup 
dialog box.

To select the desired printer and port

1. Choose the Printer Setup... command from the File menu.
The Select Printer dialog box will appear.

2. Select the desired printer inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.

The Printer Setup dialog box will disappear.

Related Topics:
Printing



The Printer Setup Dialog Box

The Printer List Box: Inside this list box you will see a list of all the currently installed printer drivers, and 
the ports to which they are connected. When the dialog box appears, the currently selected printer will be 
highlighted. To select a new printer, click on the desired printer driver inside the list box. The selected 
printer will be highlighted indicating that it is selected.
The Setup... button: Clicking on this button will bring up a dialog box that contains all the printer 
information for the currently selected printer. Refer to the Windows User's Guide for additional information
on these printer dialog boxes.
You cannot add and remove printer drivers, or change the output ports, inside the Printer Setup dialog 
box. To do this, you need to go to Windows' Control Panel. For more information on how to add and 
remove printer drivers, and change the output ports, refer to your Windows User's Guide.



Printing

When you want to print your artwork, choose the Print... command from the File menu. The Print Setup 
dialog box will appear in which you specify how your artwork is to be printed. This dialog box contains 
several buttons that bring up other dialog boxes. This section describes the purpose of the buttons. 

Related Topics:
Printer Setup



Print Setup Dialog Box

The Printer Setup Information Box: Inside this box you will see information on the currently selected 
printer and your artwork size.
The Pages Box: From this box you can select which pages you want to print. You can select the All radio 
button to have all the pages printed, the Selected Objects Only radio button to print only the selected 
objects in your artwork, or the From radio button to tell the program to print only the range of pages that 
you specified in the From and To fields.
The Copies field: Inside this field you enter the number of copies of your artwork to be printed.
The Collated checkbox: Selecting this option tells the program to collate the printed pages. If you were 
printing three copies of an artwork collated, they will be printed as 1, 2, 3, 1, 2, 3, 1, 2, 3. If the pages are 
not collated, then the artwork will be printed as 1, 1, 1, 2, 2, 2, 3, 3, 3.
The Reversed checkbox: Selecting this checkbox tells the program to print the pages of the artwork in 
reverse order, starting from the last page.
The Tiled checkbox: This option is to be used when your artwork page is larger than the paper size 
supported by your printer. Tiling is the process by which your artwork is printed on several sheets of 
paper. When the sheets are combined they will create the entire image. Selecting this option tells the 
program to tile your artwork when printing, otherwise only the area of the artwork that fits on your printer 
paper size will be printed. You can click on the Tiling... button to specify the tiling options inside the Tiling 
Options dialog box.
The Panels As Pages checkbox: This option can be used when your artwork contains panels. Selecting 
this option tells the program to print each panel on a separate page. 
The Scale Box: The options inside this box allow you to change the size of the printed artwork. If your 
artwork is larger than the printer paper, you can reduce it to a certain size, or have the program reduce it 
for you so that it fits on the paper. You can select the Normal radio button to keep the artwork at its 
original size, or Fit in Page radio button to scale the artwork such that it fits on a single page. You can also
enter a custom scaling factor as a percent inside the field.
The Print As Box: For color illustrations, there are a number of ways they can be printed. If you have a 
color printer, you can select the Color Composite radio button to print a color reproduction of your artwork.
You can select the Black/White radio button to print a black and white version of your artwork, or the Color
Separation radio button to print out color separations. When you select the Color Separation option, you 
also have the option of selecting the As Process Only option to convert spot colors used in your artwork to
process colors. If you select the Color Separation option, you can click on the Separation... button to 
specify more separation options.
The Options... button: Clicking on this button brings up the Print Options dialog box that lets you specify 
the number of bands in a graduated fiils, bleeds, image, and registration marks. You can specify the 
number of bands in a graduated fill. This allows you to specify a more gradual blend between colors or a 
more striped effect. You can print the artwork as a positive image which is normal, emulsion down, or as a
negative. You can choose between printing registration marks, crop marks, and the color names on you 
color separation sheets.
The Tiling... button: Clicking on this button brings up the Tiling Options dialog box that lets you set the 
amount of overlap between tiles, and the position of the starting tile.
The Transfer... button: Clicking on this button brings up the Transfer Functions dialog box that lets you 
adjust the corresponding gray levels for each of the process colors and spot colors. This will give you the 
best results from your printer.
The Separation... button: Clicking on this button brings up the Color Separation Options dialog box. In 
this dialog box you can specify halftone parameters, printing options such as overprinting, and trapping, 
and select only certain ink colors to be printed. This button will be grayed out if the Color Separation 
option is not selected in the Print As box. 
The Printer... button: Clicking on this button brings up the printer driver setup. For more information on 



how to use this dialog box, refer to your Windows User's Guide.
The Print to File button: Clicking on this button brings up the Print to File dialog box. This will print your 
artwork to a file so that you can print the artwork from DOS later, or examine the printing output.



Color Separation Options Dialog Box

Clicking on the Separation... button inside the Print dialog box will bring up the Color Separation Options 
dialog box. Inside this dialog box you can specify which colors in your artwork are to be printed, the 
halftone settings for individual colors, and the printing method.
The Colors List Box: Inside this list box all the spot colors and process colors contained in your artwork 
will be listed, along with the current halftone settings, and printing options. A checkmark to the left of the 
color indicates that the color will be printed. You can toggle between which colors are to be printed and 
not printed by clicking on the checkmark. Clicking on the color will select the color, highlighting it, and you 
can now change the halftone parameters, and printing options for that color.
The Print All Inks button: Clicking on this button tells the program to print all ink colors.
The Bitmap Separations box: This box contains two options: Under-Color Removal and Black 
Generation. These options allow you to alter the color of bitmaps --    which can be difficult to do 
otherwise.    The Under-Color Removal option lets you specify a percentage of under colors to remove 
and print. The Black Generation option allows you to specify how much black is used in printing colors, 
this allows you to brighten or dull the printed bitmap. 
Under-Color removal: This specifies the percentage of the minimum yellow, magenta, and Cyan that is 
removed from each color. For example, if the color consists of 50% yellow, 40% magenta, and 20% cyan, 
the minimum for these colors would be 20%. Specifying an Under-color removal of 50% would mean that 
50% of the minimum (20%) is removed from each color, therefore each color is reduced by 10%.
Black Generation: This specifies the amount of black to be printed, as a percentage of the minimum. 
Using the color example in the last paragraph, and a Black Generation of 50%, a 10% black screen is 
added to the colors in the artwork.
The Screen Box: From this box you can select the Default radio button to select the default printer 
screen options, or you can select the Custom radio button to specify your own screen parameters. When 
you select the custom option, you specify your own screen angle in degrees, and screen frequency in 
lines per inch, in the fields next to the radio button.
The Options Box: From this box you can select the Knocked Out radio button to have the areas 
overlapped by another ink color knocked out. This means the fill directly beneath the overlapping fill will 
be not be printed which keeps the top color true. The Overprint radio button to overprint the fill and outline
colors of objects overlapping the selected ink, the Trap radio button to specify the amount of trapping on 
overlapping objects. If you select the trap option, you specify the amount of trapping in points (from 0 to 
10), in the field next to it, and then choose from two types of traps, Choke and Spread. 



Trapping Objects

When your color separations are printed, if the printing plates are not lined up exactly, the final output will 
have white areas showing where objects do not overlap properly. Trapping is the process by which you 
introduce a slight overlap between colors.
HiJaak Draw provides two types of traps: the choke mask, and the spread mask. Choke masks cause the 
larger of the two objects to spread to overlap the smaller object. Spread masks cause the smaller of the 
objects to spread to overlap the larger.



Transfer Functions Dialog Box

When you specify tint levels, or process color levels in your artwork, what the printer prints may differ from
the levels that were originally intended. The transfer function is a graph that allows you to correct the tint 
or process color levels for the specific printer that you are using. HiJaak Draw allows you to specify your 
own transfer functions to get the best output results.
Clicking on the Transfer... button inside the Print dialog box will bring up the Transfer Functions dialog box
that lets you specify your own tint and process color transfer functions.
The Spot Colors radio button: Selecting this radio button tells the program that you want to adjust the 
transfer function for the spot colors. The current spot color or tint transfer function will appear inside the 
Transfer Function Graph box.
The Process Colors radio button: Selecting this radio button tells the program that you want to adjust 
the transfer function for the process colors. You then select which of the four colors that you want to 
adjust by selecting one of the Cyan, Magenta, Yellow, and Black radio buttons. The current process color 
transfer function will appear inside the Transfer Function Graph box, when you select one of the four 
process color radio buttons.
The Transfer Function Graph Box: You drag the handles of the transfer function to specify new tint and 
process color levels. The levels appearing along the horizontal axis are the requested levels in your 
artwork, while the levels along the vertical axis will be the actual printer levels.



Placing Your Own Registration and Trim Marks

You may find it more convenient to place registration marks and trim marks on the artwork yourself, 
instead of relying on the program to place these marks on the final output. You can do this by using the 
Registration command located inside the Special menu. The Registration command has a submenu that 
contains the following commands:

The Trim Marks (Box) command places horizontal and vertical trim marks at the corners of a 
bounding box that you specify.
The Trim Marks (Horizontal) command places horizontal trim marks at the ends of a horizontal line 
that you specify.
The Trim Marks (Vertical) command places vertical trim marks at the ends of a vertical line that you 
specify.
The Registration Marks command lets you place registration marks anywhere on your artwork 
page.

These marks will be placed on the Registration layer. If the layer does not exist, the program will create it.
The markers will be printed with full CMYK component values (C = 100%, M = 100%, Y = 100%, and K = 
100%).
The marks can be moved, distributed, aligned, and deleted, just as any other objects in your artwork.
You can use any of the precision positioning tools to help you place these marks at specific locations, or 
in specific relationships to other objects.

To place both horizontal and vertical trim marks simultaneously

1. Choose the Registration/Trim Marks (Box) command from the Special menu.
2. Drag out a bounding box that encloses the objects in your artwork.

To place horizontal trim marks

1. Choose the Registration/Trim Marks (Horizontal) command from the Special menu.
2. Drag out a horizontal line.

To place vertical trim marks

1. Choose the Registration/Trim Marks (Vertical) command from the Special menu.
2. Drag out a vertical line.

To place registration marks

1. Choose the Registration/Registration Marks command from the Special menu.
2. Move the registration mark to where you want the registration marks to be located.
3. Release the mouse button when the registration mark is at the desired location.
4. Repeat steps 1 through 3 to place additional registration marks on your artwork.



The Tiling Options Dialog Box

Clicking on the Tiling... button inside the Print dialog box will bring up the Tiling Options dialog box. This 
dialog box lets you specify the amount of overlap between tiles, and the position of the starting tile.
The First Tile X and Y fields: Inside these fields you enter the location of the upper left corner of the first 
tile, relative to the upper left corner of the artwork page.
The Vertical and Horizontal Overlap fields: Inside these fields you enter the amount of horizontal and 
vertical overlap between adjacent tiles.
The Preview Box: The Preview Box will show where the first tile is located relative to the artwork.



Configuring the HiJaak Draw Screen

You can use the submenu commands of the View/Screen Layout menu to configure the appearance of 
the HiJaak Draw screen. Using these commands, you can hide and show the rulers, the color bar, the 
modifier palette, the scrollbars, the status bar, and the multiple page list. When these items are visible, a 
checkmark will appear beside the commands inside the Screen Layout submenu.
You can turn any of these items on and off at any time during your work session. If you have enabled the 
Save Screen Layout on Exit option in the Preferences dialog box, the screen configurations will be saved 
so that the screen configuration will remain the same the next time you run the program.
If you turn off the modifier palette, the method button will no longer be visible. Turning the modifier off will 
have no effect on the pop-up modifier palette. You can always access the pop-up modifier palette by 
holding down the [Spacebar], whether the modifier palette is visible or not.

Related Topics:
Preferences



Preferences

You can use the Preferences... command located inside the View menu to specify various default 
parameters. The default settings are specified inside the Preferences dialog box.
You can change the preferences at any time during your work session, and the preferences will be saved 
inside the HJDRAW.INI file.

To set the preferences

1. Choose the Preferences... command from the View menu.
The Preferences dialog box will appear.

2. Specify your preferences inside the dialog box.
3. Click on OK, or press [ENTER] when you are finished.



The Preferences Dialog Box

You can set default settings in the Preferences dialog box many of these settings can be temporarily 
overridden in other dialog boxes.
The Backup Before Save checkbox: Enabling this checkbox tells the program to create an automatic 
backup whenever you save the program. The backup will be saved with the extension .PD~. 
The Automatic Timed Save checkbox and field: This option allows you to have the program save your 
work automatically at specific intervals. When this checkbox is enabled, you can enter toe save intervals, 
in minutes, into the field. 
The Handle Size options: You can select either the Normal or Large radio buttons to choose the way 
that the anchor handles are to be displayed.
Select Hollow Shapes by Interior checkbox: Enabling this option allows you to select hollow objects by
clicking inside their outline, unless they are on top of a filled object. When this option is disabled, objects 
without a fill can only be selected by clicking on their outlines.
Select Locked Objects: When this option is disabled, you cannot select locked objects at all. When this 
option is enabled, you can select them, but not move them by dragging, or reshape them.
Toggle Selection Mode: Enabling this option means that when you press and hold on an object, you will 
switch between Normal Selection Mode, Resize Mode, and Rotate Shear Mode. If this option is not 
enabled, you will always be working in Normal Selection Mode.
The Graduated Fills box: This box allows you to set the maximum number of bands to display in a 
graduated fill. Lowering this number will give you a faster screen redraw time. Raising the number will 
give you a more gradual on-screen graduated fill. Enabling Always Display Maximum will always fill an 
object with the Maximum Number of Bands Displayed, even if the object is small and would normally be 
filled with fewer bands.
The Text Blocks box: In this box you can specify the Greeking Limit for text blocks in your artwork. 
Greeking is specified as in pixels. All text in the block that is smaller than the specified pixel limit, is 
greeked (displayed as gray blocks). Greeking can be set anyhere between 0 and 24 pixels. Choosing 0 
pixels means the text will never be greeked.
The Measurement Units box: From this combo box you select the default measurement units. The 
available units are: inches, centimeters, points, and picas.
The Nudge Factor Field:This field allows you to set how far an object is moved when you nudge it with 
the cursor keys.
Rebuild Font List Checkbox: You can choose to rebuild the font list when you load HiJaak Draw. If the 
Rebuild Font List checkbox is selected, the list will be rebuilt every time you load. If this option is not 
selected, the program will use the same font list as previously. The only time it is necessary to rebuild the 
list is if you add or move fonts.
The Save Screen Layout On Exit checkbox: Selecting this option tells the program to save the screen 
configuration upon quitting the program.



File Menu

CTRL+N New Page
CTRL+O Open File
CTRL+S Save
CTRL+P Print
CTRL+F4/CTRL+Q Exit



Edit Menu

ALT+BACKSPACE/CTRL+Z Undo
SHIFT+DELETE/CTRL+X Cut
CTRL+INSERT/CTRL+C Copy
SHIFT+INSERT/CTRL+V Paste
DELETE Clear
CTRL+SHIFT+C Copy Attribute
CTRL+SHIFT+V Apply Attribute
CTRL+A Select All
CTRL+SHIFT+A Reverse Select
CTRL+D Duplicate



Arrange Menu

F2 Bring to Front
F3 Send to Back
SHIFT+F2 Move up one position in drawing order
SHIFT+F3 Move down one position in drawing order
CTRL+F2 Move in front of highest selected object
CTRL+F3 Move behind lowest selected object
CTRL+G Group
CTRL+U Ungroup
CTRL+J Join
CTRL+K Align Objects
CTRL+SHIFT+K Align Handles
ALT+K Distribute Objects
ALT+SHIFT+K Distribute Handles



View Menu

F9 Toggles Outline Only Preview
CTRL+F9 Toggles Preview Outline with Line Width
SHIFT+F9 Full Screen Preview
CTRL+1 Normal View
CTRL+2 Show Entire Page
CTRL+3 Show All Objects
CTRL+4 Refresh Screen
F5 Toggles Snap to Grid
F6 Toggles Snap to Handles
F7 Toggles Snap to Guides
F8 Toggles Snap to Cross Hairs
F12 Drawing Angles
F11 Guides
SHIFT+F11 Rulers and Grids



Objects Menu

CTRL+SHIFT+G Make Compound
CTRL+H Hide
CTRL+SHIFT+H Show All 
CTRL+SHIFT+U Release Compound
CTRL+L Lock
CTRL+SHIFT+L Unlock All



Tools

CTRL+Right Mouse button Zoom-in
SHIFT+CTRL+Right Mouse button Zoom-out
CTRL+Zoom-in tool Drags zoom rectangle from the top right corner.
Right Mouse Button Scroll Page
TAB Toggle between Pointer and last tool used.



Modifier Keyboard Equivalents

1 None
2 Center
3 Corner
4 Outline
5 Percent Segment
6 Intersection
7 Perpendicular
8 Parallel/Tangent
9 Numerical Entry
SPACE BAR Brings up the Floating Modifier Palette at the present cursor position.



Selecting Objects

SHIFT+Pointer tool Selects multiple objects by clicking on them one after another. An object can be 
deleted from those selected, by holding down the [SHIFT] key and clicking on it again or dragging over 
selected objects. Also works on handles in Handle Selection mode. 
SHIFT+Marquee tools Selects multiple objects by clicking on them one after another. An object can be 
deleted from those selected, by holding down the [SHIFT] key and clicking on it again or dragging over 
selected objects.
CTRL+Marquee tools Selects all objects closed in or crossed by the marquee tools.
CTRL+Pointer tool Selects all objects closed in or crossed by when dragging out a marquee.
ALT+Marquee tools Selects all handles closed in or crossed by the marquee tools. 
ALT+Pointer tool Picks up object by anchor handle in object selection mode. Selects entire object in 
handle selection mode.
Double-click on pointer tool Selects all objects in artwork.
Double-click on marquee tools Selects all objects in artwork.



Dialog Boxes

Double-click on a rectangle or Rectangle tool    Brings up the Corner Radius dialog box. 
Double-click on an arc or any Arc tool Brings up the Arc Styles dialog box.
Double-click on connection line or any connection tool Brings up Connection dialog box. 
Double-click on curve anchor handle Brings up the Anchor Handle dialog box.
Double-click on curve segment Brings up Line Segment dialog box.
Double-click on ruler guides Brings up Guides dialog box.
Double-click on ruler Brings up Guides dialog box
Double click on any curve tool Brings up Freehand Tolerance dialog box.
Double-click on Grating Tool Brings up Grating Parameters dialog box. 
Double-click on polygon Brings up the Corner Radius dialog box.
Double-click on Regular Polygon/Star tool Brings up the Regular Polygon/Star    dialog box.
Double-click on Percent Modifier tool Brings up Line Segment dialog box.
Double-click on Rotate tool Brings up Rotate dialog box.
Double-click on Scale tool Brings up Shear dialog box.
Double-click on Shear tool Brings up Scale dialog box.
Double-click on Reflect tool Brings up Reflect dialog box.
Double-click on Scissors tool Brings up Cut Objects dialog box.



Displaying Artwork Shortcuts

Double-click on Zoom-in tool Displays artwork at actual size.
Double-click on Zoom-out tool Displays the entire artwork page.



Constraint Keys

SHIFT Constrains mouse movements to 45 degree increments with arcs, polygons, lines, circles, curves, 
tangent lines.
SHIFT+Rectangle Constrains to square.
SHIFT+Ellipse Constrains to a circle.
SHIFT+Grating Constrains to a square.
SHIFT+Elliptical Arc Constrains to circular arc.
CTRL+Elliptical Text Effects Draws ellipse from the center.
SHIFT+Elliptical Text Effects Draws circles to place text on.
SHIFT+Text Block Places a square text block.
CTRL Generally switches between two drawing methods. Holding down the [CTRL] key while using either
method, will switch to the alternate method for as long as the [CTRL] key is held down.
CTRL+Ellipse/Rectangle Switches drawing methods between: Corner-Corner and Center-Corner or 
Angled-Corner-Corner and Angled-Center-Corner.
CTRL+Circle Switches between Diameter and Radius Drawing methods.
CTRL+Line Switches between End-End and Mid-Point-End drawing methods.
CTRL+Polygon Places a spline curve line segment as part of a polygon.
CTRL+Pen Places a spline curve line segment as part of the bezier curve.
ALT+Curve tools Switches from Symmetric or Smooth handles to Corner handles. Press and hold the 
[ALT] key while clicking on the handle placed, and dragging out the tangent line. 
BACKSPACE Deletes the last segment of a bezier or spline curve during the drawing action.



Transformations

C Transforms a copy of an object during any transformation (Rotate, Shear, Bilinear Skew, et cetera) 
leaving the original object the same. The [C] key must be pressed when the transformation is completed.
+ (on numeric keypad) Transforms a copy of an object during any transformation (Rotate, Shear, 
Bilinear Skew, et cetera) leaving the original object the same. Toggles on and off.
SHIFT+Scale (resize) Keeps the aspect ratio of the object constant while scaling an object. Also applies 
when resizing an object by dragging the handles. When reshaping or resizing lines, [SHIFT] keeps the 
line on the original slope.
CTRL+SHIFT+Scale Scales either horizontally or vertically.
SHIFT+Rotate Confines rotation to 45 degree angles.
SHIFT+Shear Shears in one direction only.
SHIFT+Reflect Places line of reflection at 45 degree angles only.
SHIFT+Skew Constrains the skew action to either a horizontal or vertical direction.
SHIFT+Distort Distorts in one direction only.
SHIFT+Scissors Places cut lines at 45 degree angles.



Groups

Double click on a group Enter the group to alter individual objects.



Baseline Shift

The Baseline Shift command in the Type menu allows you to move selected text up or down. This
command brings up a dialog box allowing you to specify, in points, the amount to shift the 
baseline from the standard baseline. Positive values will move the text up, negative values will 
move the text down.



No Reshape

The No Reshape option in the Objects menu allows you to specify objects that cannot be 
reshaped by dragging handles.This means that you cannot accidently reshape them, but can still 
select the objects and transform them with the Transformation tools. 
Objects that have the No Reshape option enabled for them, will not have handles, but will have a 
gray bounding box instead. Library items that contain connection sockets have the no reshape 
option enabled automatically.

To enable the No Reshape option

1. Select the objects for which you want to enable No Reshape.
2. Choose No reshape from the Objects menu.

The selected objects will now have a gray bounding box instead of handles.



Selecting Hidden Objects

Holding down the [CTRL] key while clicking repeatedly on overlapping objects with the Pointer 
tool, will cause the overlapping objects to be selected one by one, cyclically. This is useful for 
selecting objects that are almost entirely covered by another object.



Zoom Scale

Clicking on the status bar beside the Transformation tools will bring up a pop-up Zoom Scale. You
can click on this scale to specify a zoom level between 25 % and 400 %. The black arrow on the 
right of the scale indicates the current zoom level.



Automatic Timed Save

If you have enabled the Automatic Timed Save in the Preferences dialog box, your document will 
be periodically saved. If you are working on an untitled artwork, the first autosave will bring up a 
dialog box asking you for the filename. If you click on Cancel in this dialog box, HiJaak Draw will 
not attempt to autosave the document until after you have manually saved it, giving it a filename.
Autosave will only save the artwork if it has changed. Autosave will create backup files if the Save
Backup File option is enabled in the Preferences dialog box.



Add Files To Libraries

The Add Files... command in the Library window's Symbol menu, allows you to select a number of
files and automatically add them to a library. These do not have to HiJaak Draw files. You can add
any file to a library, as long as you have installed an import filter for it.

To add files to a library

1. Open the library you want to add files to.
2. Select Add Files... in the Library window's Symbol menu.

The Add Files To Library dialog box appears.
3. Select the files you wish to add to the library, and click on the Add button.

If you want to add files from different directories, you can do this repeatedly.
3. When all of the files you want to add are in the Files To Add list box, Click on OK, or press 

[ENTER].
The files are added to the current library.

If you have the User Named Symbols option enabled in the Library Info dialog box, the original 
filename is used as the symbol name.



Sizing Library Symbols Before Placing

The Symbol Size... command in the Library Window's Symbol menu allows you to specify the size
or scale that all symbols will be placed at. Choosing this command brings up the Symbol Size 
dialog box containing 2 options:

The Scale radio button and field: When this option is enabled, you can enter the 
percentage you wish to scale all symbols by, when they are placed. The default is 100%
The Size radio button and field: When this option is enabled, you can specify the 
maximum horizontal and vertical size of the symbol. Specifying 1 inch in this field means 
that all symbols will fit in 1 inch squares.

To size symbols before placing them

1.Choose Symbol Size from the Library window's Symbol menu.
The Symbol Size dialog box appears.

2. Set the scale or size that you desire, and click on OK, or press [ENTER].
3. Place symbols onto your artwork normally.



Exporting Animation Works Interactive Cells

HiJaak Draw artwork can be exported to Gold Disk's Animation Works Interactive as an actor's 
cell, or series of cells. This allows you to create intricate actors within HiJaak Draw and export 
them for immediate use with Animation Works Interactive.
If there are objects selected, each grouped or single object will export as a separate cell in the 
actor. If no objects are selected, each layer in the artwork will export as a separate cell.



Moving Objects By Nudging

You can move objects in your artwork by nudging them with the cursor keys (arrows) on your 
keyboard. 
The nudge factor is set in the Preferences dialog box, and specifies how far the object will move 
each time you press a cursor key.

To nudge an object

1.Set the desired nudge factor in the Preferences dialog box.
2. Select the objects you want to nudge.
3. Press the cursor key corresponding to the direction you want to nudge the objects. 

Each time you press the cursor key, the objects will move, in the direction of the cursor key,
by the nudge factor.



Remove Hidden Extrude Surfaces

The Remove Hidden Surfaces command in the Special/Extrude menu removes any surfaces of 
the extrude object that are entirely covered by other surfaces in the object. This causes the 
original Extrude action to take longer, but subsequent screen refreshes will be quicker.



Show Current Cursor Position

The Show Current Cursor Position command in the View/Show Options menu, is a toggle 
command. When this command is enabled, the Status bar below the Document window will 
reflect the cursor's current X and Y position during a drawing action. If the command is disabled, 
the position will not be displayed.



HiJaak Draw INI File

The HiJaak Draw INI file contains a few settings you may want to change manually. Most of the 
settings in the INI file can b set within the program using the Preferences dialog box and the Page
Setup dialog box. If you are going to make changes to the HJDRAW.INI file, be sure to make a 
backup copy of this file first. This file contains many of the custom settings for HiJaak Draw, and 
accidentally changing something could have negative effects.
The INI file can be edited in any text editor. The Microsoft Windows Notepad works well.
If you make changes to the file and then have problems with the program, revert to the backup 
copy that you made of the INI file.
The settings that you may wish to change in the file are:
zoomMode: This allows you to decide whether you want the Zoom-in tool to drag out a zoom 
rectangle from the center or from the corner by default. If this is set to 0, the zoom rectangle will 
be drawn from the center, if it is set to 1, it will be drawn from the corner.
angleOrientation: This allows you to decide if you prefer to have all of the angle dials in the 
program to measure in compass mode (0 degrees at the top, measuring clockwise) or graph 
mode (0 degrees at 3 o'clock, measuring counterclockwise. If this is set to 0, compass mode will 
be used, if it is set to 1, graph mode will be used.
UseFontFile: Uses the existing font file, or re-searches for fonts if you add new fonts or font 
paths.    If this is set to 0 the file will be rebuilt, if it is set to 1 the existing font file is used.
UseATM: Allows you to use ATM to manage your Type 1 fonts, or use HiJaak Draw's font dll to 
manage them. If this is set to 0 HiJaak Draw's dll will be used. If this is set to 1 ATM will be used
Font Locations: Allows you to specify where fonts have been added without re-running the 
installation program.
New font types and paths should be specified as:

FontTypeName=Fonttdllpath[,fontpath[,fontmetricspath]]
where everything in square brackets is optional, and necessary only if fonts and font metrics are 
in different directories than the dll. If you do have more than one path in the line, they should be 
separated by commas. You can have up to 10 font locations specified. Each one is entered on a 
separate line.



SCODL Export Dialog Box

Background Color Box: Allows you to set the background color of your export slide to black, 
white (will be transparent on the slide), or a custom color by enabling the appropriate radio 
button.
Custom Radio Button: Enabling this button allows you to specify a colored background by 
entering the components for Red, Green and Blue into the    fields to the right.
Background Preview Box: Displays the currently selected background color.
# of Colors: Tells you how many colors are in the artwork you are exporting. SCODL Devices will
not accept more than 255 colors. If you attempt to export more than 255 colors to SCODL, results
are unpredictable. If there are too many colors, and you have Linear Graduated fills in your 
artwork, you can reduce the number of bands in the fill that are exported, thereby reducing the 
total number of colors.
Specify # of Bands: Allows you to specify the number of bands in a linear graduated fill that will 
be exported. NOTE: You cannot export patterns or radial fills to SCODL.
Export as Polygons: Converts curves to a series of straight line polygons. If this option is 
enabled, the Export Polygons Only dialog box appears.



Export Polygons Only Dialog Box

This dialog box appears when you export drawings to HPGL, or DXF and when you export to 
SCODL as Polygons.
Smoothness Factor:Specifies how closely the polygon lines will follow a curve.    A smoother 
setting will create more, shorter lines that closely follow the curve. A coarser setting will create 
fewer, longer lines and a more jagged appearance.



HPGL Mapping Dialog Box

Item box: This box contains checkboxes allowing you to choose what types of items are included
in the Items list box. You can include layers, dashes, line types, and fill types. The list box 
displays all of the items you have chosen to map. These are selected by enabling the appropriate 
checkboxes in the Include box. The Map all items together checkbox allows you to map all 
objects in the list box to what you one pen, fill type and/or line type.
Map To Box: This box contains lists of the pens, line types and fill types available for your HPGL 
device. You specify what these options are in the HP Device Info box to the right. To map an item 
to a pen and fill or line type select the item, and then click on the appropriate pen and line or fill 
types. If your HPGL device will support it, you can also specify the spacing between lines that 
make up a fill type, and the angle the fill type is placed on.
Output Device box: This box contains a list of HPGL devices. When you select the device you will be 
outputting to, the options in the Map To box will change to reflect the pens, line types, and fill types 
available for that device. The Custom... button brings up the HPGL Device Options dialog box.

Print Options Dialog Box

Clicking on the Options... button inside the Print dialog box will bring up the Print Options dialog box 
which contains options for the number of graduated fills, a bleed, print image and registration. 
# of Graduated Fill Bands field: In this field you can specify the number of bands that will be printed in 
graduated fills. This allows you to have your graduated fills print differently then they are displayed on 
screen. Entering a larger number in this filed will create a smoother looking fill, lower numbers will create 
a more banded effect.
Bleed field: In this field you can specify the amount of bleed you want around your artwork, and crop 
marks will be placed accordingly.

Print Image Box
Clicking on the Image... button inside the Print dialog box will bring up the Print Image dialog box. Inside 
this dialog box you specify the orientation of the artwork image on the final output.
The Normal (On Paper) radio button: Selecting this radio button tells the program to print the artwork as
it would normally.
The Emulsion Down (On Film) radio button: Selecting this radio button tells the program to reflect the 
image in order to get a correct orientation relative to the emulsion side of the film.
The Negative checkbox: Selecting this checkbox tells the program to print the artwork as a negative that
can be used with a phototypesetter.

The Registration Box
This box lets you choose between printing registration marks, crop marks, or the actual color names on 
the color separation sheets. These marks will be printed on each page of the output.
The Registration Marks checkbox: Selecting this checkbox tells the program to print the registration 
marks on your final output.
The Crop Marks checkbox: Selecting this checkbox tells the program to print the crop marks on your 
final output.
The Separation Names checkbox: Selecting this checkbox tells the program to print the color names on
the color separation sheets of you final output. This checkbox will be grayed out if the Color Separation 
option is not selected in the Print dialog box.

Related Topics:



Placing your own Registration and Trim Marks



HPGL Device Options Dialog Box

The HPGL Device Options dialog box allows you to specify the number of pens you have 
available (or want to use), if you have, 
and the Line and Fill Types available, and what they are. You can also specify the buffer 
allocation in order to facilitate the printing of your artwork. When you select an HPGL device from 
the list box on the right side of the dialog box, the default options for that device will be placed 
everywhere else in the dialog box. 
SP Command box: In this box you specify the number of pens you have available, or that you 
want to use. This corresponds directly to the HPGL SP command. 
LT Command: In this box you specify if you have any line types available, and what they are. 
This corresponds directly to the HPGL LT command. 
FT Command: In this box you specify if you have any fill types available, and how many you 
have. This corresponds directly to the HPGL FT command. 
GM Command box: You can also reallocate buffers in order to fill more complicated objects. For 
example, HiJaak Draw handles Pen Sorting, so you can minimize this buffer and maximize the 
Polygon buffer. You can reallocate buffers for the Polygon buffer, Character buffer, Replot buffer, 
Vector buffer, and Pen Sort buffer. These settings cannot exceed the buffer space available on 
your HPGL device. The Reallocate Buffer Information directly links with the HPGL GM command. 
To find out information on your buffer sizes, look up the GM command in your device manual.



Text Block Dialog Box

No Wrap radio button: This option causes text not to wrap around and object but rather to pass 
right over it.
Wrap to Bounds radio button: This option causes text to wrap around an object's bounding box.
Wrap to Shape radio button: This option causes text to wrap around the shape of the object.
Distance field: In this field you enter the distance you want the wrapped text to stay from the 
object it is being wrapped around. The distance is specified in the units of measurement you are 
currently using.
Margins box: This box allows you to set margins for the text block. These margins are the 
distance between the text and the bounding box of the text block.
Related Topics:

Text Block Margins
Wrapping Text Around Objects



Text Block Margins

You can set margins for text blocks. These margins will be the distance between the text and the 
text block's bounding box.

To set margins

1. Create the text block.
2. With the Pointer tool, double click on the text block.

The Text Block Dialog Box appears.
3. In the right hand side of the dialog box, enter the margins you want to use. 
4. When you are finished, click on OK.




